Whats the status of Manjaros Gnome with wayland enabled?

Now that even debian defaults to wayland we should talk once more about Manjaro and if its time to remove that restriction.

Gnome will still default to xorg in case of the NVidia driver. That's a restriction made by Gnome, because EGLStream is still not really supported.

What do you think?

I m not against with this but i need some feedback from our users.. We can remove our restrictions and push an ISO to test...

I have been testing wayland on gnome for weeks, it is not ready. Firefox (any version, including aur fedora wayland) just does not work, Vivaldi works mostly, but is patchy. I must give Fedora a go in a vm, maybe later today.

I think is still early for this, desktop recording now works but available software has not been ported yet to wayland, KDE based editions will probably will have issues, this should only be done when other distributions start moving to wayland not only 2.

firefox works, you could even use set MOZ_ENABLE_WAYLAND=1 so you run native wayland firefox. this one suffers here and there from graphics glitches but is overall also usable. Xwayland Firefox however just works.

Again, even Debian uses it (gnome 3.30!) and there was a loooong talk about it. I think it's ready enough. (I switched with gnome 3.28 on all of my machines btw).

@codesardine it's only gnome, KDE Wayland is not there yet.

1 Like

Does not work for me, fairly standard hardware, reasonably powerful i5.

Firefox can also (or has to?) be compiled with specific Wayland support:
ac_add_options --enable-default-toolkit=cairo-gtk3-wayland

Haven't tried it in ages though.

Nvidia is working on better Wayland support by the way.

I cannot be arsed compiling a browser, my life is too short :smiley:

I will enable it in Plasmafox... maybe in 2045, when Wayland will be ready... :slight_smile:

2 Likes

I dont think we should enforce firefox to use its native wayland backend. the default it can just fine run in xwayland and do the switch when its not an experimental feature anymore :smiley:

btw I dont think Nvidia we will see NVidia as an option for wayland in the near future. Because they would need to maintain the patches by themself in kwin, gnome mutter, sway/wlroots, weston, mir, and every other compositor. Don't think they'll do that.

What happens if you try to run it?

I'm speaking of Plasmafox :wink:
Of course not the default vanilla Firefox.

Nvidia announced better Wayland support (maybe even switching away from EGL) half a year ago or so, I don't know how the situation is currently.
EDIT: the announced "better support" is for KDE only if I remember correctly.

1 Like

Yep, they have created EGLStreams backend for mutter and kwin but nobody works on them since that. at least for gnome they had that one active for a month, it was kind of broken and so NVidia is back on the blacklist. Dont know what KDE will do with this but I don't think they will do the work for Nvidia

Hmm yes in that regard nvidia is not to be trusted.

EGLStreams got merged into Kwin with 5.16 (needs KWIN_DRM_USE_EGL_STREAMS=1).
I don't follow the development so not sure how well it works and what to make of it...

It seems as they all wish to find a successor to both EGLStreams and GBM.

Hm I don't think anyone wants to switch away from GBM. As far as I remember it was only Nvidia who dont wants to use GBM and talked about who not create something thats good for everyone. But at that stage everyone else was already using GBM and nobody wanted to work on something else.

I also couldn't find anything that there is some work done by now or even some talk about something. Do you have anything to read about that situation?

https://www.phoronix.com/scan.php?page=news_item&px=NVIDIA-KDE-KWin-EGLStreams-POC
https://www.phoronix.com/scan.php?page=news_item&px=EGLStreams-Merged-KWin-5.16

(off topic now, this should be about Gnome, sorry... :slight_smile: )

Sorry, had to nip out.

See the bug report in my post above. I am trying the MOZ setting you gave me earlier to see if that makes any difference.

Will report back.

So far distros with default-to-wayland support on gnome:

  • ArchLinux
  • Fedora
  • Debian
  • OpenSuse Tumbleweed (pretty sure also the latest stable, but unable to test this)
  • Mageia

things I know that do not work with wayland are:

  • you cant use xprop and other tools to set your resolution
  • no teamviewer support
  • for screencapture you have to use gnome tools right now (no OBS for example)
  • no root-window support sudo firefox and such will not work anymore
  • Firefox touch support does not work (execpt if you enable experimental native wayland support via MOZ_ENABLE_WAYLAND=1)
  • ?
1 Like

This is a bugreport about a firefox-wayland-native feature. Thats experimental and so not active by default. firefox on wayland will still run in xorg mode (called xwayland)

If you enable this, you will hit this problem from your bugreport, because thats the setting to switch to experimental wayland-native support of firefox :wink:

I was getting the problem within 10-15 minutes on:

  • Firefox (normal from repo)

  • FF Develper (ditto)

  • FF Fedora wayland (aur)

It has been 12 minutes so far, but I am not using the browser heavily, I am trying to find a film to watch on Netflix :exploding_head: