What would the Manjaro Community dream about KDE?

kde

#123

You’ld be suprised at all the hurdles that need to be worked out for a wayland session to work well.
Not on the plasma and/or wayland side mind you, but for other things, like x11 only apps (xwayland) that need root access, etc. etc. Untill these kinds of apps start using policykit properly, the work arounds IMHO are a security risk at best.


#124

Root apps are always a security risk. But there shouldnt be many apps who require that today.


#125

Well, that’s not the only issue, but it is a big one. I prefer not to use workarounds by default if at all possible, especially ones that could potentially introduce a security risk. Themes between widget sets are another major issue ATM under wayland.


#126

Huh whats wrong with them?


#127

They do not get applied.
The workaround is to run gtk apps in xwayland sessions under plasma, and vice versa, not a good compromise if you ask me. I should know, trying to get GTK+3 and Qt5 apps too look right under Enlightenment has the same issue, have to run them under xwayland sessions for the themes to apply.
GTK+2 and Qt4 apps run under x (xwayland) by default anyway, so not an issue.


#128

Ohh didnt knew that. :thinking: I only run Qt apps with standard design, thats why. :joy:


#129

Uh, Glad i read this. Over recent days i had begun pondering [given i seem to see “Wayland” mentioned left right & centre online these days] if maybe i should begin investigating what i would need to do to try W on my Tower, & what risk that might imply to my present installation. Basically so i could see what all the Wayland buzz seems to be about. However reading your posts here means i won’t take that idea any further for now, i think. Thanks.


#130

I wanted to reply earlier, but got sidetracked by some phone-calls from clients.
You can test wayland also this way (not quite the best way, but is fun)

export KWIN_COMPOSE=Q
export $(dbus-launch)
kwin_wayland --libinput --xwayland "plasmashell --platform wayland"

and you will have a new session in a window.
For some reason mine crashes and i can’t log normally in plasma-wayland-session. My guess is that i do something wrong. I forget some stuff etc … :slight_smile:


#131

Upstream plasma 5.13 no longer sets QT_QPA_PLATFORM to wayland by default, thus your QT5 applications are using the xcb platform plugin and not the wayland platform plugin.


#132

Sad but understandable. Better run xwayland for now than have crashing apps all around. If the change will come with Qt5.11 I don’t see a big problem.

I have tried the Wayland session now and it’s really smooth. Theme changes for gtk apps also work, if you restart the gtk app after the change. Something I also have to do on the xorg session. It’s exactly alike. Drag and drop is right now a thing that doesn’t work the way it needs to but other than that it already feels nice.


#133

For theme-lovers, we have now our first version of Adapta-Breath ready for KDE:

sudo pacman -U https://manjaro.moson.eu/pool/overlay/plasma5-theme-adaptabreath-0.1-1-any.pkg.tar.xz


#134

Just tried this in a VM. It is lovely, well done.

Confession: I did have to “Oxygenate” part of it… been using Oxygen too long to just go cold-turkey instantly. :laughing:


#135

Very nice Plasma theme, it remids me an old good one named Carbon that was created when KDE 4 and Plasma itself were just a new buggy and eyecandy thing to almost all Linux users.
Adapta styled kvantum part and colours are, from the other side, uh… I’d better stay with Breath/Breeze (just my opinion).
Thanks for your work guys!

EDIT: This theme is just amazing!
But as far as new themes are concerned, I wonder why several system icons haven’t received attention? I mean Manjaro Settings Manager and Octopi of course.
Screenshot_20180714_212642


#136

Sorry, not my theme. It clashes with my bright Breeze setup since it is a dark theme.


#137

There are both light and dark options, Adapta Breath and AdaptaBreathLuna.


#138

I only saw the dark one in the KDE settings so I did not use it. In Look & Feel there was one item added and that was the dark theme. Will have another look at it. Thanks.


#139

Its me doing it:
AdaptaBreath Theme WIP
I had a burst of time a few days ago - but I dont consider it ‘final’ yet.
Especially the “Luna” variant as its more of a full rewrite than the other AdaptaBreath parts.
Please drop by the thread to point things out and/or make suggestions :slight_smile:


#140

There is firefox-kde-opensuse:

https://aur.archlinux.org/packages/firefox-kde-opensuse/

It has both kde patch and ubuntu menu patch and few other ones. When building it’s rather advised to disable pgo patch which uses some old packages and increase time of the build enormously.

As to my wishes to Manjaro KDE, it works quite nicely but I would like to see it with mentioned above firefox-kde-opensuse and thunderbird with unity/ubuntu patch and opensuse patches…

Alas, I know it’s not that easy because this would require a lot of effort of building packages so that’s unlikely. However… There is bin version of firefox but meant for arch hence pgp keys don’t match with Manjaros. Can we add it so everyone could easily install it from AUR?:

https://aur.archlinux.org/packages/firefox-kde-opensuse-bin/

With Thunderbird it’s a tougher issue. It’s more tricky to build and we have only version with global menus:

https://aur.archlinux.org/packages/thunderbird-appmenu/

Here are the screens of firefox-kde-opensuse and thunderbird-appmenu running on Manjaro:

The only con of that is that AWC is not working correctly with FF and TB menus so you have to use system widget for that.

KDE dialogs work well on this FF and it would be even more awesome to have them on TB since they are more often used there.


#141

No, we do not add AUR packages to our install media, especially unverifiable binary builds.
I’m not aware of this being done on the community editions, however if it is, that is not the way to do things. Maintainers of community editions, and/or third party spins, should have their needed packages either in their own on-line repository, or added to the official repositories.
Adding packages to the repository requires a maintainer to keep them up-to-date.
As stated before, these were already dropped for good reason, and rehashing it is counter productive.


#142

Yeah, I know that, still, this is a thing that I would wish was added to Manjaro KDE. It may not be possible or reasonable right now but who knows, maybe some day? Maybe arojas will decide to ship those? It’s a slim chance but for the sake of integration? Or maybe firefox finally fixes this absurd no-dbus exposing for menu. There is global menu on mac, why isn’t it added on Linux? Nowadays most DEs ship with global menus and they all use similar ways to make it work.

As to KDE dialogs… FF could add it as well. Somehow there is no problem with Chromium or Chrome which use KDE dialogs. FF is open source and yet it feels like foreign app and since TB is using it code, it’s inheriting this absurd state.