What is command to install Git on manjaro linux?

What is command to install Git on manjaro linux?

sudo pacman -S git
or
pamac install git

https://wiki.manjaro.org/index.php?title=Pacman_Overview

1 Like

I will also add that if you want to use command-line and search for a package then you can use
pacman -Ss git
then after you find your correct package...
sudo pacman -S packagename

1 Like

pamac worked. Thanks!

sudo kept asking me for a sudo password

Hi cscs I am still struggling .. but making progress!

which it should.
sudo is required to 'elevate priveleges' and asks you a password to see if you have rights..
(some applications are 'smarter' and ask you even if you do not use sudo .. but the same thing is happening)
Such things should be asked for anything interacting with the system or root ( / ).

2 Likes

As far as I know, so does pamac. I would think it would be bad if it didn't.

Do you not know the password?

1 Like

The password to log into manjaro does not work using sudo.

Pamac worked fine.

I think pamac is polkit compliant.
[which would mean it more dynamically accepts users and groups]
pacman is a bit more old-school.
[also if you at some point entered the correct password then sudo wouldnt bother you from within the same terminal for 5 minutes or so]

But yes - in some cases you may have set an admin/sudo password differently from your user password.

um... as a Linux user... if sudo isn't working... you're gonna have to figure out why because sudo is usually used a lot...

And yes @realmain is correct .. if you cannot access sudo then you need to figure that out ...

Tracking it down now..

thanks!

sudo is not needed for Pamac CLI, and Pamac CLI wont work if you try to install a AUR package with sudo pamac build.

As cscs said, it uses polkit to get elevated privileges when required. You get a prompt that is similar to the usual dialog box you get when a GUI program needs elevated privileges. See this example.

[awesome@i56400 ~]$ pamac install lollypop
==== AUTHENTICATING FOR org.manjaro.pamac.commit ====
Authentication is required
Authenticating as: Awesome (awesome)
Password: 
==== AUTHENTICATION COMPLETE ====
Synchronizing package databases...
Refreshing DEB_Arch_Extra.db...
Choose optional dependencies for lollypop:                                      
1:  easytag: Modify tags
2:  kid3-qt: Store covers in tags
3:  python-pylast: Last.FM support
4:  python-wikipedia: Wikipedia support

Enter a selection (default=none): 

Preparing...
Resolving dependencies...
Checking inter-conflicts...
To install (3):
  lollypop               1.1.4.5-1    community  423.4 kB
  python-beautifulsoup4  4.7.1-1      community  155.7 kB
  python-soupsieve       1.9.2-1      community  60.0 kB

Total download size: 639.1 kB
Total installed size: 3.8 MB
Apply transaction ? [y/N] n

Transaction cancelled.

(Yes, polkit is usable in a command-line interface. You get a similar thing if you use systemctl without sudo in TTY.)

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.