What has happened to systemd-timesyncd?

What has happened to systemd-timesyncd ? Which as I understand it is needed to auto set network time setting.

What do you mean?
It exists and is provided by systemd as usual.
Though ‘needed’ is a bit strong … its one of the options for network time sync.
ex: [HowTo] Automatically sync timezone, date, time with minimal overhead

systemd-timesyncd command not found. I think it’s been removed?
Found how to do it sudo timedatectl set-ntp 1

There is no such command.

systemctl enable --now systemd-timesyncd.service
1 Like

Well there used to be it was included in manjaro tools
enable_systemd=(‘avahi-daemon’ ‘bluetooth’ ‘cronie’ ‘NetworkManager’ ‘cups’ ‘irqbalance’ ‘preload’ ‘cpupower’ ‘thermald’)
it used to be in this list I’ve removed it but I bet it is still in other profile.conf

It’s not in your $PATH then.
The binary came with systemd package:

$ pacman -F systemd-timesyncd
core/systemd 255.4-2 [installed]
$ pacman -Qo /usr/lib/systemd/systemd-timesyncd
/usr/lib/systemd/systemd-timesyncd is owned by systemd 255.4-2

systemd-timesyncd.service still exists and uses it:

$ systemctl cat systemd-timesyncd.service  | grep ExecStart

Those look like service names to enable rather than commands to execute?

1 Like

They are but the point is systemd-timesyncd was and probably still is included in that list in manjaro-tools but calamares can’t do it. This is probably as you say systemd-timesyncd is not in its path.
Interesting sudo /usr/lib/systemd/systemd-timesyncd falls over

It doesn’t need to be on the PATH because this executable will never (or rather should) be run manually.
The service will run it for you.

1 Like

I agree that’s what I did and it works but who is going to remove it from Profile.conf?


The profile.conf files line you reference is for systemd units. Not executables.
It does not need to be removed.

All of these are services.
systemctl status bluetooth.service etc etc.

1 Like