Weird keyboard layout

Besides English I want also Latvian keyboard layout. Settings → Keyboard → Layout → Keyboard layout → Add → Latvian. None of the options (adapted, apostrophe, ergonomic, F, modern) return Latvian.
Latvian alphabet goes like A, Ā , B, C, Č, D, E, Ē …
But in Manjaro the result is A, Æ, B, C, ©, D, E, E
Locale: lv_LV.UTF-8 (seen in bottom right at login screen)
Any idea how to get necessary keyboard layout?

Edit: Oh no! Latvian is partly as system language, though I wanted to change only keyboard layout.
Edit2: Thanks to Manjaro Settings Manager now system is displayed in English.

Your locale can stay English, no need to change that.

After this click on Change layout option and select Both Ctrl together . This option should switch to Latvian keyboard layout, when you press them.

Also if you haven’t enable it from the panel, so that you can see when you change the layout.

This must be a font problem. Try changing the font.

Thanks a lot! I missed the change layout option. With that set Latvian layout does work. Only don’t see any indicator of active keyboard layout.

Go to settingspanelitemsclick add and search for Keyboard layout .

Whoa! Manjaro is the dream! Thanks GokuSan!

No problem. Can you please mark my first post here as a solution ??
So others with same problem can find the answer easy.

Click the 3 dots below the answer to mark a solution like this below the answer:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

Cheers… :beers:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.