Weird hibernation behavior - works as it should only first time after powering on laptop

I configured hibernation according to this Arch wiki article. And here is the problem I have:
When I power on my laptop, do some work, click “Hibernate” - everything works as it should. My machine completely shuts down and after pressing power button once again it correctly restores saved session BUT if after some additional work I click “Hibernate” once again it just turns off my display and that’s it. Fan is spinning, wi-fi led is still on. If I move muse/press any key - display turns on and there is lock screen. After logging in everything looks the same way it was when I left it with only one difference - networking is disabled and I can’t enable it (wi-fi led is still on). It starts working correctly only after rebooting. And after rebooting once again I can perform only one correct cycle of hibernation - correct shutting down and session restoration.

Please help me fix this because correct hibernation is a major part of my workflow.

Here are the steps I did while configuring hibernation:

  1. Updated my etc/default/grub file to correctly point to swap file


  1. Updated my /etc/mkinitcpio.conf file, so that hooks line looks like this:

HOOKS=“base udev resume autodetect modconf block keyboard keymap filesystems fsck”

  1. Updated my /etc/systemd/sleep.conf file - by uncommenting and editing this line to properly shut down machine (before that it was platform shutdown):


  1. Updated grub and mkinitcpio.conf:

sudo mkinitcpio -P && sudo update-grub

Also adding my inxi output:

  Kernel: 5.10.59-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 
  root=UUID=dca2d871-d8a3-4ae4-8d42-84415237cf26 rw 
  resume=UUID=1336917e-4355-4c52-8419-74e48e61e9ab quiet apparmor=1 
  security=apparmor resume=UUID=1336917e-4355-4c52-8419-74e48e61e9ab 
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: xfce4-panel wm: xfwm 4.16.1 vt: 7 
  dm: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux 
  Type: Portable System: Dell product: Studio 1537 v: A11 serial: <filter> 
  Mobo: Dell model: 0P132H v: A11 serial: <filter> BIOS: Dell v: A11 
  date: 04/14/2011 
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse M315/M235 
  serial: <filter> charge: 55% (should be ignored) rechargeable: yes 
  status: Discharging 
  RAM: total: 1.93 GiB used: 1.36 GiB (70.5%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: Dual Core model: Intel Core2 Duo P8400 bits: 64 type: MCP arch: Penryn 
  family: 6 model-id: 17 (23) stepping: 6 microcode: 60F cache: L2: 3 MiB 
  bogomips: 9049 
  Speed: 798 MHz min/max: 800/2267 MHz Core speeds (MHz): 1: 798 2: 798 
  Flags: acpi aperfmperf apic arch_perfmon bts clflush cmov constant_tsc cpuid 
  cx16 cx8 de ds_cpl dtes64 dtherm dts est fpu fxsr ht lahf_lm lm mca mce mmx 
  monitor msr mtrr nopl nx pae pat pbe pdcm pebs pge pni pse pse36 pti 
  rep_good sep smx sse sse2 sse4_1 ssse3 syscall tm tm2 tsc vme xtpr 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX unsupported 
  Type: l1tf mitigation: PTE Inversion 
  Type: mds 
  status: Vulnerable: Clear CPU buffers attempted, no microcode; SMT disabled 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass status: Vulnerable 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 
  mitigation: Full generic retpoline, STIBP: disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: AMD RV620/M82 [Mobility Radeon HD 3450/3470] vendor: Dell 
  driver: radeon v: kernel bus-ID: 01:00.0 chip-ID: 1002:95c4 class-ID: 0300 
  Device-2: Ricoh Integrated Webcam type: USB driver: uvcvideo bus-ID: 1-6:3 
  chip-ID: 05ca:18a0 class-ID: 0e02 serial: <filter> 
  Display: x11 server: X.Org 1.20.13 compositor: xfwm4 v: 4.16.1 driver: 
  loaded: ati,radeon unloaded: modesetting alternate: fbdev,vesa 
  display-ID: :0.0 screens: 1 
  Screen-1: 0 s-res: 1280x800 s-dpi: 96 s-size: 338x211mm (13.3x8.3") 
  s-diag: 398mm (15.7") 
  Monitor-1: LVDS res: 1280x800 hz: 60 dpi: 98 size: 331x207mm (13.0x8.1") 
  diag: 390mm (15.4") 
  OpenGL: renderer: AMD RV620 (DRM 2.50.0 / 5.10.59-1-MANJARO LLVM 12.0.1) 
  v: 3.3 Mesa 21.1.6 compat-v: 3.0 direct render: Yes 
  Device-1: Intel 82801I HD Audio vendor: Dell driver: snd_hda_intel v: kernel 
  bus-ID: 00:1b.0 chip-ID: 8086:293e class-ID: 0403 
  Device-2: AMD RV620 HDMI Audio [Radeon HD 3450/3470/3550/3570] vendor: Dell 
  driver: snd_hda_intel v: kernel bus-ID: 01:00.1 chip-ID: 1002:aa28 
  class-ID: 0403 
  Sound Server-1: ALSA v: k5.10.59-1-MANJARO running: yes 
  Sound Server-2: JACK v: 1.9.19 running: no 
  Sound Server-3: PulseAudio v: 15.0 running: yes 
  Sound Server-4: PipeWire v: 0.3.33 running: no 
  Device-1: Broadcom BCM4312 802.11b/g LP-PHY 
  vendor: Dell Wireless 1397 WLAN Mini-Card driver: wl v: kernel modules: ssb 
  port: 2000 bus-ID: 04:00.0 chip-ID: 14e4:4315 class-ID: 0280 
  IF: wlp4s0 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  Device-2: Broadcom NetLink BCM5784M Gigabit Ethernet PCIe vendor: Dell 
  driver: tg3 v: kernel port: 2000 bus-ID: 08:00.0 chip-ID: 14e4:1698 
  class-ID: 0200 
  IF: enp8s0 state: down mac: <filter> 
  WAN IP: <filter> 
  Message: No bluetooth data found. 
  Message: No logical block device data found. 
  Message: No RAID data found. 
  Local Storage: total: 232.89 GiB used: 10.65 GiB (4.6%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda maj-min: 8:0 vendor: Hitachi model: HTS543225L9A300 
  size: 232.89 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s 
  type: HDD rpm: 5400 serial: <filter> rev: C40C scheme: MBR 
  Optical-1: /dev/sr0 vendor: TSSTcorp model: DVD+-RW TS-T633A rev: D300 
  dev-links: cdrom 
  Features: speed: 24 multisession: yes audio: yes dvd: yes 
  rw: cd-r,cd-rw,dvd-r,dvd-ram state: running 
  ID-1: / raw-size: 228.63 GiB size: 223.98 GiB (97.97%) used: 9.89 GiB (4.4%) 
  fs: ext4 dev: /dev/sda1 maj-min: 8:1 label: N/A 
  uuid: dca2d871-d8a3-4ae4-8d42-84415237cf26 
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 4.25 GiB used: 777.5 MiB (17.8%) 
  priority: -2 dev: /dev/sda2 maj-min: 8:2 label: N/A 
  uuid: 1336917e-4355-4c52-8419-74e48e61e9ab 
  Message: No unmounted partitions found. 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 6 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 1-6:3 info: Ricoh Integrated Webcam type: Video driver: uvcvideo 
  interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 100mA chip-ID: 05ca:18a0 
  class-ID: 0e02 serial: <filter> 
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 6 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Hub-3: 3-0:1 info: Full speed (or root) Hub ports: 2 rev: 1.1 speed: 12 Mb/s 
  chip-ID: 1d6b:0001 class-ID: 0900 
  Hub-4: 3-1:2 
  info: Broadcom BCM2046B1 USB 2.0 Hub (part of BCM2046 Bluetooth) ports: 3 
  rev: 2.0 speed: 12 Mb/s power: 94mA chip-ID: 0a5c:4500 class-ID: 0900 
  Device-1: 3-1.1:3 info: Dell Integrated Keyboard type: Keyboard 
  driver: hid-generic,usbhid interfaces: 1 rev: 2.0 speed: 12 Mb/s power: 2mA 
  chip-ID: 413c:8157 class-ID: 0301 
  Device-2: 3-1.2:4 info: Dell Integrated Touchpad / Trackstick type: Mouse 
  driver: hid-generic,usbhid interfaces: 1 rev: 2.0 speed: 12 Mb/s power: 2mA 
  chip-ID: 413c:8158 class-ID: 0301 
  Hub-5: 4-0:1 info: Full speed (or root) Hub ports: 2 rev: 1.1 speed: 12 Mb/s 
  chip-ID: 1d6b:0001 class-ID: 0900 
  Hub-6: 5-0:1 info: Full speed (or root) Hub ports: 2 rev: 1.1 speed: 12 Mb/s 
  chip-ID: 1d6b:0001 class-ID: 0900 
  Hub-7: 6-0:1 info: Full speed (or root) Hub ports: 2 rev: 1.1 speed: 12 Mb/s 
  chip-ID: 1d6b:0001 class-ID: 0900 
  Hub-8: 7-0:1 info: Full speed (or root) Hub ports: 2 rev: 1.1 speed: 12 Mb/s 
  chip-ID: 1d6b:0001 class-ID: 0900 
  Device-1: 7-1:2 info: Logitech Unifying Receiver type: Keyboard,Mouse,HID 
  driver: logitech-djreceiver,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s 
  power: 98mA chip-ID: 046d:c52b class-ID: 0300 
  Hub-9: 8-0:1 info: Full speed (or root) Hub ports: 2 rev: 1.1 speed: 12 Mb/s 
  chip-ID: 1d6b:0001 class-ID: 0900 
  System Temperatures: cpu: 45.0 C mobo: 45.0 C 
  Fan Speeds (RPM): cpu: 3227 fan-2: 3232 
  Processes: 176 Uptime: 1h 25m wakeups: 3 Init: systemd v: 248 
  tool: systemctl Compilers: gcc: 11.1.0 Packages: pacman: 1020 lib: 283 
  flatpak: 0 Shell: Bash v: 5.1.8 running-in: xfce4-terminal inxi: 3.3.06```

Some applications (VLC, Spotify, qBittorrent, …) can disable hibernate mode!



Thanks for the reply!

Hm, nice to know that.
Nothing special actually. Was just running Firefox with few tabs, thunar file manager and build-in sticky note app to make sure my 4Gb swap file will be enough and also to test it.

Well, in the first place my hibernation didn’t work at all. When I clicked “Hibernate” I just got black screen with laptop still being on. So according to "Troubleshooting" section from mentioned above Arch wiki article I edited it and it indeed helped to some extent (at least now I can have just one working cycle of proper hibernation)

In that case,

Upgrade your BIOS first, then report back. (FMI: downgrading kernel is next)

I’m afraid that’s not possible - this is the latest bios available for this model (which I bought back in 2009)

  • Execute:

    sudo mhwd-kernel --install linux54
  • to ensure grub is showing, execute:

    sudo nano --backup /etc/default/grub
  • Change (or add?) the following 3 lines:


    (3 or higher is fine, add the # before the lines above if those lines are present)

  • Ctrl+X Y Enter to save if there is anything to save

  • If you did save, execute:

    sudo update-grub
  • Reboot

  • Go to grub’s Advanced options

  • Choose the 5.4 kernel and see if that helps?


Ok, today a had time to test this so I’m reporting back:
I switched kernel as you suggested and first time I tried to hibernate - I got regular black screen with laptop still running on and no internet after logging in again.
I reverted /etc/systemd/sleep.conf to be:

HibernateMode=platform shutdown

and it worked.

Afterwards tried a bunch of times to hibernate/wake up system and only once mentioned in my original post problem occurred.

The thing is this 5.4 kernel gives me also additional problems:

  1. Each time I click “Log Out” button I hear very loud annoying beep sound coming from motherboard, which I can’t turn off.
    (tried this suggestion, but it didn’t do anything)
  2. Each time I hibernate there is this error on the screen:

Those are BIOS issues and as you can’t upgrade it any more because your machine is too old the only options you have right now is:

  • Live with these issues
  • Buy a new machine


Therefore, I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back to your question after your issue has been solved and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.