Weird freezes when playing certain games / How to make a log for this issue?

Hey there,

first off, I'd like to apologize if this has been asked somewhere. I didn't find a topic that comes close to my problem.

I switched to Manjaro (KDE) about a year ago now and it feels great in general. Usually every game works without problems and there are barely any inconveniences. However, every now and then, when playing certain games, I get a strange freeze of my whole computer when a specific "event" is triggering in games. These are (at least for now) only popping up when playing games per WINE / Proton.

Examples for these are:
Wolcen: When a reward window is popping up, my whole OS freezes.
We Were Here Together: Loading into the second level is also freezing my whole OS.

Now, when I say "freeze my OS", I really mean completely frozen. Sometimes I am able to resolve it by opening a terminal (Yakuake, Ctrl + Alt + T). The terminal is scrolling down then, like... very VERY slowly. It looks like 1 frame per 10 seconds. By then very slowly typing in htop and killing the task, I can use my computer again. While in this "frozen" state, I also cannot use Ctrl + Alt + F2 to switch to another terminal. It just won't respond, at all.

I know that I am probably not enough giving enough information here to resolve it, therefore I'd like a suggestion of how to log all of this.

Here's my system information:

System:    Host: foregone-pc Kernel: 5.4.18-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.0 Desktop: KDE Plasma 5.17.5 
           Distro: Manjaro Linux 
Machine:   Type: Desktop System: Micro-Star product: MS-7A32 v: 1.0 serial: <root required> 
           Mobo: Micro-Star model: X370 GAMING PRO CARBON (MS-7A32) v: 1.0 serial: <root required> UEFI: American Megatrends 
           v: 1.90 date: 09/20/2017 
CPU:       Topology: 8-Core model: AMD Ryzen 7 1800X bits: 64 type: MT MCP arch: Zen rev: 1 L2 cache: 4096 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 115234 
           Speed: 1887 MHz min/max: 2200/3600 MHz Core speeds (MHz): 1: 2026 2: 2434 3: 1886 4: 1884 5: 1884 6: 1885 7: 1886 
           8: 1891 9: 1873 10: 1852 11: 1854 12: 1879 13: 1874 14: 1833 15: 1885 16: 1875 
Graphics:  Device-1: NVIDIA GM204 [GeForce GTX 980] vendor: Micro-Star MSI driver: nvidia v: 435.21 bus ID: 24:00.0 
           Display: x11 server: X.Org 1.20.7 driver: nvidia resolution: 1920x1080~60Hz, 1920x1080~60Hz 
           OpenGL: renderer: GeForce GTX 980/PCIe/SSE2 v: 4.6.0 NVIDIA 435.21 direct render: Yes 
Audio:     Device-1: Creative Labs Sound Core3D [Sound Blaster Recon3D / Z-Series] driver: snd_hda_intel v: kernel 
           bus ID: 21:00.0 
           Device-2: NVIDIA GM204 High Definition Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel 
           bus ID: 24:00.1 
           Device-3: Yamaha type: USB driver: snd-usb-audio bus ID: 5-2.1:4 
           Sound Server: ALSA v: k5.4.18-1-MANJARO 
Network:   Device-1: Intel I211 Gigabit Network vendor: Micro-Star MSI driver: igb v: 5.6.0-k port: f000 bus ID: 1e:00.0 
           IF: enp30s0 state: up speed: 1000 Mbps duplex: full mac: 4c:cc:6a:fd:55:48 
Drives:    Local Storage: total: 2.52 TiB used: 723.41 GiB (28.1%) 
           ID-1: /dev/sda vendor: Samsung model: SSD 840 PRO Series size: 238.47 GiB 
           ID-2: /dev/sdb vendor: Samsung model: SSD 850 PRO 512GB size: 476.94 GiB 
           ID-3: /dev/sdc vendor: Seagate model: ST32000641AS size: 1.82 TiB 
Partition: ID-1: / size: 233.43 GiB used: 81.57 GiB (34.9%) fs: ext4 dev: /dev/sda2 
Sensors:   System Temperatures: cpu: 44.8 C mobo: N/A gpu: nvidia temp: 51 C 
           Fan Speeds (RPM): N/A gpu: nvidia fan: 0% 
Info:      Processes: 314 Uptime: 8m Memory: 15.65 GiB used: 2.31 GiB (14.7%) Init: systemd Compilers: gcc: 9.2.0 
           clang: 9.0.1 Shell: bash v: 5.0.11 inxi: 3.0.37 

After it happens, you might tray journalctl -xe or sudo dmesg and see if anything interesting pops up in that. Otherwise, try running the game from a terminal. Since yakuake slows down, you might use konsole to launch the games in. If you're using Lutris, try the -d command line switch. Also, lutris will show you the last wine log if you click the logs button (second from the right under the play/stop button in the right hand pane.

So, I tried to fiddle a bit around with my settings and with what I have opened.

For whatever reason, it seems that Firefox is causing this issue. When I leave it open while playing a game (in this case Wolcen), it is crashing at said moments. When it is closed, it doesn't.

I will try some more combinations tomorrow. Getting late here.

The only interesting thing that dmesg is giving me now, when this error occurs, is this one (marked the critical ones with a "!"):

 [34253.185577] audit: type=1105 audit(1581728731.131:114): pid=12097 uid=1000 auid=1000 ses=3 subj==unconfined msg='op=PAM:session_open grantors=pam_limits,pam_unix,pam_permit acct="root" exe="/usr/bin/pkexec" hostname=? addr=? terminal=? res=success'
![34535.760462] NVRM: Xid (PCI:0000:24:00): 31, pid=837, Ch 00000056, intr 10000000. MMU Fault: ENGINE GRAPHICS GPCCLIENT_RAST faulted @ 0x0_00000000. Fault is of type FAULT_PDE ACCESS_TYPE_WRITE
![34722.319654] GpuWatchdog[32546]: segfault at 0 ip 00007f018f11921d sp 00007f01845f8510 error 6 in libcef.so[7f018b393000+69a4000]
 [34722.319661] Code: 00 79 09 48 8b 7d a0 e8 e1 7f c1 02 41 8b 85 00 01 00 00 85 c0 0f 84 ab 00 00 00 49 8b 45 00 4c 89 ef be 01 00 00 00 ff 50 58 <c7> 04 25 00 00 00 00 37 13 00 00 c6 05 a1 a5 37 03 01 80 bd 7f ff
 [34722.319707] audit: type=1701 audit(1581729200.278:115): auid=1000 uid=1000 gid=1000 ses=2 subj==unconfined pid=32542 comm="GpuWatchdog" exe="/home/foregone/.local/share/Steam/ubuntu12_64/steamwebhelper" sig=11 res=1
 [34722.340332] audit: type=1130 audit(1581729200.302:116): pid=1 uid=0 auid=4294967295 ses=4294967295 subj==unconfined msg='unit=systemd-coredump@4-12896-0 comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'

I think libcef.so is the Chromium Embeded Framework so do you have any apps that use Electron? They might be involved in this issue.
NVRM: Xid messages come from the driver. There is some info here.

Searching for the GPCCLIENT_RAST brought up this dxvk issue that's been fixed (It was a driver bug). I would monitor memory while you're playing the game, GPU and main memory if you can. Might be there's a leak somewhere. Sorry I can't help you directly with this.

1 Like

The only thing I have, that relies on Electron, is Riot (riot-desktop). Though I didn't start it for several days now. Riot depends on directly on electron. There is no other dependency to it.

Unfortunately I couldn't test anything today because the game servers are down. Will post an update as soon as I get one.

Again. I believe the problem is Firefox in this case, as the problem only appeared when I left it open while playing the game. Gonna see what happens when I try that the next one or two days.

Also: Thank you very much for helping me out here! It's hard to find support for those things! Kudos!

So... apparently it wasn't Firefox. It seems to come down to "just luck".

I tried every combination of two Linux kernels, two GPU drivers and opened and / or closed programs. It is just random.

One time I am starting my PC and nothing else than Steam >>> It works
Next time it doesnt. However I found someone with the same problem in Overwatch. For him it says ACCESS_TYPE_READ instead of ACCESS_TYPE_WRITE.

Again, one of these two errors seem to be the issue here:
[ 850.592871] GpuWatchdog[3025]: segfault at 0 ip 00007f52866a921d sp 00007f527bb88510 error 6 in libcef.so[7f5282923000+69a4000]
[ 2676.967412] NVRM: Xid (PCI:0000:24:00): 31, pid=785, Ch 00000036, intr 10000000. MMU Fault: ENGINE GRAPHICS GPCCLIENT_RAST faulted @ 0x0_00000000. Fault is of type FAULT_PDE ACCESS_TYPE_WRITE

I have no clue though where it comes from. It also seems random which one of those appear. Sometimes it's the libcef.so stuff, sometimes the Engine Graphics fault.

Anyone got a clou about this?

Forum kindly sponsored by