Weird change in / folder after failed kernel update

I’m using Manjaro XFCE for a few months with no problems.
My system is divided in 3 partitions + swap (sda1 for /boot/efi in fat32, sda3 for / and sda4 for /home, both in btrfs)
Today I was updating my system, and there was a kernel update (no problem, I’ve done before with no stress), but during the update process, there was a energy shortage in my house for a few minutes and my computer turned off.
After I try to turn it on, there was a bug in my grub, trying to find the vmlinuz image.
“All right, a grub problem, just use a live ISO and solve it, no problem at all, done that before”
In the live ISO, I found something weird.
My / partition was different, with only 3 folders: @/, @cache/ and @log/
I tried to find anything about it online and nothing appeared, looked the @/ folder and it had all my / files.
“All right, let’s ignore those other folders and try chroot in the @/ folder, finish the update and make grub new again”
Well, tried a few tutorials and nothing solved.
“It seems that it’s just cache and logs, I’ll remove them and move all @/ folder to the original folder and try again”
Tried the tutorials again and nothing solved.
Re-install the 5.13 kernel, created new initramfs, uptaded grub, reinstaled grub and nothing solved.
In my /boot mounted in the live ISO, there was the vmlinuz, but in my /boot during initialization, there wasn’t.
In start up, grub was looking for a vmlinuz in @/boot.
Tried changing the grub root and prefix to the / partition, but it still not working.
After everything, I decided to reinstall manjaro without formating my /home partition and everything went back to normal (except my programs, but that’s an easy fix).
I’m just sharing my weird adventure with a / folder renamed to @/ and, apparently, nobody in the internet had it before (I looked really hard trying to find why and how to solve this, but I couldn’t find anywhere)

Welcome to the forum!

Then you didn’t look as hard as you think you did. :stuck_out_tongue:

Had you read the manual for btrfs, then you would have known that btrfs always creates at least one subvolume in every partition, named @. This subvolume is the root subvolume, in which other subvolumes can be created (like subdirectories). Next to the root subvolume, you can also have other subvolumes which can be mounted to subdirectories of /, or which can remain unmounted.

Apparently your power outage messed up GRUB in some way, and GRUB was looking for the kernel image in the wrong place.

Please read the btrfs manual(s) and you will be enlightened. :wink:


I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back to your question after your issue has been solved and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.