Weird behavior of KDE at start-up

Good morning everyone

I was installing Manjaro KDE yesterday, after using GNOME for a while (clean install).

What I have noticed is that every time I boot up the laptop, the drop down terminal is open. Don’t know why the behavior is like that.
I have also noticed that if I forget to close any application (file manager, thunderbird, etc) before turning the computer off or rebooting, these applications are always open on the next boot.

I do not get this behavior in GNOME or XFCE (knowing drop down terminal isn’t in GNOME).

I have been trying to find this on the internet, but I suspect that I haven’t worded my search well enough yet.

[olividir@HP ~]$ inxi -Fzzzxa -no-host
System:    Host: HP Kernel: 5.8.6-1-MANJARO x86_64 bits: 64 compiler: N/A 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 
           root=UUID=f90c1ec5-7cd7-47fb-bf4b-d2eb2320d764 rw quiet apparmor=1 
           security=apparmor udev.log_priority=3 
           Desktop: KDE Plasma 5.19.5 tk: Qt 5.15.0 wm: kwin_x11 dm: SDDM 
           Distro: Manjaro Linux 
Machine:   Type: Laptop System: HP product: HP Pavilion Gaming Laptop 15-cx0xxx 
           v: Type1ProductConfigId serial: <filter> Chassis: type: 10 serial: <filter> 
           Mobo: HP model: 8478 v: 70.57 serial: <filter> UEFI: Insyde v: F.22 
           date: 04/21/2020 
Battery:   ID-1: BAT1 charge: 38.0 Wh condition: 37.4/52.8 Wh (71%) volts: 12.8/11.6 
           model: Hewlett-Packard PABAS0241231 type: Li-ion serial: <filter> status: Unknown 
CPU:       Topology: Quad Core model: Intel Core i5-8300H bits: 64 type: MT MCP 
           arch: Kaby Lake family: 6 model-id: 9E (158) stepping: A (10) microcode: D6 
           L2 cache: 8192 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 36812 
           Speed: 3984 MHz min/max: 800/4000 MHz Core speeds (MHz): 1: 3998 2: 3990 3: 3993 
           4: 3966 5: 3983 6: 3984 7: 3981 8: 3987 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf 
           mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass 
           mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 
           mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, 
           STIBP: conditional, RSB filling 
           Type: srbds mitigation: Microcode 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel UHD Graphics 630 vendor: Hewlett-Packard driver: i915 v: kernel 
           bus ID: 00:02.0 chip ID: 8086:3e9b 
           Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: Hewlett-Packard 
           driver: nvidia v: 450.66 alternate: nouveau,nvidia_drm bus ID: 01:00.0 
           chip ID: 10de:1c8d 
           Device-3: Cheng Uei Precision Industry (Foxlink) HP Wide Vision HD Integrated 
           type: USB driver: uvcvideo bus ID: 1-5:5 chip ID: 05c8:03bc 
           Display: x11 server: X.Org 1.20.8 compositor: kwin_x11 driver: modesetting,nvidia 
           unloaded: intel,nouveau alternate: fbdev,nv,vesa display ID: :0 screens: 1 
           Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
           s-diag: 582mm (22.9") 
           Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 142 size: 344x193mm (13.5x7.6") 
           diag: 394mm (15.5") 
           OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 20.1.7 
           direct render: Yes 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Hewlett-Packard 
           driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci 
           bus ID: 00:1f.3 chip ID: 8086:a348 
           Sound Server: ALSA v: k5.8.6-1-MANJARO 
Network:   Device-1: Realtek RTL8822BE 802.11a/b/g/n/ac WiFi adapter vendor: Hewlett-Packard 
           driver: rtw_8822be v: N/A modules: rtw88_8822be port: 4000 bus ID: 02:00.0 
           chip ID: 10ec:b822 
           IF: wlo1 state: up mac: <filter> 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
           vendor: Hewlett-Packard driver: r8169 v: kernel port: 3000 bus ID: 05:00.0 
           chip ID: 10ec:8168 
           IF: eno1 state: down mac: <filter> 
Drives:    Local Storage: total: 1.60 TiB used: 396.76 GiB (24.3%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLW256HEHP-000H1 size: 238.47 GiB 
           block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 
           serial: <filter> rev: CXB73H1Q scheme: GPT 
           ID-2: /dev/sda type: USB vendor: Western Digital model: WD My Passport 0740 
           size: 465.73 GiB block size: physical: 512 B logical: 512 B serial: <filter> 
           rev: 1007 scheme: MBR 
           ID-3: /dev/sdb type: USB vendor: Toshiba model: External USB 3.0 size: 931.51 GiB 
           block size: physical: 512 B logical: 512 B serial: <filter> rev: 5438 scheme: MBR 
Partition: ID-1: / raw size: 238.17 GiB size: 233.43 GiB (98.01%) used: 35.62 GiB (15.3%) 
           fs: ext4 dev: /dev/nvme0n1p2 
Swap:      Alert: No Swap data was found. 
Unmounted: Message: No unmounted partitions found. 
Sensors:   System Temperatures: cpu: 58.0 C mobo: 29.8 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 301 Uptime: 1h 25m Memory: 15.53 GiB used: 4.30 GiB (27.7%) 
           Init: systemd v: 246 Compilers: gcc: 10.2.0 alt: 9 clang: 10.0.1 Packages: 1305 
           pacman: 1287 lib: 366 flatpak: 9 snap: 9 Shell: Bash v: 5.0.18 
           running in: konsole inxi: 3.1.05 

Any idea where to start looking really appreciated.


  1. Drop-down terminal
    . You can config his behavior in the application settings
  2. Session
    . You can set it to start a new session in system settings

I guess my inexperience with KDE is showing over there. I think I have found these settings and will let you know when I can reboot next (should be in 2 hours).


Is called Yakuake. You can configure it like this:


This is because you’ve got Plasma set to save its session on logout. This means that whenever you log in again, (almost) everything you had running in the last session will automatically be started again.

By default, Manjaro configures KDE Plasma to have Yakuake started automatically on login, but considering that you’re saving the session on logout, the next time you login, there will be two Yakuake sessions running, and as such, one session will be visible with an open window, and the other will be hidden.

Open up the System Settings and navigate to… :arrow_down:

Workspace → Startup and Shutdown → Desktop Session

Make sure that “Start with an empty session” is selected. Then close all running applications, log out, and log back in. And now only that which was set to automatically start at login will be running again. :wink:

Thank you, I had already figured it out from the first answer. I have stopped Yakuake to display on boot and make the session start on an empty session.

It was my inexperience using KDE that gave me this problem to begin with. Everything is good now :slight_smile:

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.