Webmin not working anymore

Hi,

I dont know when webmin stopped working but it is not starting properly anymore:

68# systemctl status webmin.service 
● webmin.service - Webmin
   Loaded: loaded (/usr/lib/systemd/system/webmin.service; disabled; vendor preset: disabled)
   Active: active (exited) since Tue 2018-01-30 20:05:18 CET; 1min 22s ago
  Process: 17208 ExecStart=/etc/webmin/start (code=exited, status=0/SUCCESS)
 Main PID: 17208 (code=exited, status=0/SUCCESS)
    Tasks: 1 (limit: 4915)
   CGroup: /system.slice/webmin.service
           └─17209 /usr/bin/perl /opt/webmin/miniserv.pl /etc/webmin/miniserv.conf

Jan 30 20:05:16 rakete systemd[1]: Starting Webmin...
Jan 30 20:05:16 rakete start[17208]: Starting Webmin server in /opt/webmin
Jan 30 20:05:16 rakete perl[17208]: pam_unix(webmin:auth): authentication failure; logname= uid=0 euid=0 tty= ruser= 
Jan 30 20:05:18 rakete webmin[17208]: Webmin starting
Jan 30 20:05:18 rakete start[17208]: Pre-loaded WebminCore
Jan 30 20:05:18 rakete systemd[1]: Started Webmin.

This here seems to be the issue:
pam_unix(webmin:auth): authentication failure; logname= uid=0 euid=0 tty= ruser=

The process seems to run:

69# ps -ef | grep webmi
root     17209     1  0 20:05 ?        00:00:00 /usr/bin/perl /opt/webmin/miniserv.pl /etc/webmin/miniserv.conf
root     17365 17209  0 20:09 ?        00:00:00 /usr/bin/perl /opt/webmin/miniserv.pl /etc/webmin/miniserv.conf

But when I try to connect to https://localhost:10000 it sits and waits and is doing nothing. This used to work some time ago.

I do not see any meaningful log entries in the journal or the webmin log. And I do not find anything helpful with google.

Any idea what is going wrong or how to debug this?

Matthias

There should be some logs, possibly in /opt/webmin/logs. If it’s installed in /opt I’m not sure where you installed it from…


(moved from #technical-issues-and-assistance:applications to #technical-issues-and-assistance:aur as webmin isn’t in the repos)

What’s the content of /etc/pam.d/webmin ?
(I’m just guessing…)
And output of: grep -i pam /etc/webmin/miniserv.conf

Well, as I said: The log files do not contain meaningfull messages.

/var/log/webmin/miniserv.error:
[31/Jan/2018:07:04:56 +0100] miniserv.pl started
[31/Jan/2018:07:04:56 +0100] IPv6 support cannot be enabled without the Socket6 perl module
[31/Jan/2018:07:04:56 +0100] Using MD5 module Digest::MD5
[31/Jan/2018:07:04:56 +0100] PAM authentication enabled

and systemd journal:

Jan 31 07:04:54 rakete systemd[1]: Starting Webmin…
Jan 31 07:04:54 rakete start[28939]: Starting Webmin server in /opt/webmin
Jan 31 07:04:54 rakete perl[28939]: pam_unix(webmin:auth): authentication failure; logname= uid=0 euid=0 tty= ruser= rhost= user=root
Jan 31 07:04:55 rakete webmin[28939]: Webmin starting
Jan 31 07:04:56 rakete start[28939]: Pre-loaded WebminCore
Jan 31 07:04:56 rakete systemd[1]: Started Webmin.

That is it. And to the other questions:

/etc/pam.d/webmin and /etc/webmin/miniserv.conf are unchanged because I deleted /etc/webmin and did a fresh install in hope to fix the issue

4# cat /etc/pam.d/webmin 
#%PAM-1.0
auth      include   system-remote-login
account   include   system-remote-login
password  include   system-remote-login
session   include   system-remote-login

5# grep -i pam /etc/webmin/miniserv.conf
pam=webmin
pam_only=1
pam_end=1
pam_conv=
no_pam=0

And I can remove /etc/pam.d/webmin, reboot and it does not make a difference.

Apparently webmin is running.

Can you curl https://127.0.0.1:10000 or telnet 127.0.0.1 10000 ?


18# curl https://127.0.0.1:10000
curl: (60) SSL certificate problem: self signed certificate
More details here: https://curl.haxx.se/docs/sslcerts.html

curl failed to verify the legitimacy of the server and therefore could not
establish a secure connection to it. To learn more about this situation and
how to fix it, please visit the web page mentioned above.

telnet just sits and waits

OK, so it’s running and responding to requests. Check your browser settings.

Indeed. I checked with epiphany and that works. So it seems to be a firefox issue…

Started firefox in --safe-mode and that does not help.

Solved!

I needed to create a new self signed certificate in webmin. Found this from 2014:
https://exdc.net/2014/11/27/kurztipp-probleme-beim-zugriff-via-firefox-auf-ssl-webmin/

Unfortunately - for obvious reasons - this can not be done in Firefox. So I ended up using epiphany to log into webmin, go to Webmin -> Webmin Configuration -> SSL Encryption -> Self Signed Certificate and “Create Now”.

Now it is working with Firefox again. Weird. Why did it stop working in the first place? And why isnt Firefox telling me that something is wrong with the certificate? I will leave it at that.

Thank you, @jonathon

1 Like

I had to do it again. New webmin package came today. Same issue. Using epiphany to fix it. Weird. Is this now an issue with the package builder who has forgotten to add to create a new certificate?

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by Bytemark