Webcam doesn't work

Hi !

I tried to make my webcam work. I have two webcam and none of them worked.
Either, i'm a unlucky owner of 2 unsupported webcam or something is wrong with my computer. And i pray, it's the later :innocent:

I read some post without a clear explanation, as far i understood webcam are supported with "video for linux", v4l, wich is included in the kernel. So i tried :
-Reinstalling v4l v4l-utils and reboot.
-I tried various webcam software.
-Installing other package without being sure what they do, as v4l2...
-Found the camera key fn+10 but the light don't lit. It's just detected.

So, Usualy do they work out the box ? Or do i need to install the driver ? if yes, how ?

The first one is an integrated laptop webcam and the second is a usb webcam.

[Toto@Totoro ~]$ lsusb
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 1af3:0001 Kingsis Peripherals ZOWIE Gaming mouse
Bus 001 Device 003: ID 8087:0a2b Intel Corp. 
Bus 001 Device 006: ID 5986:112d Acer, Inc BisonCam, NB Pro
Bus 001 Device 005: ID 046d:0826 Logitech, Inc. HD Webcam C525
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Thank you for your help :slightly_smiling_face:

Make use of this command to see where are listed
v4l2-ctl --list-devices
Usually are on /dev/video0 but sometimes (and might be your case) are on /dev/video1
In that case
v4l2-ctl -d /dev/video1 --list-ctrls
should show what configurations are available for it
with vlc for instance you should use
vlc v4l2:// :input-slave=alsa:// :v4l-vdev="/dev/video1"

Thank you ! I tried and got those result :

[toto@totoro ~]$ v4l2-ctl --list-devices
Cannot open device /dev/video0, exiting.

[toto@totoro ~]$ v4l2-ctl -d /dev/video1 --list-ctrls
Cannot open device /dev/video1, exiting.

At this point, i did a little search and tried a new command. I got a surprising result :

[toto@totoro ~]$ sudo modprobe uvcvideo
libkmod: kmod_config_parse: /etc/modprobe.d/nouveau_blacklist.conf line 1: ignoring bad line starting with '´╗┐blacklist'

So the webcam work !! Both ! :smiley:

Not sure what i should do at this point. Sould i check this file ? Do a little cleaning ?

If i recall, i did blacklist nouveau when i tried to install Manjaro the first time because i had a :
-A blackscreen (tlp starting...)
-A optimus laptop (intel+nvidia)

I installed Bumblebee with Optimus-manager and it's magic, HDMI port work (on nvidia switch), game flawlessy.

So What do you recommend ? :slight_smile:

Hi, did you check on "settings" in "confidentiality" if webcam is enabled?

In the /etc/modprobe.d/nouveau_blacklist.conf make sure you have:
blacklist nouveau
not '´╗┐blacklist' - i hope this helps, but you might have it already blacklisted in /etc/modprobe.d/mhwd-gpu.conf

Then, add in /etc/modules-load.d/modules.conf this line:
uvcvideo
Reboot after that.

Forum kindly sponsored by