Wayland session not working

Hi linub, xorg-xwayland was already installed by default.

1 Like

I have the exact same problem as the OP, with the “Plasma (Wayland)” session making the display go black for a few seconds, then return to SDDM.

I tried everything in the [Howto] Use wayland with propietary nvidia drivers article, plus I’ve read everything in the KWin/Wayland - KDE Community Wiki article and tried everything there.

Here are the contents of my ~/.local/share/sddm/wayland-session.log file, which is written when trying to start the “Plasma (Wayland)” session from SDDM:

(kwin_wayland:2556): Gtk-WARNING **: 15:48:22.031: cannot open display: 
KWin exited with code 1
startplasmacompositor: Shutting down...
startplasmacompositor: Done.

I have:

  • Nvidia GTX 1080 Ti
  • Nvidia proprietary driver version 470.42.01
  • Manjaro unstable branch with the latest available package versions
  • everything KDE-and-Wayland-related installed that I could find in research

Here is the output from inxi -G:

  Device-1: Intel HD Graphics 530 driver: i915 v: kernel 
  Device-2: NVIDIA GP102 [GeForce GTX 1080 Ti] driver: nvidia v: 470.42.01 
  Device-3: Logitech C922 Pro Stream Webcam type: USB 
  driver: snd-usb-audio,uvcvideo 
  Display: x11 server: X.Org 1.20.12 driver: loaded: nvidia resolution: 
  1: 1920x1200~60Hz 2: 1920x1080~60Hz 
  OpenGL: renderer: NVIDIA GeForce GTX 1080 Ti/PCIe/SSE2 
  v: 4.6.0 NVIDIA 470.42.01

Here is the output of yay -Qs wayland (meaning packages that are wayland-related that are installed on my machine):

local/egl-wayland 1.1.7-1
    EGLStream-based Wayland external platform
local/kodi 19.1-5
    A software media player and entertainment hub for digital media
local/kwayland 5.84.0-1 (kf5)
    Qt-style Client and Server library wrapper for the Wayland libraries
local/kwayland-integration 5.22.3-1 (plasma)
    Provides integration plugins for various KDE frameworks for the wayland
    windowing system
local/kwayland-server 5.22.3-1 (plasma)
    Wayland server components built on KDE Frameworks
local/layer-shell-qt 5.22.3-1 (plasma)
    Qt component to allow applications to make use of the Wayland wl-layer-shell
local/lib32-wayland 1.19.0-1
    A computer display server protocol
local/libva 2.12.0-1
    Video Acceleration (VA) API for Linux
local/plasma-wayland-protocols 1.3.0-1
    Plasma Specific Protocols for Wayland
local/plasma-wayland-session 5.22.3-1
    Plasma Wayland session
local/qt5-wayland 5.15.2+kde+r29-1 (qt qt5)
    Provides APIs for Wayland
local/sddm 0.19.0-6
    QML based X11 and Wayland display manager
local/wayland 1.19.0-1
    A computer display server protocol
local/wayland-protocols 1.21-1
    Specifications of extended Wayland protocols
local/waylandpp 0.2.8-1
    Wayland C++ bindings
local/wrapland 0.522.0-1
    Qt/C++ library that wraps and mediates the libwayland client and server API
local/xorg-xwayland 21.1.2-1 (xorg)
    run X clients under wayland

I’ve tried researching this online extensively and haven’t been able to find a solution. I really want to try Plasma with Wayland. Any help, including asking me for things to try, would be greatly appreciated. Thanks for reading!

OK, I’ve got some very limitted succes. After installing all wayland-related packages I added this to the kernel command line:


Wayland session started, but everything was so slow that the system was totally useless. It looks like the frame rate went down to 1 FPS or so.

EDIT: ksysguard shows that SDDM was on 90% cpu.

I have that kernel command line parameter as well, but have the same issue, despite having that. I wonder what else I need.

I did a clean install with open source drivers and tried wayland session, but it doesn’t work, the screen just goes blanks, so no point continuing these tests for now. Guess KDE isn’t wayland-ready yet.

1 Like

I’m still getting this issue, even with all the most recent updates in the unstable branch. I don’t get it.

Same issue here.

On my Optimus laptop it works only on Intel graphics and refuses to work on Nvidia.

As AMD user I have no issues running Wayland on KDE.

Hi ForeverNoob,

maybe this could help you?
Start KDE Settings-> Workspace-> Startup and shutdown-> SDDM-> Behavior-> and choose username and Plasma Wayland.

This helps me 3hours ago. :grinning:

I’m able to start some sort of super-broken wayland session with this command from a TTY:

kwin_wayland --drm --libinput --xwayland /usr/lib64/startplasma-waylandsession

  • It’s all black except for a mouse cursor.
  • The right-click context menu can appear and show a context menu.
    • The context menu is different depending on different invisible (black) elements, like desktop icons, behind the cursor wherever I clicked.
  • There are panels that I had set up with the X11 Plasma session a while back, but they are invisible (black), and the blackness overlaps something if I open it.
  • I was able to see a Nemo file manager window and interact with it, so I could navigate manually to /usr/share/applications/ and open the KDE System Settings application.
    • The KDE System Settings application in this mode was an utter garbage mess, where it would only show black panels most of the time, and often not update the tab list on the left side, but the title bar would always update, so I could somewhat see where I was navigating.
      • Since I couldn’t see any contents in the right side, though, this was useless.

So, I don’t know. KDE Plasma with Wayland is utterly broken here. I don’t know how to make it work in any normal way, no matter what I do. How can people use it at all? It’s baffling.

Hi myrko,

Thnaks for the info. I was able to start a KDE/Wayland/nvidia session on openSUSE Tumbleweed. It kind of works, but not yet good enough. Firefox, for example, displays garbage and is totally unusable. I will continue watching this and update.

I’m going to watch this thread too, I have a similar setup and the same issues.

1080 Ti, KDE Plasma, Wayland just black screens and boots me back out. Tried about 6 months ago and nothing has change since then really sadly…

1 Like

I have encounter exactly the same problem, and it is solved in execatly the same way as you did.
This is just the way in ArchWiki: KDE - ArchWiki

However wayland is not slow anyway, some env:

  • Nvidia GTX 1650
  • Linux 5.13.11-1

But I have another problem, fonts in chromium blurs, 4K monitor with 200% scaling, a screenshot that might not be able to illustrate the problem:

The problem of blurry fonts in chromium is solved by following the ArchWiki:

BTW the icon for chromium changes for wayland
No blurry at all, but the startup takes much longer time, I think it has not been optimized yet.

When playing a same video in chromium using xorg and wayland, wayland is slower considerably, cpu usage roughly as below, also not optimized enough

  • xorg 10%~15%
  • wayland 15%~20%
1 Like

Current status on my machine: Wayland session starts, speed not too bad, but window decorations invisible and system tray tooltips not refreshing when moving between icons. Also, Windows game under wine starts and makes the right noises, but the screen is completely blanks. Still far from usable.

On openSuse Tumbleweed things look better: window decoration is OK and Windows game plays well. But this is no surprise, as it updates much more frequently.

Try kwin_wayland --replace, it might help.

Tried, it didn’t change anything.

Update: I’ve installed Nvidia beta driver 495.29.05, gone through the guide again just to double-check everything’s the same, then rebooted. I have almost the exact same issue as described in my first post in this thread, to which I’m replying now. The only difference is that the cannot open display: line is repeated several times in ~/.local/share/sddm/wayland-session.log now, instead of just once.

If anyone has any insight into this cannot open display: problem, please help me. I’ve been at this for months with no progress.

2 posts were merged into an existing topic: [Howto] Use wayland with propietary nvidia drivers