Wayland on Plasma 5.27

That’s cool and stuff and I know it, however 2 finger swipes are meant to trigger horizontal scrolling, anything else is counter-productive. And that feature has nothing to do with Google Chrome and, most importantly, Dolphin and Konsole.
I stick to X.

Did you try it with touche? Desktop gestures don’t work on Wayland, but app gestures do. So my pinch in/out gestures are all right. Maybe there is a way to set them for next/previous page in a browser two? You need to avoid 3 and 4 finger swipes thou, those are already defined in Wayland, so it’s really tricky to find out something else.

I wasn’t aware that the swipe gestures work on X11… :wink:

Well there’s a couple of third-party tools that add this functionality. Like libinput-gestures or touchegg. But when one uses Wayland, Plasma’s hardcoded gestures interfere with those solutions causing worse experience. You ether have both actions triggered or the primary (provided by Plasma) only. That’s why it’s better to have a toggle to switch them off while they are not configurable (ATM).

1 Like

The non-configurable gestures is the main showstopper for me as well. If they at least could have left us the possibility to turn the default ones off, but maybe it’s not that easy as turning them off would make libinput magically work again.

Sounds like you are referring to touch devices.

I use Plasma and Wayland on desktop and I have zero problems.

Actually - all my prejudices about KDE and Plasma have been put to shame - I am totally overwhelmed how well it works.

Initially I started experimenting with kwin on lxqt - as lxqt has no preference for the window manager - and one package took the other and now I am rolling a slimmed down plasma using Manjaro Plasma minimal ISO.

Current hwinfo: http://ix.io/4jFi


Having done some experiments myself, it is. If you use libinput-gestures and set it to a gesture that Plasma uses, then both gestures will activate simultaneously. And it is as easy as turning them off, I was able to locate a single-digit number of lines of code in the Kwin source that control whether the gestures are on or off. I’m just not adventurous enough to compile and use my own fork of Plasma :sweat_smile:

In case of pad, I didn’t notice any issues aside when you have an animation added in touchegg and in Wayland this gestures won’t work. The effect is that you get animation alone or animation not matching the effect. That’s it. Animation is not necessary, so you can always turn it off.
So basically all defined desktop gestures on touche are replaced with defined in Wayland, while app gestures still work.

For me, touché works much better than libinputy-gestures, although the mechanics seems to be the same, but I might be wrong about that.

I’ve been using Wayland about a month, and yesterday I experienced my first Kwin/Wayland spontaneous crash, so that can happen, sadly. It’s too random to know what triggered it, so I won’t report a bug.

Forget what I’ve said before about zoom

  1. Uninstall any copy you have
  2. flatpak install us.zoom.Zoom
  3. Open zoom once, then close it
  4. kate ~/.var/app/us.zoom.Zoom/config/zoomus.conf
  5. switch enableWaylandShare=true
  6. Relaunch Zoom

It will now work flawlessly, non flatpak versions do not work by the way

1 Like

I followed the instruction and:

  1. In the first start it did tell me to restart and add the value you provided above, but when I went to ~/.var/app/us.zoom.Zoom/config/zoomus.conf it already had “enableWaylandShare=true”
  2. When I clicked on share screen, I got exactly the same info above that it only works on Gnome.
  3. Flatpack version has automatically allowed to save files to Documents, although I don’t have such folder in my language version, so it’s creating it every time I launch Zoom. This is incredibly annoying, and I can’t change it or switch it to a different folder.

Looks like flatpack works in the same way as the AUR version, has the same limitations and has additional annoying features, that AUR version doesn’t have :frowning: .

New development in Wayland camp!

XWayland bridge was created to ensure screen sharing options in Wayland for XWayland apps even if they don’t support Wayland screensharing just yet. I tested it on Zoom and in flatpack verision doesn’t work, but with AUR version worked like a charm. I could choose my sharing window without a problem.

See the info:


It’s possible it will be integrated with the system, but for now it’s only available in flatpack version. So what you need to do is to go to this site and download the flatpack file:

Have Discover installed. Double click on a file, a Discover will open with option to install it. After it is done, copy the .desktop file from


to your


Since this is in early development and not available through flathub or any official repo, you need to check for updates manually. At some point it probably will be available through AUR and then later as an official package or will be eventually integrated with system packages.

It looks like the biggest Wayland issues have been addressed: in Plasma 6 windows will recover after a compositor crash/restart and screen sharing has a bridge till native solutions won’t be developed in various apps.

1 Like