Wayland not working

Hi guys, been following a few guides to try and get Wayland working with Gnome and editing files to allow Wayland to work with Nvidia but so far I am not having any luck.

Is there a new process that has to be done?
I have WaylandEnable=true in /etc/gdm/custom.conf
I also have commented DRIVER==“nvidia”, RUN+="/usr/lib/gdm-runtime-config set daemon WaylandEnable false" in /etc/udev/rules.d so it looks like this
#DRIVER==“nvidia”, RUN+="/usr/lib/gdm-runtime-config set daemon WaylandEnable false"

you can blame nvidia for that. nvidia runs best on xorg, they been dragging there buts for wayland for years.

You have to enable early KMS too Kernel mode setting - ArchWiki