Wayland: Intel+Nvidia hybrid requires call prime-offload and optimus-manager after every boot

Running Manjaro with gnome/GDM, kernel 6.6.32-1, and proprietary/hybrid drivers. GDM is set to use Wayland.

After every boot, already at the login screen only the notebook monitor turns on, while the external is not detected.

After login, to get the external monitor to work I have to call

prime-offload && optimus-manager --switch hybrid

It does an auto logoff, and the login screen now detects both monitors correctly. After the second login, everything works fine with gnome in hybrid mode.

How can I fix this to make the external monitor available on first login?

Extra info: if I try to run optimus-manager --print-mode without the prime-offload call first, I get this error:

ERROR: a GPU setup was initiated but Xorg post-start hook did not run.
Log at /var/log/optimus-manager/switch/switch-20240630T224028.log
If your login manager is GDM, make sure to follow those instructions:
If your display manager is neither GDM, SDDM nor LightDM, or if you don't use one, read the wiki:
Cannot execute command because of previous errors.

optimus-manager is junk and ‘hybrid’ mode is how you would already be without any ‘switcher’ utility.

I understand the criticism over optimus-manager, and I’ve tried the mhwd and the envycontrol approaches.

But it was only with optimus-manager that I’ve managed to make gnome/gdm work with hybrid mode on wayland.

Without optimus, how can I make my gnome work on wayland? Nothing works.

Ok… forget about this post. I just made it all work perfectly by removing: optimus-manager, gdm-prime, libgdm-prime. And later following the proper tutorial from [HowTo] Use Wayland with proprietary NVIDIA drivers

Previously, I’ve seen tutorials quite similar to this one, but missing the instruction “2) To force-enable Wayland…”, which seems to be critical. Without it, my system would boot, but it wouldn’t open GDM and I would be stuck to the console.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.