Wayland disabled after installing nvidia drivers


My PC worked OK with wayland session and open source drivers, but after installing latest nvidia drivers I was back on x11 and the wayland switch in layouts-settings was off and disabled. Is there a way to turn wayland back on?


Hello @ForeverNoob :wink:

The reason for this is that nvidia has only partial support for wayland and it works pretty bad (laggy) at the moment as i know.

But if you really need this, here is a guide to disable the rule for nvidia:

Nvidia is preparing a driver for extended wayland support.
Turn on the free driver, or wait nvidia.

Aren’t latest drivers supporting wayland?

NVIDIA Drivers 470 on Linux: DLSS and XWayland support arrives

Hi megavolt,

I followed the instructions in the Howto, but the wayland switch insisted on staying disabled.

Yes it works, but not great since it is just basic support and it is beta.

I have done it myself some weeks ago and it worked. You must made a mistake somehow.

What reason do you have for using Wayland?

Nothing specific, just curiosity.

Possibly. Will try again.

I would stick to Xorg for now until Wayland is more mature.

manjaro-gnome works well with wayland and open source drivers. I was even able run a Windows game (under wine) without special problems. It looks more loke a Plasma problem.