Wayland buggy/unusable for Manjaro KDE

x11 works fine but when I switch to wayland on the login screen it either freezes up after entering the login details or when it does get past the login screen, everything works great except that the entire bottom menu bar/task bar is completely missing.

  Kernel: 5.15.32-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=281760b5-544a-4dc9-b2ea-e41ca29ea9e9 rw quiet
    root=/dev/mapper/luks-7262977c-d0cc-4daa-a444-725f2fc63224 apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: KDE Plasma v: 5.24.4 tk: Qt v: 5.15.3 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: Micro-Star model: Z390-A PRO (MS-7B98) v: 1.0
    serial: <superuser required> UEFI: American Megatrends v: 1.80
    date: 12/25/2019
  Message: No system battery data found. Is one present?
  RAM: total: 15.57 GiB used: 3.53 GiB (22.7%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
  Info: model: Intel Core i7-9700K bits: 64 type: MCP arch: Coffee Lake
    family: 6 model-id: 0x9E (158) stepping: 0xC (12) microcode: 0xEC
  Topology: cpus: 1x cores: 8 smt: <unsupported> cache: L1: 512 KiB
    desc: d-8x32 KiB; i-8x32 KiB L2: 2 MiB desc: 8x256 KiB L3: 12 MiB
    desc: 1x12 MiB
  Speed (MHz): avg: 2640 high: 4796 min/max: 800/4900 scaling:
    driver: intel_pstate governor: powersave cores: 1: 800 2: 800 3: 1111
    4: 4159 5: 2878 6: 2535 7: 4796 8: 4043 bogomips: 57616
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_perfmon art avx avx2 bmi1 bmi2 bts clflush clflushopt
    cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts
    ept ept_ad erms est f16c flexpriority flush_l1d fma fpu fsgsbase fxsr ht
    hwp hwp_act_window hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid
    invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe mpx msr mtrr
    nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln
    pni popcnt pse pse36 pts rdrand rdseed rdtscp rep_good sdbg sep smap smep
    smx ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow
    tsc tsc_adjust tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave
    xsavec xsaveopt xsaves xtopology xtpr
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf status: Not affected
  Type: mds mitigation: Clear CPU buffers; SMT disabled
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: disabled, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort mitigation: TSX disabled
  Device-1: NVIDIA GP104 [GeForce GTX 1080] vendor: Gigabyte driver: nouveau
    v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 16 link-max: gen: 3
    speed: 8 GT/s ports: active: HDMI-A-1 empty: DP-1, DP-2, DP-3, DVI-D-1
    bus-ID: 01:00.0 chip-ID: 10de:1b80 class-ID: 0300
  Display: x11 server: X.Org v: with: Xwayland v: 22.1.1
    compositor: kwin_x11 driver: X: loaded: modesetting alternate: fbdev,vesa
    gpu: nouveau display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: HDMI-A-1 mapped: HDMI-1 model: Acer VG270 serial: <filter>
    built: 2018 res: 1920x1080 hz: 75 dpi: 82 gamma: 1.2
    size: 598x336mm (23.54x13.23") diag: 686mm (27") ratio: 16:9 modes:
    max: 1920x1080 min: 720x400
  OpenGL: renderer: NV134 v: 4.3 Mesa 21.3.8 direct render: Yes
  Device-1: Intel Cannon Lake PCH cAVS vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl
    bus-ID: 00:1f.3 chip-ID: 8086:a348 class-ID: 0403
  Device-2: NVIDIA GP104 High Definition Audio vendor: Gigabyte
    driver: snd_hda_intel v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 16
    link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.1 chip-ID: 10de:10f0
    class-ID: 0403
  Sound Server-1: ALSA v: k5.15.32-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.49 running: yes
  Device-1: Intel Ethernet I219-V vendor: Micro-Star MSI driver: e1000e
    v: kernel port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15bc class-ID: 0200
  IF: eno1 state: down mac: <filter>
  Device-2: Intel Wireless 8260 driver: iwlwifi v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 bus-ID: 03:00.0 chip-ID: 8086:24f3 class-ID: 0280
  IF: wlp3s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  IF-ID-1: ipv6leakintrf0 state: unknown speed: N/A duplex: N/A
    mac: <filter>
  IP v6: <filter> type: noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  IF-ID-2: proton0 state: unknown speed: 10 Mbps duplex: full mac: N/A
  IP v4: <filter> type: noprefixroute scope: global broadcast: <filter>
  IP v6: <filter> virtual: stable-privacy scope: link
  IF-ID-3: pvpnksintrf0 state: unknown speed: N/A duplex: N/A mac: <filter>
  IP v4: <filter> type: noprefixroute scope: global broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: No WAN IP found. Connected to web? SSL issues? Try enabling dig
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
    bus-ID: 1-7:2 chip-ID: 8087:0a2b class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
  Message: No logical block device data found.
  Device-1: luks-7262977c-d0cc-4daa-a444-725f2fc63224 maj-min: 254:0
    type: LUKS dm: dm-0 size: 465.46 GiB
  p-1: sdb2 maj-min: 8:18 size: 465.46 GiB
  Message: No RAID data found.
  Local Storage: total: 1.36 TiB used: 88.29 GiB (6.3%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital
    model: WD10EZEX-22MFCA0 size: 931.51 GiB block-size: physical: 4096 B
    logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter>
    rev: 1A01 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 type: USB model: SSK SSK Storage
    size: 465.76 GiB block-size: physical: 4096 B logical: 512 B type: N/A
    serial: <filter> rev: 0209 scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 465.46 GiB size: 457.09 GiB (98.20%)
    used: 88.29 GiB (19.3%) fs: ext4 dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-7262977c-d0cc-4daa-a444-725f2fc63224 label: N/A
    uuid: 281760b5-544a-4dc9-b2ea-e41ca29ea9e9
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 440 KiB (0.1%) fs: vfat dev: /dev/sdb1 maj-min: 8:17 label: NO_LABEL
    uuid: D91E-3253
  Alert: No swap data was found.
  ID-1: /dev/sda1 maj-min: 8:1 size: 16 MiB fs: <superuser required>
    label: N/A uuid: N/A
  ID-2: /dev/sda2 maj-min: 8:2 size: 931.5 GiB fs: ntfs label: HDD
    uuid: 0682C08F82C08521
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 16 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-7:2 info: Intel Bluetooth wireless interface type: Bluetooth
    driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA
    chip-ID: 8087:0a2b class-ID: e001
  Device-2: 1-9:3 info: Kingston HyperX Alloy Core RGB type: Keyboard
    driver: hid-generic,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s
    power: 500mA chip-ID: 0951:16dd class-ID: 0301
  Device-3: 1-10:4 info: MosArt Wireless Mouse type: Mouse
    driver: hid-generic,usbhid interfaces: 1 rev: 1.1 speed: 12 Mb/s
    power: 100mA chip-ID: 062a:4102 class-ID: 0301
  Hub-2: 2-0:1 info: Super-speed hub ports: 10 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Device-1: 2-6:2 info: JMicron / USA JMS567 SATA 6Gb/s bridge
    type: Mass Storage driver: uas interfaces: 1 rev: 3.2 speed: 5 Gb/s
    power: 896mA chip-ID: 152d:0562 class-ID: 0806 serial: <filter>
  System Temperatures: cpu: 27.8 C pch: 45.0 C mobo: N/A gpu: nouveau
    temp: 39.0 C
  Fan Speeds (RPM): N/A gpu: nouveau fan: 1247
  Processes: 277 Uptime: 8m wakeups: 0 Init: systemd v: 250 tool: systemctl
  Compilers: gcc: 11.2.0 clang: 13.0.1 Packages: 1261 pacman: 1243 lib: 336
  flatpak: 11 snap: 7 Shell: Zsh v: 5.8.1 default: Bash v: 5.1.16
  running-in: konsole inxi: 3.3.15

Don’t expect any good with nvidia + xwayland at this stage. Even if you use the nouveau driver. At this moment only intel and amd gpus work good enough with wayland. At least this is my experience.

Maybe without nouveau driver it will work better. I recently tried with my GTX 1060 and it just works, there are issues with some applications but I even tried to play games like Sea of Thieves and I had no issues really, just there are some weird bugs like SMPlayer can not fullscreen video, or the video player is outside the main application frame, in a second frame/window (basically unusable to me). But it shouldn’t crash I think now. It is still unusable as a replacement for X11/Xorg in my opinion, but it works. Try to install Nvidia drivers (sudo mhwd -i pci video-nvidia) and try again if you really want to use the not fully ready and not fully working and not fully compatible new display server Wayland.

What I don’t understand is why are people feeling they need to use Wayland.


I’ve a 6800XT, Testing Branch, amdgpu. The desktop/UI loads fine but clicking on just about anything with the interface and launching apps freezes the desktop for a ridiculous amount of time (ie; launching System Settings might take a minute, Dolphin half a minute, clicking on system tray icons for anything will maybe be 20 seconds before it pulls down). inxi -G output;

  Device-1: AMD Navi 21 [Radeon RX 6800/6800 XT / 6900 XT] driver: amdgpu
    v: kernel
  Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.2 driver: X:
    loaded: amdgpu unloaded: modesetting,radeon gpu: amdgpu
    resolution: 2560x1440
  OpenGL: renderer: AMD Radeon RX 6800 XT (sienna_cichlid LLVM 13.0.1 DRM
    3.46 5.18.3-1-MANJARO)
    v: 4.6 Mesa 22.1.1

glxinfo | grep 'direct rendering' output; direct rendering: Yes

I’ve tried resetting Desktop Effects, disabling xscreensaver from launching at login (since it doesn’t support Wayland). Krusader, Firefox launch fine, for example, so I’ve no idea what particular API calls are causing the UI to completely chunk after interacting with anything.

Thank you.

‘SOLVED’ (for me?);

System Settings > Appearance > Fonts > DISABLE ANTI ALIASING

Everything becomes super snappy, but…fonts in everything are now UGLY! :roll_eyes:

Going to try different Font settings ** sigh **

EDIT: I re-enabled/re-clicked Anti-aliasing, it applied…but it’s staying snappy. Hoping I wasn’t teasing myself, I logged out, back in…everything launches and is still snappy—everything is quite usable! :grinning: :+1:t4: I’m almost in disbelief [that] it was this simple!

EDIT 2: The freezing is back after a reboot :sob: I had to run, hope to try to troubleshoot this afternoon.

EDIT 3: I can’t make heads or tails of it. I was in an X11 session for awhile as I rooted an Android phone. When done, I disabled Font AA again, logged out and back in to Wayland, enabled AA—beautiful (looks and performance). Shut down, cold boot. Logged into Wayland—crapped! Logged into X11, disabled AA, logged into Wayland—crapped! Tried logging in again (Wayland), ran journalctl -f (if you’ve a better suggestion, I’m all ears, I’m a noob) but saw nothing apparent when UI freezes occurred. Nihilism is setting in. :expressionless:

EDIT 4: I created a fresh account and noticed it didn’t have these problems at all. I began following these instructions from user ‘Ben’ and noticed Wayland was performing beautifully through logout/logins and reboots. Now, where I screwed up was, after everything was running quite well, I cheated (forgive me, I’d been dealing with this for hours yesterday) and used PlasmaConfigSaver to restore how my desktop looked and BAM, immediate UI hangs!

I found and was checking out PlasmaConfigSaver’s script to figure out what it actually recovered to make the UI chunk under Wayland and I can’t find a breakdown in their Github’s readme. I hope to figure this out soon.

1 Like

Wow, sorry to hear that… I actually only used it for a month or two playing with themes, now I’m pretty much stuck (call it the perfect theme, or maybe it just gets to the point that there’s not really much point). I occasionally tweak the colour scheme, and with Kitty just edit the colours to fit in.

So it’s time to analyse everything saved by PlasmaConfigSaver, and try to figure it out to fix manually.

1 Like

Kompare or Meld are useful tools to compare files or folders (containing files) to help find the culprit in the config files.

1 Like

I finally set aside some time and got around to moving the .config and .local/share into the DOTCONFIG directory, restarted and let KDE recreate its default files. Everything clean, Wayland was performing smoothly. This time I only began moving over files and directories [that] I knew had nothing to do with KDE, making sure to restart after changes and decided to set up KDE again, mostly from scratch (I kept a couple of things, like color sets), using a screenshot as reference.

Right now everything is still running smoothly. I would love to have been able to understand the script to have understood exactly what the culprit was but I’m glad it appears to be working now. Thank you all for your help…until next time! :sweat_smile: