Warpinator "Permission denied: '/usr/lib/python3.10/site-packages"

I installed Warpinator software
When I run warpinator

[Errno 13] Permission denied: ‘/usr/lib/python3.10/site-packages/altgraph-0.17.3.dist-info’

how to fix?

Remove altgraph the same way you installed it. Do not install Python packages with sudo pip. See [root tip] [How To] Avoid common pitfalls as developer

1 Like

now error

[Errno 13] Permission denied: ‘/usr/lib/python3.10/site-packages/ds-0.0.1.dist-info’

It’s the same error with a different Python package. Apply the same principle. :wink:

i cant remove altgraph wih sudo pacman -R altgraph not found
i install pip then sudo pip uninstall altgraph

how to uninstall with sudo pip uninstall ds or ?

I had not installed them, I remove them by mistake
I had to timeshif back to the original state
I didn’t install the python package via pip that I want to remove

This problem still exists

Can i solve the problem by changing the permission chmod 644?

sudo ls -l /usr/lib/python3.10/site-packages/altgraph-0.17.3.dist-info
total 32
-rw-r----- 1 root root 4 Nov 30 19:04 INSTALLER
-rw-r----- 1 root root 1002 Nov 30 19:04 LICENSE
-rw-r----- 1 root root 7395 Nov 30 19:04 METADATA
-rw-r----- 1 root root 1466 Nov 30 19:04 RECORD
-rw-r----- 1 root root 9 Nov 30 19:04 top_level.txt
-rw-r----- 1 root root 110 Nov 30 19:04 WHEEL
-rw-r----- 1 root root 1 Nov 30 19:04 zip-safe

If you removed app dependencies unintentionally - remove the app and reinstall it

sudo pacman -Rns warpinator
1 Like

thanks solved permissions.
now show error

Traceback (most recent call last):
File “/usr/bin/warpinator”, line 7, in
from gi.repository import Gio, GLib
ModuleNotFoundError: No module named ‘gi’

Python module gi comes from python-gobject package. Reinstall this package


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.