WARNING: after latest update [23/01/2019] my computer won't start anymore!

Today’s update is a complete disaster. Don’t do this update. It’s worse and I’m not able to use my computer anymore. << You are now being dropped into an emergengy shell >>

have you checked announcements ?

1 Like

Help!! Yes,this update has been a disaster - exactly as described above.

2 Likes

And I have no idea how to solve this problem. I’m not an IT specialist.

2 Likes

launch on USB install
open a terminal

manjaro-chroot -a ( select 1 )
pacman -Syyuu
exit( quit chroot) 

reboot

2 Likes


Here’s a screen’s shot of the boot process. My keyboard does not work in the “emergency shell”.

1 Like

Yes, I have the same info on my screen after today’s update. No idea how to get it right again.

Is there a proper manual to restore my system? Is someone able to guide me through the procedures to restore my system? Maybe with screenshots?

Read the announcements thread

I have no idea how this works. I’m not an IT specialist and I have no time to become one. :slight_smile:

use a manjaro iso, and enter 3 command lines

tuto:

Follow @stephane’s instructions above.

In the first step, you need to boot from the USB media you used to install Manjaro on your computer. If you don’t still have this USB media, you will need to download the Manajaro ISO on another computer and write the ISO to USB media.

Once this live media loads on your computer, you open a terminal and run the commands shown in the post above. Finally, you boot into your computer as usual, and your problems should be fixed. If not, we can help you.

1 Like

I tried. But failed. << Can’t create chroot on non-directory >> Maybe I use the wrong terminal. Have no idea. :slight_smile: after typing ( select 1 ) bash: syntax near unexpected token “)”

reboot: error while loading shared libraries: libidn2.so.0: cannot open shared object file: No such file or directory. [comment after using a terminal]

Worked fine for me. Here’s what I entered in a drop-down terminal window:

manjaro-chroot -a
pacman -Syyuu
exit
reboot

Thanks to Stephane!!

3 Likes

After booting from your USB media, you open a terminal. In the terminal you type

manjaro-chroot -a

and immediately press the Enter key.

You will then be presented with a list of “detected systems.” It’s likely that only ManjaroLinux appears in the list. For example, you might see the following:

0) ManjaroLinux

Since ManjaroLinux follows the number 0, you would simply type 0 and press the Enter key. If ManjaroLinux follows some other number, you would type that number instead.

do you use a return at the end of the command lines?

Yes, press the Enter key after typing each command.

I booted the system from the USB. After that i saw a lot of text on my sreen. Now I have the same screen as usual. And opend the terminal. I have written this command. After that, there’s no list. Only
Mounting (Manjarolinux) [/dev/nvme0n1p2]
mount: [/mnt]
mount: [/mnt/boot/efi]

It looks like the manjaro-chroot command is mounting your partitions automatically. Perhaps it doesn’t present a list of “detected systems” because it detected that you have only Manjaro installed on this computer.

If you see the command prompt in the terminal once again, you can proceed with the next command:

pacman -Syyuu

Nice username and initial post BTW.

I can see from your user profile that you’ve made an exhaustive search on the forum (4 threads).

If others can correct this issue by following the instructions on this thread perhaps you might want to reconsider where the problem lies here.

4 Likes

Forum kindly sponsored by Bytemark