Want to install Manjaro alongside Windows, installation fails every time

Hey, it says

BIOS Version/Date: Insyde F.29 2/7/2020
SMBIOS Version: 2.8

I really haven’t a clue as to where to find how to disable efi. There are two boot orders, as per the photo provided, UEFI, and Legacy, and I can only disable the latter. Maybe I’m too thick to figure out where to disable it :confused:

When you load the Manjaro system - scroll the initial Welcome to Manjaro - yes it probably have items you cannot see - below the border.

If you get an entry reading (your system is booted as EFI and Manjaro install will fail because disk is MBR)

20201001-154911_300x39_screenshot

Or an entry offering to run memtest (in which case the system is booted as a legacy system)

20201001-154818_269x42_screenshot
20201001-160317_319x42_screenshot

For the first case - and judging from what you shared - there is no way of changing this - the only way forward is to wipe the Windows system - or - in case you are in possession of the original Windows install media (which is rare) - you may be able to disable Legacy boot - and install Windows in EFI mode - which in turn will remove the obstacles for installing Manjaro and keeping Windows for the person you share the computer with.

First: I have no idea how to force a Manjaro ISO into booting as MBR when the system clearly prefers EFI/GPT.

Second: There is not second :slight_smile: sorry.
ping @m_nimal
Now there is a second.

When the installer get’s to the point of selecting partitions - do as follows (when you get messages telling you are on the wrong track) just accept them and continue

  • Select Manual partitioning - ignore the notes for the selected method
  • Double click the sda3 partition
  • Filesystem -> select ext4
  • Mountpoint -> select /
  • In the flags section -> select legacy-boot (nothing else in the flags) and click OK
  • A box appears at the bottom - verify it reads something like
    Master Boot Record of … (/dev/sda)

Click Next - and because Calamares is not used to Legacy boot EFI system - it will display a message - click OK and continue with the user information and password screen

This should do the trick.

2 Likes

Hey, THANKS! This did the trick, and I was able to finish the installation, which is wonderful. However, upon restarting, all I get is a
Missing operating system_
message on a black screen, and I can only turn the laptop off physically. :grimacing: is there something I’m missing? (Edit: other than an operating system…)

1 Like

I have no idea - apparently the computer vendor HP - has a non standard way of doing things - I am really lost now.

Personally - I would bite the bullet - disable Legacy in firmware and use the whole disk for a new EFI based Manjaro installation (the use whole disk option) - and never look back.

1 Like

Hahah I’ll have to end up doing that, it seems!
Thank you so much for all your help, you’re fantastic, have a nice day :slight_smile:

1 Like

I assume there’s no way of me getting back into either windows or manjaro now? Other than through the usb. (I can still see all the windows files, my downloads etc there)

Usually there is - but I have idea on how to continue from here.

Maybe loading Manjaro from USB then use chroot to switch to the installed Manjaro.

From there I would try to get the installations recognized.

The steps required is in order

  1. load Manjaro from ISO
  2. open a terminal, switch to root, mount sda3
    $ su
    # sudo mount /dev/sda3 /mnt
    
  3. enter chroot
    # manjaro-chroot /mnt /bin/bash
    
  4. try to locate the windows install using os-proper
    # os-proper
    
  5. reinstall grub
    # grub-install --force --target=i386-pc --recheck --boot-directory=/boot /dev/sda
    
  6. rebuild grub config
    # grub-mkconfig -o /boot/grub/grub.cfg
    
  7. exit chroot and reboot
    # exit
    $ reboot
    

@Alfy
i wish to share my experience and setup.
everytime i broke windows [i opt for fresh re-install] i know i have to touch chroot in manjaro for grub [i am currently triple booting alongside windows and Mx linux.]

windows and manjaro are on efi [ i have chosen /boot/efi on /dev/sda1 [the efi for windows] . /dev/sda2 is windows, /dev/sda3 is manjaro [fyi my partition is bios] so extended logical i have mx installed with its grub on its root partition]

everytime windows misbehaves, i clear it, chroot into manjaro and manjaro grub sets everything right !

what i wish to point is /dev/sda1 is the efi partition for windows as well as manjaro.

further, i share common swap partition for mx and manjaro [which is in the extended logical part] hope this helps.

EDIT:
Alternatively, with your current setup, you may need to allot atleast 8MB unformated empty partition prior to your / for manjaro. once you do this, your grub will be showing windows and manjaro

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.