Want to install Manjaro alongside Windows, installation fails every time

Hello everybody!

I hope I’m posting this in the right place.
Was recently given a laptop with Windows 7 on it, and I wanted to try Manjaro. I am fairly new to computers, so I don’t know what the problem is with my installation.

First, some technical info:
Laptop is a
HP 255 g4 notebook
running Windows 7 Ultimate 64 bit
AMD E1-6015 APU 1.40 GHz

I’ve disabled secure and legacy boot.
Can boot into the manjaro USB without any issues.

When I get to the part where I have to choose a partition, I’ve tried all but one option (one I haven’t tried is deleting the whole disk).
Top left says EFI, top right says MBR.
No matter what I try, I always get the same “grub-install: error: /boot/efi doesn’t look like an EFI partition” error during installation, some 78% in:

ibb(.)co/VV3zNZt Here it is in its entirety. Since this is my first post, I’m unable to post links, so please, if it’s not a problem, just delete the brackets around the first dot :slight_smile:

Could someone please help me out, what am I missing here?
Thank you in advance.

hello :slight_smile:
I used this guide to set my dual boot up

seems you are mixing mbr and efi.

1 Like

Hey, Alfy, thanks for the quick response! I came across that post as well, but I’m not sure how to … not mix EFI and MBR, since I’m a newbie. Is there a way I can make it so that it’s EFI and GPT? Thanks again :slight_smile:

This is probably due to the current disk is formatted using the MBR partition schema.

Don’t try to install Manjaro as EFI when the disk is formatted using MBR as this is doomed to fail.

Unless you are prepared to ditch the installed Windows system - I recommend to disable EFI boot in the firmware then install using MBR schema.

If you are prepared to ditch the current system - select use whole disk and erase what’s on the disk.

1 Like

Hey, I am actually prepared to do so,since I don’t have any files here, but would I then be able to install Windows alongside Manjaro? I won’t be the only person using this laptop, and the other person needs Windows. Thank you!

Change firmware and disable EFI

Then verify that Windows loads when EFI is disabled - just to avoid an unpleasant surprise.

You can install as dual-boot but you cannot use the partition schema from the linked guide - just disable EFI in firmware - and restart Manjaro then select install alongside - it will work.


I’d want to try to do that now, but I don’t really know what you mean by “change firmware, and disable EFI”, I’m sorry. Would you mind explaining it to a newbie? Thank you so much. If it’s too much, I’ll look online for it :slight_smile:

Reverse the legacy boot option and disable EFI or set legacy as primary.

BIOS is the old term - as the bios actually handled the devices attached

(U)EFI is the new term - as the firmware now only provides interfaces which the operating system handles.


This is what it looks like now.
I’m not sure where I can disable EFI :thinking:

Enable the Legacy option - the one you - according to OT disabled.

When you have enabled Legacy - new options may show - options which only applies if Legacy is enabled.

1 Like

When I enable the legacy option, most other options are greyed out, and I can’t change them. The only options not greyed out are cd rom boot, internal network adapter boot, usb boot, and legacy support.

Then save the options and reboot - verify your Windows load - as you expect.

Restart your system with an USB attached and load Manjaro.

Open a terminal and execute this command

$ sudo fdisk -l /dev/sda

Use your mouse to select the text in the terminal.
Open this topic and click the Reply button

Format the reply like this


Line 1
Line 2
Line 3


The output will help us determine if your disk is partitioned using MBR - then we will be able to advise what to do next.

1 Like
Disk /dev/sda: 465.76 GiB, 500107862016 bytes, 976773168 sectors
Disk model: TOSHIBA MQ01ABF0
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: dos
Disk identifier: 0x121e59c3

Device     Boot     Start       End   Sectors   Size Id Type
/dev/sda1  *         2048    718847    716800   350M  7 HPFS/NTFS/exFAT
/dev/sda2          718848 488743936 488025089 232.7G  7 HPFS/NTFS/exFAT
/dev/sda3       488743937 976768064 488024128 232.7G  7 HPFS/NTFS/exFAT

Partition 3 does not start on physical sector boundary.

1 Like

You need to install Manjaro in MBR mode.


Is there a guide on how to do that? If I’m perfectly honest, I don’t really know the difference still, but I can learn that. Would it be less of a hassle if I formatted the hard drive to GPT?
By the way thanks a mil for all your replies

I am pretty sure your previous attempts has been due to disabling Legacy which forces Manjaro to load in EFI mode - and then the installation fails because the disk is setup using MBR.

You should be able to run the install from A-Z by following the graphical installer guide. (if in doubt during installation - avoid anything EFI/GPT related).

It looks like - your disk is already partitioned

  • sda1 is windows bootloader troubleshooting files
  • sda2 - probably your windows system
  • sda3 - could look like the second half of a dual-boot disk but with the wrong filesystem

I think the installer has the option to replace a partition - and using sda3 looks like the ideal choice - but - you are the user - you know what is on the disk - so don’t take my word for it - check it.

The installer may ask where to install the boot loader - select your internal disk - /dev/sda - and you should be off in no time.


Thanks, I’m going to try to do it now. sda3 is where I tried to install manjaro previously, so I’ll use that. Will report in case something goes wrong. Thank you for your time, you’ve been extremely helpful.

1 Like

No luck still, the installer didnt ask where to install the bootloader, when I clicked replace a partition it just did its thing. And I got the following message again:

Boost.Python error in job "bootloader".
Command 'grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=Manjaro --force' returned non-zero exit status 1.
Installing for x86_64-efi platform. grub-install: error: /boot/efi doesn't look like an EFI partition.

File "/usr/lib/calamares/modules/bootloader/main.py", line 476, in run

  File "/usr/lib/calamares/modules/bootloader/main.py", line 448, in prepare_bootloader
    install_grub(efi_directory, fw_type)

  File "/usr/lib/calamares/modules/bootloader/main.py", line 310, in install_grub

  File "<string>", line 5, in <module>

This is slightly frustrating, but I don’t want to quit until it’s been resolved :frowning:

first identify your windows install
boot into windows and hit Super (Win Logo button} + RUN
when run dialogue open, type msinfo32 and check bios if its legacy OR uefi.
this will help you install manjaro on the same lines

1 Like

The error is because your system boots in EFI mode - you need to find a way to make it boot in BIOS mode. When the disk is MBR partition style - installing efi style will fail - they cannot coexist.

This is why I was mentioning - disable EFI - but from your previous comment it appears it is not possible.

And why I mentioned - stay away from efi/gpt related options - if the installer tries to use efi select bios/mbr.