Wake on Lan Manjaro systemd Service startet nicht?

Hallo!
Ich hatte bis vor kurzem Ubuntu Desktop 20.04 im Einsatz jedoch war die Performance und ein paar weitere Dinge nicht so überzeugend. Manjaro läuft demgegenüber sehr flüssig und schnell.

Ich würde gerne wie auch bisher bei Ubuntu wieder Wake on Lan aktivieren.

sudo nano /etc/systemd/system/wol.service

[Unit]
Description=Configure Wake On LAN

[Service]
Type=oneshot
ExecStart=/sbin/ethtool -s enp12s0 wol g

[Install]
WantedBy=basic.target
sudo systemctl daemon-reload
sudo systemctl enable wol.service
sudo systemctl start wol.service

Bei einer Überprüfung mit:
sudo ethtool enp12s0

Wird der Wert hierbei auch korrekt angepasst. Leider steht nach einem Neustart jedoch Wake-on bei dem Netzwerkgerät trotzdem immer wieder auf d. Das Aufwecken des Gerätes klappt nicht, wie zuvor bei Ubuntu.

Ich habe es auch schon über die hier beschriebene Variante probiert:

https://wiki.archlinux.org/index.php/Wake-on-LAN#systemd_service

Dies scheint aber auch überhaupt nicht zu funktionieren:

/usr/bin/ethtool -s %i wol g
netlink error: No such file or directory
Cannot get current wake-on-lan settings: No such device
  not setting wol

Habt ihr einen Tipp? Vielen Dank!

Wie im Arch Wiki beschrieben ist eigentlich ein guter Weg. Bei deinem Service gibt es überhaupt keine Abhängigkeiten, dadurch wird der Service wahrscheinlich viel zu früh aktiviert.

Am besten der Service wie im Arch wiki beschrieben erstellen und aktiveren. Das %i ist nur eine Variable die systemd automatisch mit dem Wert hinter dem @ beim Service ersetzt.
Also Service erstellen ( /etc/systemd/system/wol@.service ), systemd Dämon neu laden und den Service aktiveren.

systemctl enable --now  wol@enp12s0.service

Funktioniert natürlich nur so wenn dein Netzwerk Device auch wirklich enp12s0 heißt.

Hallo xabbu,

ich habe es auch gerade einmal genau wie dort beschrieben probiert mit neuladen & enable Befehl von dir. Dann das Notebook heruntergefahren und es ging per WOL leider wieder nicht an. Nach dem Login nachgeschaut und es steht weiter d:

[usr1@manjaro-nb ~]$ sudo ethtool enp12s0
[sudo] Passwort für usr1: 
netlink error: No such file or directory
Settings for enp12s0:
	Supported ports: [ TP MII ]
	Supported link modes:   10baseT/Half 10baseT/Full 
	                        100baseT/Half 100baseT/Full 
	                        1000baseT/Half 1000baseT/Full 
	Supported pause frame use: Symmetric Receive-only
	Supports auto-negotiation: Yes
	Supported FEC modes: Not reported
	Advertised link modes:  10baseT/Half 10baseT/Full 
	                        100baseT/Half 100baseT/Full 
	                        1000baseT/Half 1000baseT/Full 
	Advertised pause frame use: Symmetric Receive-only
	Advertised auto-negotiation: Yes
	Advertised FEC modes: Not reported
	Link partner advertised link modes:  10baseT/Half 10baseT/Full 
	                                     100baseT/Half 100baseT/Full 
	                                     1000baseT/Half 1000baseT/Full 
	Link partner advertised pause frame use: No
	Link partner advertised auto-negotiation: Yes
	Link partner advertised FEC modes: Not reported
	Speed: 1000Mb/s
	Duplex: Full
	Port: MII
	PHYAD: 0
	Transceiver: external
	Auto-negotiation: on
	Supports Wake-on: pumbg
	Wake-on: d
	Current message level: 0x00000033 (51)
			       drv probe ifdown ifup
	Link detected: yes

Wenn ich jedoch

sudo systemctl start wol@enp12s0.service

sage und dann nachschaue, steht korrekterweise wieder das g drin.
Es scheint also nach wie vor einfach nicht mitzustarten.

Zu welchem Zeitpunkt startet der Service denn? Gibt es irgendeinen Log Eintrag im journal? Und was passiert wenn du mit einem ExecStartPre mit sleep den start etwas hinaus zögerst?

Ich habe es gerade einmal so probiert:

[Service]
ExecStartPre=/bin/sleep 15
ExecStart=/usr/bin/ethtool -s %i wol g
Type=oneshot

Leider kommt das NB so auch nicht per WOL zum Leben. Auch einige Zeit nach Systemstart bleibt es weiter bei:

Wake-on: d

Ausgabe:
journalctl -a -p err -b

Jul 30 23:41:52 manjaro-nb kernel: kvm: disabled by bios
Jul 30 23:41:52 manjaro-nb kernel: kvm: disabled by bios
Jul 30 23:41:52 manjaro-nb kernel: kvm: disabled by bios
Jul 30 23:41:52 manjaro-nb kernel: kvm: disabled by bios
Jul 30 23:41:52 manjaro-nb kernel: kvm: disabled by bios
Jul 30 23:41:52 manjaro-nb kernel: kvm: disabled by bios
Jul 30 23:41:52 manjaro-nb kernel: kvm: disabled by bios
Jul 30 23:41:52 manjaro-nb kernel: kvm: disabled by bios
Jul 30 23:41:52 manjaro-nb kernel: Bluetooth: hci0: unexpected event for opcode 0x0000
Jul 30 23:43:05 manjaro-nb lightdm[1015]: gkr-pam: unable to locate daemon control file
Jul 30 23:43:13 manjaro-nb kernel: snd_hda_codec_hdmi hdaudioC1D0: out of range cmd 0:5:707:ffffffff
Jul 30 23:43:13 manjaro-nb kernel: snd_hda_codec_hdmi hdaudioC1D0: out of range cmd 0:5:707:ffffffbf
Jul 30 23:43:13 manjaro-nb kernel: snd_hda_codec_hdmi hdaudioC1D0: out of range cmd 0:5:707:ffffffff
Jul 30 23:43:13 manjaro-nb kernel: snd_hda_codec_hdmi hdaudioC1D0: out of range cmd 0:5:707:ffffffbf

Ich wurde doch noch fündig. Es liegt am TLP, der WOL immer wieder deaktiviert.
Zudem: Mit Linux Kernel 5.7.9-1 funktioniert es nicht. Jedoch mit 5.4.52-1

Nun funktioniert es endlich! :slight_smile:

Forum kindly sponsored by