Vulkan with Nvidia 390.157


On my old laptop I use manjaro with gtx460m and nvidia driver 390.157.
This driver is the latest version compatible with gtx460m and it allows me to do short video productions.

3 years ago on the same laptop I run Kubuntu and I was able to play using steam and vulkan from nvidia proprietary driver from nvidia.

However under Manjaro I use the standard mhwd -a pci video-nvidia-390xx driver.
I installed later on the vulkan-nvidia drivers, tools using:

sudo pacman -Syu vulkan-icd-loader
sudo pacman -Syu vulkan-validation-layer
sudo pacman -Syu vulkan-tools

However I’m not able to run vulkan layer with steam.

I know that vulkan driver is included into proprietary driver from nVidia 390.157, but if I installed it, manjaro boot and freeze (black screen) and manjaro never displays login session. I can boot in consol mode but graphic session does not run and freezes.

Any idea how can I solve it ?


390xx has no vulkan support. 470xx and above has it. Looks like this card is supported by 470xx. I was wrong it is only supported by 390xx.

Appendix A. Supported NVIDIA GPU Products

According to Vulkan Driver Support | NVIDIA Developer, 390.157 should include Vulkan 1.3 support…
or did I understand it wrong ?

@alain.roger well you right. I should rephrase it: The driver 390xx has not enough support for Vulkan API, so that it can work with modern wine/proton when using DXVK or VKD3D. Look how much was added between 390xx and 470xx. Proton needs at least 470xx to work properly and that can change in the future. Anyway, you can switch to OpenGL Layer anytime.


January 25th, 2022 - Windows 473.11, Linux 470.62.22

I would be happy to be able to install nvidia 470 but manjaro does not allow to make it work with gtx460m.
When I tried, system send message at boot that gtx460m is not supported with nvidia 470 after using mhwd -i pci video-nvidia-470xx command line

I’m wondering if proprietary nvidia 470 driver would support gtx460 and avoid boot message I have with driver 470 supplied by manjaro system

Sorry for the misleading advise. I simply misread that your card is not supported. Also in the docs. See above.

Your card just have no support for vulkan 1.3, which is the default on Manjaro. Even 1.2 is not supported. Therefore OpenGL is the only way for you on Linux.