VS Code Package Issuses

I have little to no experience operating and navigating a linux OS so if my question seems like a joke it’s not, I’m genuinely confused and have tried everything to fix it.

Whenever I try to update my packages this error message comes up:

vscode.db failed to download
error: failed retrieving file ‘vscode.db’ from packages.microsoft. com : The requested URL returned error: 404
error: failed to synchronize all databases (failed to retrieve some files)

I have tried to update it normally in my package manager as well but a “failed to find a database” error message comes up.

I have looked everywhere on laptop and could not find any references or dependencies on vscode and looked at my package manager to try and deselect any packages of vscode but could not find any, would appreciate the help as to why this is happening.

For some context I installed a version of vscode , deleted it and then this error started to come up.

Some information about my system/OS:


  • KDE Plasma Version; 5.27.4
  • KDE Frameworks Version: 5.104.0
  • Qt Version: 5.15.8
  • Kernel Version: 6.1.25-1-MANJARO (64-bit)
  • Graphics Platform: X11


  • Processors: 4 × Intel® Core™ i7-6600U CPU @ 2.60GHz
  • Memory: 19.4 GiB of RAM
  • Graphics Processor: Mesa Intel® HD Graphics 520
  • Manufacturer: LENOVO

Welcome to the forum! :vulcan_salute:

This suggests that packages.microsoft. com got added to your mirror list somehow.

Hmm… So that’s the culprit then, although it shouldn’t have done that. :thinking:

The two files you should check for any mention of the Microsoft server are… :arrow_down:

  • /etc/pacman.conf
  • /etc/pacman.d/mirrorlist

Both are plain-text files that you can open in an editor. I would suggest looking at those files, removing any reference to the Microsoft server — the syntax of the files should be easy enough to understand — and saving the file(s) again.

Most GUI editors are polkit-aware and will prompt you for the administrative password when saving the file(s), because both of those files are root-owned.

In the event of doubt regarding the editing of those files, just copy/paste the relevant sections here — no screenshots, please — and then we’ll take it from there.

1 Like

Thank you Aragorn your solution helped me find the problem it was in /etc/pacman.conf, much appreciated, you saved me a lot of stress and I will be returning to this site if any future issues come up.

1 Like

Actually, it would benefit you to visit this forum on a regular basis, and to subscribe for notifications to the Stable Updates category, because every major update — of which there are on average two per month — comes with a dedicated announcement thread, which will highlight some of the important changes and possible caveats.

Also, since you’ve now managed to get rid of the disruptive error message, I would advise you to update both your mirror list and your system… :arrow_down:

sudo pacman-mirrors -f 5 && pamac update


1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.