Vorta error since last Manjaro (stable) update ?

❰greg❙~❱✔≻ vorta
Traceback (most recent call last):
  File "/usr/bin/vorta", line 6, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python3.8/site-packages/pkg_resources/__init__.py", line 3252, in <module>
    def _initialize_master_working_set():
  File "/usr/lib/python3.8/site-packages/pkg_resources/__init__.py", line 3235, in _call_aside
    f(*args, **kwargs)
  File "/usr/lib/python3.8/site-packages/pkg_resources/__init__.py", line 3264, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/lib/python3.8/site-packages/pkg_resources/__init__.py", line 583, in _build_master
    ws.require(__requires__)
  File "/usr/lib/python3.8/site-packages/pkg_resources/__init__.py", line 900, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python3.8/site-packages/pkg_resources/__init__.py", line 786, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'vorta==0.6.23' distribution was not found and is required by the application

❰greg❙~❱✘≻ yay -Qi vorta
Name : vorta
Version : 0.6.23-1
Description : A GUI for BorgBackup
Architecture : any
URL : https://github.com/borgbase/vorta
Licenses : GPL
Groups : None
Provides : None
Depends On : borg python-appdirs python-apscheduler python-pyqt5 python-peewee python-paramiko python-dateutil python-keyring python-psutil python-llfuse python-qdarkstyle
Optional Deps : None
Required By : None
Optional For : None
Conflicts With : None
Replaces : None
Installed Size : 1286.00 KiB
Packager : Unknown Packager
Build Date : Thu 10 Oct 2019 20:52:04 BST
Install Date : Wed 11 Dec 2019 09:07:10 GMT
Install Reason : Explicitly installed
Install Script : No
Validated By : None

System: Host: greg-pc Kernel: 4.19.88-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.0 Desktop: KDE Plasma 5.17.4
Distro: Manjaro Linux
Machine: Type: Laptop System: Dell product: Inspiron 5767 v: N/A serial:
Mobo: Dell model: 03XWWJ v: A00 serial: UEFI [Legacy]: Dell v: 1.0.0 date: 07/14/2016

Hope someone can help out , thx.

Did you try to re(build/install) it ?

yep, i did. Although im not sure i did a clean build maybe i should try that.

Na did not change anything.

Have you also try to reinstall

python-apscheduler
python-helpdev
python-qdarkstyle

as per one of the comments in the AUR package page?

ok tried
yay -S python-qdarkstyle python-helpdev python-apscheduler

It reinstalled them all but still same vorta python error.

Someone mentioned this on the stable announcement


I suppose you restarted the system after update. As about this error

i found a few references but not sure how would apply to your issue ...

Yes i always reboot after a system update but i have just rebooted again.

What are you suggesting here? should i run this "small script" below ?

Not quite sure how that works, but since is related to python3.8 changes, maybe is related. Still looking to get the big picture.

No, I don't think it may help you in your case. It is aimed only at Python developers working with virtualenvs, not at end users.

1 Like

odd i reinstalled vorta again and this time i get a slightly differant error

❰greg❙~❱✔≻ vorta
Traceback (most recent call last):
  File "/usr/bin/vorta", line 6, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python3.8/site-packages/pkg_resources/__init__.py", line 3252, in <module>
    def _initialize_master_working_set():
  File "/usr/lib/python3.8/site-packages/pkg_resources/__init__.py", line 3235, in _call_aside
    f(*args, **kwargs)
  File "/usr/lib/python3.8/site-packages/pkg_resources/__init__.py", line 3264, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/lib/python3.8/site-packages/pkg_resources/__init__.py", line 583, in _build_master
    ws.require(__requires__)
  File "/usr/lib/python3.8/site-packages/pkg_resources/__init__.py", line 900, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python3.8/site-packages/pkg_resources/__init__.py", line 786, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'qdarkstyle' distribution was not found and is required by vorta

so before i was getting

pkg_resources.DistributionNotFound: The 'vorta==0.6.23' distribution was not found and is required by the application

now i get

pkg_resources.DistributionNotFound: The 'qdarkstyle' distribution was not found and is required by vorta

well i have no clue what just happened but after i see the error had changed i just thought meh.. if its mentioning qdarkstyle i shall reinstall it on its own, so i did.

Then vorta throws this
pkg_resources.DistributionNotFound: The 'apscheduler' distribution was not found and is required by vorta

so next i reinstall python-apscheduler and get
pkg_resources.DistributionNotFound: The 'helpdev>=0.6.2' distribution was not found and is required by qdarkstyle

After reinstalling python-helpdev it darn well works again :checkered_flag:

I definataly already had all these installed and i definataly reinstalled them when ask to a few posts up, very wearied.

Thank You @JackDinn for getting this far.
Mine still refused to believe qdarkstyle was reinstalled. After several times somehow it stuck, and now I have

pkg_resources.DistributionNotFound: The 'secretstorage' distribution was not found and is required by vorta

aka python-secretstorage, which was already installed. Reinstall didn't change anything

from shell:

pip3 install --user vorta

finally that works.

Forum kindly sponsored by