VMWare - Can't change screen resolution

I used to run in Windows 10, there was definitely a view menu somewhere.

Below is a screenshot that shows the view menu on Windows. If your VM is full-screen it is probably tucked away in the bar at the top.

Here's what my window looks like. I tried under the 'player' menu, but nothing about displays.

That is vmware player. I am less familiar with that.

Off the top of my head there are a few things that play into this:

  • The open-vm-tools have to be installed and running - They are installed by default and appear to be running from the above output you provided
  • You need to be using video-vmware - Your inxi shows that this is the case
  • In vmware you need to be auto-fitting guests - Not clear how to check that in vmware player
  • The display settings for the vm to be set. It is interesting that Accelerate 3D graphics is greyed out but that should be needed in vmware. At least it isn't in workstation pro.

Accelerate 3D is grayed out because the VM is running. I shut it down and tried enabling it, no change.

I tried the other option in there to 'specify monitor settings' and changed that to 1280 X 1024. I can now make the VM window wider, but it won't let me resize horizontally.

One other setting that might matter:

There's a setting for the type of Linux. I have 'Other Linux 4.x or later kernel 64-bit'. There's no option for Manjaro or Arch.

I believe that is used when you create the VM to set defaults, I don't think it matters much on a running VM.

Have you tried making sure the guest is fully up-to-date and rebooting? It is strange that it did work and then stopped.

I found instructions to convert a Vmware image to Virtualbox. I'm running that right now, will try it in Virtualbox.

Yes, I ran all the updates before I started using the VM.

I did try updating the video drivers on the host (new NVidia drivers out today) and rebooted. No help.

Make sure you use the VGA Adaptor(not svga) and enable 3D acceleration.

Once you get into the system you may need to use mhwd to install the proper drivers.

After that follow these instructions:
https://wiki.manjaro.org/index.php?title=VirtualBox#Running_Manjaro_under_VirtualBox

1 Like

Already set to VboxVGA. I turned on 3D acceleration, now it will boot to a menu where I can select Manjaro 18 (or something similar), but then boots to a black screen. I'll look at that page you referenced later. Assuming I'll need to boot to command line and install the driver.

1 Like

So the install in VMware definitely seemed to be glitchy. Sometimes I could re-size the window, but most of the time I couldn't.

I ended up doing a clean install using Virtualbox and choose the accelerate 3D and VboxVGA. It's been working flawlessly.

Virtualbox seems to have more, useful settings. Makes VMware Workstation seem like a stripped down version.

1 Like

That is because VMWare Workstation Player is a stripped down version. :smile:

1 Like

Hello,

I have the same problem, with a little digging i found out that doing when the session is opened :

systemctl stop vmtoolsd.service
systemctl start vmtoolsd.service

The resolution adapts to the screen.

There is probably a solution by editing the service file (like in this post)

But I didn't find a working solution yet

2 Likes

It seems to work by adding in this file /usr/lib/systemd/system/vmtoolsd.service

After=display-manager.service
At the end of the [Unit] part.

I had to close completely the player and restart the vm, the resolution adapts with the size of the window now.

I ended up setting it up in VBox and deleted the VMWare image. I'm liking VBox more, seems more consistent.

where is the unit part though? at the end? im having the same problem. cant go higher than f**king 800x600.

Yes, these steps resolved the issue for me as well (using VMware player 15 something) and adding the After… to /usr/lib/systemd/system/vmtoolsd.service, the content is now:

[Unit]
Description=Open Virtual Machine Tools (VMware Tools)
ConditionVirtualization=vmware
After=display-manager.service

[Service]
ExecStart=/usr/bin/vmtoolsd

[Install]
WantedBy=multi-user.target

@Infinite-Dao

i just did that and it didnt solve the problem. I am using vmware workstation 15 with latest Manjaro KDE version. Everytime i change the resolution it changes for half a second and jumps back to 800x600 >-<

@Infinite-Dao

Thank you so much. This fixed two separate issues I've been having. First, this fixed the display not being able to find the correct resolution, or auto resize.

Second, this fixed my dual monitor setup. Previously, whenever I tried to use 'Cycle multiple monitors', I would get an error:

"..cannot use multiple monitors..virtual machine must have up-to-date VMware Tools installed and running"

Now it works as expected. You're a life saver.

Also, if on a Mac, don't enable vmware settings 'Use full resolution for Retina display'.

Forum kindly sponsored by