Vmlinuz-5.10-x86_84 not found

hello everyone
today I tried to install a program using pamac and it started a pamac update, during the process I hit the wire and the computer shut down.
this error: “vmlinuz-5.10-x86_84 not found” appears during boot, I’ve tried booting from the live cd and running manjaro-chroot -a. but when I type this in the terminal nothing appears, no error, no message at all.
someone can save me here hahaha, thanks!

Try mounting the relevant partitions first, such as /, /boot, and /boot/efi

Nesting them under /mnt/ is standard practice in a live USB session.

So it might look like,

  • root parition → /mnt
  • boot partition → /mnt/boot/ (not always applicable, depends on your setup)
  • efi partition → /mnt/boot/efi

You can follow this by manually pointing to the mounted root partition,

manjaro-chroot /mnt

Was it doing a full system update? If so, to play it safe, I would not only rebuild the initramfs and grub bootloader, but also force re-install all packages, and then force another update with pamac/pacman, while still in the chroot.

1 Like

Did you become root before you tried that? :arrow_down:

sudo su -
manjaro-chroot -a


yes i became root before trying this

I read this thread, but I’m having trouble executing manjaro-chroot command

Try mounting first, then executing manjaro-chroot.

the root partition is sda2, correct? how do I find out which is the boot partition and which is the efi?

sda 8:0 0 931.5G 0 disk
├─sda1 8:1 0 300M 0 part
├─sda2 8:2 0 922.4G 0 part
└─sda3 8:3 0 8.8G 0 part

300 MB in size is a dead giveaway it’s the EFI partition.

Doesn’t look like you have a separate boot partition, only efi and root (sda2, 922 GB)

Not sure what sda3 is. Perhaps swap? Not needed for a recovery.

In essence, you only need to mount root and efi, at /mnt/ and /mnt/boot/efi respectively.

alright, already mount the root and efi partition and ran manjaro-chroot /mnt

You can use pamac in the terminal while in chroot.

I would,

  • reinstall everything
  • update everything
  • rebuild initramfs and update grub

Exit chroot, reboot.


and how I do it? lol

pamac’s syntax is straight-forward, and uses more intuitive terms than pacman.

I haven’t had to resort to this in a while, but I believe it’s something like:

pamac reinstall *

pamac update --force-refresh

mkinitcpio -P


Hope you didn’t catch that earlier typo!

The above should force pamac to reinstall everything, then update the database, then install all available package updates, then rebuild the initramfs, then update Grub’s menu.

nothing happens

[manjaro@manjaro ~]$ sudo manjaro-chroot /mnt
sh-5.1# pamac reinstall *
sh-5.1# pamac update --force-refresh


What about: pamac --version

nothing either.
the pacman works
sh-5.1# pacman --version

.–. Pacman v6.0.1 - libalpm v13.0.1
/ _.-’ .-. .-. .-. Copyright (C) 2006-2021 Pacman Development Team
\ '-. ‘-’ ‘-’ ‘-’ Copyright (C) 2002-2006 Judd Vinet
This program may be freely redistributed under
the terms of the GNU General Public License.

Oh interesting. Alright, old-school style, use pacman instead. :sauropod:

pacman -Qqn | pacman -S -
pacman -Syyu

Then proceed with rebuilding the initramfs and grub menu.

sh-5.1# pacman -Qqn | pacman -S -
pacman -Syyu
error: failed to init transaction (unable to lock database)
error: could not lock database: File exists
if you’re sure a package manager is not already
running, you can remove /var/lib/pacman/db.lck
:: Synchronizing package databases…
error: failed to synchronize all databases (unable to lock database)

Go ahead and remove the lock file.

It might have been due to the sudden power outage during an update.

UPDATE: Which might explain the odd behavior with pamac earlier. You said you accidentally unplugged the power from the wall in the middle of a system update, yes?

Can you remove the lock file and then try again with pamac just out of curiosity?

Otherwise, continue with pacman.

resolving dependencies…
looking for conflicting packages…
error: could not open file /var/lib/pacman/local/python-cryptography-3.4.8-2/desc: No such file or directory
warning: could not fully load metadata for package python-cryptography-3.4.8-2
error: failed to prepare transaction (invalid or corrupted package)

nothing happens

Skip the reinstall step. Just force a database refresh and update:

pacman -Syyu

Something’s really odd.

sh-5.1# mkinitcpio -P
==> ERROR: No presets found in /etc/mkinitcpio.d