VM with Manjaro CLI on ESX, fails to get an IP

I tried to create a VM on ESX 6.0 VM specifications are:
4BG of RAM
100G HDD Thick provisioned Lazy Zero
EthernetNIC is configured in a vSwitch that has connectivity to internet.

I used the manjaro-architect-20.0.3-200607-linux56.iso from the manjaro website
I have chosen linux 54 as the kernel and below packages:
Kernel virtualbox guest modules
Kernel virtualbox host modules

I installed the CLI version.

When the machine boots, it fails to get any IP.

Did anyone face similar issue ? Can anyone help me debug this problem ? Should I install some new packages during the installation ?

I tried giving the inxi command as shown in another post on this forum, but in my console it is giving me an error stating that
‘’’-bash: inxi: command not found’’’

I’m not sure if any network software is automatically enabled if you choose the very basic CLI flavor.
Did you checked if any is installed and enabled?

On a headless system, systemd-networkd works good. Read up on how to configure it and don’t forget to enable it.