VLC high CPU usage on 1080p and 4k Videos. i3-6100 processor

Updating to 1.0 sec doesn’t affect usage at all. I mentioned that smplayer alone used 85%.

libva 1.7.3-1
libva-intel-driver 1.7.3-1

I don’t have it installed. I will install and post my results.

The results are same even after installing libva-mesa-driver

I’m out of ideas then, sorry :slight_smile:

Have you tried it?
I think you need libva-vdpau-driver and check what vdpauinfo sais after restart!
https://wiki.archlinux.org/index.php/Hardware_video_acceleration#Configuration

1 Like

Thanks for your support.

1 Like

I have tried it and the MPV player plays 4k much better than VLC. CPU dropped down from 75% to around 50%.

Great, so that is the maximum it can do?! Do you have x265 installed?

I think installing VLC does the job of installing x265. Right?

export VDPAU_DRIVER=va_gl
vdpauinfo
display: :0 screen: 0
Failed to open VDPAU backend libvdpau_va_gl.so: cannot open shared object file: No such file or directory
Error creating VDPAU device: 1
Well it reduced CPU%. But somehow the vdpauinfo failed.

Yes, I think but check it pls with pacman.

printenv | grep VDPAU
VDPAU_DRIVER=va_gl

I checked with pamac and it’s installed.

I think you need a restart.
https://bugs.launchpad.net/ubuntu/+source/libvdpau/+bug/1300215

Do intel CPUs use VA-API or VDPAU?

I am gonna reboot and post.

I rebooted and still get the same error message.
display: :0 screen: 0
Failed to open VDPAU backend libvdpau_va_gl.so: cannot open shared object file: No such file or directory
Error creating VDPAU device: 1

mpv --hwdec=vaapi 4k.mp4
Finally I tried pure mpv from terminal CPU usage dropped down to 6%. VA-API is preferrable over VDAPU for intel GPU. Thanks for assisting me.

1 Like

I had also switched to mpv from VLC. On wayland there is no VDPAU support yet, only VAAPI which is running well with mpv.

1 Like

Use smplayer using mpv as the multimedia engine. Then go to options>preferences>general>video choose the output driver as vaapi and check the direct rendering box, apply and restart playing the video. You should see much less cpu usage when playing 4K videos. That’s how i overcome that problem.