VLC high CPU usage on 1080p and 4k Videos. i3-6100 processor

Running manjaro for over a week, I came across this. When I try to play 1080p videos in VLC, the CPU usage for VLC alone rises to 25%. Worse it rises to around 60%(H264) on playing 4K videos. The processor supports Hardware Level h265 decoder. I have enabled Hardware Acceleration in VLC, but the issue isn’t gone. I installed drivers from the manjaro settings manager.

Edit: I have tried various methods and still couldn’t figure out exactly what is causing the problem? or Is it normal for an i3 - 6100 to spike to 75%(HEVC) on VLC when playing a 4k motion graphic video with a bitrate of 2500kbps?

Also I want to know if any of you guys have properly configured an Skylake Integrated Graphics for optimal performance?
If then what are the steps in doing so?

Try smplayer. In the preferences dialog, click performance, then set hardware accelerated decoding to Auto.

Do you have libva-intel-driver installed?

Yeah yes

Do you have va-api selected in VLC (under input/codecs)?

I’ve got similar results, just downloaded a sample 4k video and played it in vlc with nvidia proprietary drivers and full vdpau stack.


As you can see it’s pretty harsh on my 4.4 ghz i5. So I think you’re pretty much in the norm here with your results.

VDPAU is the default acceleration method, since VLC 2.2, so you need to install and enable it in your system.
https://wiki.videolan.org/VLC_GPU_Decoding/

Actually we still don’t know which graphics card OP uses. Vdpau is for nvidia, vaapi is for amd and intel. Since he didn’t mention anything other than i3-6100 I assume he’s using built-in gpu.

I am using the IGPU.

I played with VA-API enabled and video drops frames and uses around 70% CPU( total CPU usage around 90%).

You could try mpv-based player like ben81 suggested, see if that makes any difference. I googled a bit and this kind of CPU hits upwards of 50% use with 4k video playback even on windows platform.

Tried vlc --avcodec-hw=vaapi and the output on the terminal is like this.
Failed to open VDPAU backend libvdpau_va_gl.so:

What does it mean?

Gonna give smplayer a try. Will reply with the results.

smplayer is much worse than VLC. It alone uses 85% of CPU>

I’m confused by this, why is it complaining about vdpau? Do you have any vdpau packages installed?
What’s the output of
pacman -Q | grep vdpau

libvdpau 1.1.1-2. I was out doing some errands. sry for the late reply.

I think you need libva-vdpau-driver and check what vdpauinfo sais after restart!
https://wiki.archlinux.org/index.php/Hardware_video_acceleration#Configuration

That probably got pulled in as a dependency of ffmpeg’s.
In similar fashion, what does it say for:
pacman -Q | grep libva
Do you have libva-mesa-driver installed?

Just to note that, task manager itself uses cpu, change system load tab update interval to 1.0 sec, also I am using SMPlayer, and uses ~10 precent on old intel core 2 2600.

I had a similar issue with SMPlayer and solved it by chosing XV under Preferences/General/Video/Output driver.

1 Like

Well it reduced my CPU Usage from 85% to under 60%. Can you suggest any settings for VLC? Coz I prefer VLC and have been using it for a long time.