VLC closed after opening video files

Hello I am trying to use VLC to watch videos but after I open one video there is a segmentation falt error:

░▒▓    ~  vlc file:///home/anderson/Downloads/aula3.ts 
VLC media player 3.0.18 Vetinari (revision 3.0.13-8-g41878ff4f2)
[0000555e60ce7550] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
[00007f5b84ceecf0] mpeg4audio packetizer: AAC channels: 2 samplerate: 44100
[00007f5b60007a60] gl gl: Initialized libplacebo v4.208.0 (API v208)
libva error: /usr/lib/dri/i965_drv_video.so init failed
[00007f5b60007a60] glconv_vaapi_x11 gl error: vaInitialize: unknown libva error
libva error: /usr/lib/dri/i965_drv_video.so init failed
[00007f5b60007a60] glconv_vaapi_drm gl error: vaInitialize: unknown libva error
libva error: /usr/lib/dri/i965_drv_video.so init failed
[00007f5b60007a60] glconv_vaapi_drm gl error: vaInitialize: unknown libva error
zsh: segmentation fault (core dumped)  vlc file:///home/anderson/Downloads/aula3.ts

I found in ArchWiki maybe it can be the VAAPI init failed but when I tried to remove the DISPLAY and open all things closed including the terminal. This is my session type:

 ░▒▓    ~  echo $XDG_SESSION_TYPE                                                                                                                                                                                

And this is my inxi -Fazy, I think maybe there is something misconfigured in my video drivers.

  Kernel: 6.1.1-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-6.1-x86_64
    root=UUID=52fa92b3-346f-49d0-8451-85818eabe887 rw rootflags=subvol=@ quiet
    splash apparmor=1 security=apparmor
    resume=UUID=a77cec8e-084c-42b3-a4e9-83bcb4d4d329 udev.log_priority=3
  Desktop: GNOME v: 43.2 tk: GTK v: 3.24.36 wm: gnome-shell dm: GDM v: 43.0
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Dell product: Inspiron 5402 v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Dell model: 0FJYHK v: A00 serial: <superuser required> UEFI: Dell
    v: 1.8.0 date: 10/01/2021
  ID-1: BAT0 charge: 45.6 Wh (100.0%) condition: 45.6/53.0 Wh (85.9%)
    volts: 16.5 min: 15.0 model: BYD DELL TXD0316 type: Unknown serial: <filter>
    status: full
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse MX Master 3
    serial: <filter> charge: 100% (should be ignored) rechargeable: yes
    status: discharging
  Info: model: 11th Gen Intel Core i7-1165G7 bits: 64 type: MT MCP
    arch: Tiger Lake gen: core 11 level: v4 note: check built: 2020
    process: Intel 10nm family: 6 model-id: 0x8C (140) stepping: 1
    microcode: 0xA6
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 320 KiB desc: d-4x48 KiB; i-4x32 KiB L2: 5 MiB desc: 4x1.2 MiB L3: 12 MiB
    desc: 1x12 MiB
  Speed (MHz): avg: 1000 high: 1188 min/max: 400/4700 scaling:
    driver: intel_pstate governor: powersave cores: 1: 1188 2: 1078 3: 973
    4: 1181 5: 883 6: 950 7: 612 8: 1135 bogomips: 27040
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
    filling, PBRSB-eIBRS: SW sequence
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] vendor: Dell driver: i915
    v: kernel arch: Gen-12.1 process: Intel 10nm built: 2020-21 ports:
    active: HDMI-A-1,eDP-1 empty: DP-1 bus-ID: 0000:00:02.0 chip-ID: 8086:9a49
    class-ID: 0300
  Device-2: NVIDIA GP108M [GeForce MX330] vendor: Dell driver: nvidia
    v: 525.60.11 alternate: nouveau,nvidia_drm non-free: 525.xx+
    status: current (as of 2022-12) arch: Pascal code: GP10x process: TSMC 16nm
    built: 2016-21 bus-ID: 0000:2b:00.0 chip-ID: 10de:1d16 class-ID: 0302
  Device-3: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo
    bus-ID: 3-6:4 chip-ID: 0bda:5538 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.org v: with: Xwayland v: 22.1.7
    compositor: gnome-shell driver: X: loaded: modesetting,nvidia
    alternate: fbdev,nouveau,nv,vesa dri: iris gpu: i915 display-ID: :1
    screens: 1
  Screen-1: 0 s-res: 3840x1080 s-size: <missing: xdpyinfo>
  Monitor-1: HDMI-A-1 mapped: HDMI-1 pos: right model: AOC 27G2G5
    serial: <filter> built: 2021 res: 1920x1080 hz: 60 dpi: 82 gamma: 1.2
    size: 598x336mm (23.54x13.23") diag: 686mm (27") ratio: 16:9 modes:
    max: 1920x1080 min: 720x400
  Monitor-2: eDP-1 pos: primary,left model: BOE Display 0x082e built: 2018
    res: 1920x1080 hz: 60 dpi: 158 gamma: 1.2 size: 309x174mm (12.17x6.85")
    diag: 355mm (14") ratio: 16:9 modes: 1920x1080
  API: OpenGL v: 4.6 Mesa 22.3.1 renderer: Mesa Intel Xe Graphics (TGL GT2)
    direct render: Yes
  Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: Dell
    driver: sof-audio-pci-intel-tgl
    alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 0000:00:1f.3
    chip-ID: 8086:a0c8 class-ID: 0401
  Sound API: ALSA v: k6.1.1-1-MANJARO running: yes
  Sound Interface: sndio v: N/A running: no
  Sound Server-1: PulseAudio v: 16.1 running: yes
  Sound Server-2: PipeWire v: 0.3.63 running: no
  Device-1: Intel Wi-Fi 6 AX201 driver: iwlwifi v: kernel bus-ID: 0000:00:14.3
    chip-ID: 8086:a0f0 class-ID: 0280
  IF: wlp0s20f3 state: up mac: <filter>
  IF-ID-1: docker0 state: down mac: <filter>
  IF-ID-2: virbr0 state: down mac: <filter>
  Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB
    driver: btusb v: 0.8 bus-ID: 3-10:5 chip-ID: 8087:0aaa class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
  Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
    v: 0.6 port: N/A bus-ID: 0000:00:0e.0 chip-ID: 8086:9a0b rev: class-ID: 0104
  Local Storage: total: 476.94 GiB used: 207.32 GiB (43.5%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: A-Data
    model: IM2P33F3A NVMe 512GB size: 476.94 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 92103061 temp: 47.9 C scheme: GPT
  ID-1: / raw-size: 75 GiB size: 75 GiB (100.00%) used: 65.89 GiB (87.8%)
    fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
  ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
    used: 608 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 393.44 GiB size: 393.44 GiB (100.00%)
    used: 141.41 GiB (35.9%) fs: btrfs dev: /dev/nvme0n1p4 maj-min: 259:4
  ID-4: /var/log raw-size: 75 GiB size: 75 GiB (100.00%)
    used: 65.89 GiB (87.8%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 8 GiB used: 19.5 MiB (0.2%) priority: -2
    dev: /dev/nvme0n1p2 maj-min: 259:2
  System Temperatures: cpu: 55.0 C mobo: 52.0 C
  Fan Speeds (RPM): cpu: 2939
  Processes: 392 Uptime: 2h 22m wakeups: 4 Memory: 15.36 GiB
  used: 10.39 GiB (67.7%) Init: systemd v: 252 default: graphical
  tool: systemctl Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: 1450
  pm: pacman pkgs: 1440 libs: 328 tools: gnome-software,pamac pm: flatpak
  pkgs: 0 pm: snap pkgs: 10 Shell: Zsh v: 5.9 running-in: terminator
  inxi: 3.3.24

Somebody can help me? Thanks!

Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text


have a look here, the solution is talking about video driver.

I saw that thread, but they only say the problem is with the driver. I don´t know if I had any driver problem, I tried to reinstall my nvidia drivers, but it won´t work too.

Please post the output of the following commands using formatted text. Install libva-utils if necessary:

prime-run vainfo

Follow the results:

Trying display: wayland
Trying display: x11
libva error: /usr/lib/dri/i965_drv_video.so init failed
vaInitialize failed with error code -1 (unknown libva error),exit
prime-run vainfo
Trying display: wayland
Trying display: x11
libva error: /usr/lib/dri/i965_drv_video.so init failed
vaInitialize failed with error code -1 (unknown libva error),exit

Both printenv returned nothing:

▓    ~  printenv LIBVA_DRIVER_NAME                  3 ✘  13:42:28  ▓▒░
░▒▓    ~  printenv VDPAU_DRIVER                       1 ✘  13:42:59  ▓

What about:

LIBVA_DRIVER_NAME=nvidia prime-run vainfo

What about:
LIBVA_DRIVER_NAME=nvidia prime-run vainfo

are you saying to me to execute this command and get the results or set this as a env variable?

If you are talking about the return of this command line it’s here:

░▒▓    ~  LIBVA_DRIVER_NAME=nvidia prime-run vainfo                                                                                                                                                                
Trying display: wayland
Trying display: x11
Failed to open VDPAU backend libvdpau_va_gl.so: cannot open shared object file: No such file or directory
/usr/bin/prime-run: line 2: 53052 Floating point exception(core dumped) __NV_PRIME_RENDER_OFFLOAD=1 __VK_LAYER_NV_optimus=NVIDIA_only __GLX_VENDOR_LIBRARY_NAME=nvidia "$@"

I just installed intel-media-driver and it’s working now. VLC and vainfo…

That’s odd. libvdpau_va_gl.so is provided by libvdpau-va-gl which I do not have installed.

This is my output:

Trying display: wayland
Trying display: x11
vainfo: VA-API version: 1.17 (libva 2.17.0)
vainfo: Driver version: Splitted-Desktop Systems VDPAU backend for VA-API - 0.7.4
vainfo: Supported profile and entrypoints
      VAProfileMPEG2Simple            :	VAEntrypointVLD
      VAProfileMPEG2Main              :	VAEntrypointVLD
      VAProfileMPEG4Simple            :	VAEntrypointVLD
      VAProfileMPEG4AdvancedSimple    :	VAEntrypointVLD
      VAProfileH264ConstrainedBaseline:	VAEntrypointVLD
      VAProfileH264Main               :	VAEntrypointVLD
      VAProfileH264High               :	VAEntrypointVLD
      VAProfileVC1Simple              :	VAEntrypointVLD
      VAProfileVC1Main                :	VAEntrypointVLD
      VAProfileVC1Advanced            :	VAEntrypointVLD
      VAProfileVP9Profile0            :	VAEntrypointVLD

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.