VLC audio Stuttering when using usb headphone but it is fine on built in speaker. KDE plasma

I need to VLC to browse thru a lot of video files, but the audio Stuttering seriously when i increase the speed of playing (to save time), it only occurs when using usb headphone; it is fine on built in speaker.

What is the problem ? how to fix it ?

MSI GP602QE Laptop; KDE plasma

:+1: Welcome to Manjaro! :+1:

  1. Please read this:
    How to provide good information
    and post some more information so we can see what’s really going on. Now we know the symptom of the disease, but we need some more probing to know where the origin lies… :grin:
  2. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information for us to be able to help you. (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
    Also, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text.


P.S. If you enter a bit more details in your profile, we can also see which Desktop Environment you’re using, which exact CPU/GPU or Kernel, … you have without typing it every time

I have 3 computer, each using different manjaro kernel … hence i can’t put those detail in profile, else it will mislead people instead.

1 Like
  Kernel: 5.12.19-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.12-x86_64 
  root=UUID=0eef34c8-7ed8-4eb2-bffe-5f7e04864898 rw udev.log_priority=3 
  Desktop: KDE Plasma 5.22.4 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM 
  Distro: Manjaro Linux base: Arch Linux 
  Type: Desktop System: Micro-Star product: GP60 2QE v: REV:1.0 
  serial: <filter> 
  Mobo: Micro-Star model: MS-16GH v: REV:1.0 serial: <filter> 
  UEFI: American Megatrends v: E16GHIMS.10H date: 12/25/2014 
  ID-1: BAT1 charge: 14.9 Wh (95.5%) condition: 15.6/48.8 Wh (31.9%) 
  volts: 12.4 min: 11.1 model: MSI Corp. MS-16GH type: Unknown serial: N/A 
  status: Unknown 
  RAM: total: 15.55 GiB used: 2.07 GiB (13.3%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: Dual Core model: Intel Core i5-4210H bits: 64 type: MT MCP 
  arch: Haswell family: 6 model-id: 3C (60) stepping: 3 microcode: 28 cache: 
  L2: 3 MiB bogomips: 23154 
  Speed: 798 MHz min/max: 800/3500 MHz Core speeds (MHz): 1: 798 2: 804 3: 868 
  4: 840 
  Flags: abm acpi aes aperfmperf apic arat arch_perfmon avx avx2 bmi1 bmi2 bts 
  clflush cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm 
  dts epb ept ept_ad erms est f16c flexpriority flush_l1d fma fpu fsgsbase 
  fxsr ht ibpb ibrs ida invpcid invpcid_single lahf_lm lm mca mce md_clear mmx 
  monitor movbe msr mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm 
  pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts rdrand rdtscp rep_good 
  sdbg sep smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 
  tpr_shadow tsc tsc_adjust tsc_deadline_timer vme vmx vnmi vpid x2apic xsave 
  xsaveopt xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel 4th Gen Core Processor Integrated Graphics 
  vendor: Micro-Star MSI driver: i915 v: kernel bus-ID: 00:02.0 
  chip-ID: 8086:0416 class-ID: 0300 
  Device-2: NVIDIA GM108M [GeForce 940M] vendor: Micro-Star MSI driver: nvidia 
  v: 470.57.02 alternate: nouveau,nvidia_drm bus-ID: 01:00.0 
  chip-ID: 10de:1347 class-ID: 0302 
  Device-3: Acer MSI Integrated Webcam type: USB driver: uvcvideo 
  bus-ID: 1-1.4:5 chip-ID: 5986:014c class-ID: 0e02 
  Display: x11 server: X.Org 1.20.11 compositor: kwin_x11 driver: 
  loaded: modesetting,nvidia alternate: fbdev,intel,nouveau,nv,vesa 
  display-ID: :0 screens: 1 
  Screen-1: 0 s-res: 1920x2160 s-dpi: 96 s-size: 506x570mm (19.9x22.4") 
  s-diag: 762mm (30") 
  Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 142 size: 344x194mm (13.5x7.6") 
  diag: 395mm (15.5") 
  Monitor-2: HDMI-1 res: 1920x1080 hz: 60 dpi: 305 size: 160x90mm (6.3x3.5") 
  diag: 184mm (7.2") 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 4600 (HSW GT2) 
  v: 4.5 Mesa 21.1.5 compat-v: 3.0 direct render: Yes 
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio 
  vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus-ID: 00:03.0 
  chip-ID: 8086:0c0c class-ID: 0403 
  Device-2: Intel 8 Series/C220 Series High Definition Audio 
  vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 
  chip-ID: 8086:8c20 class-ID: 0403 
  Device-3: Plantronics Plantronics .Audio 622 USB type: USB 
  driver: plantronics,snd-usb-audio,usbhid bus-ID: 3-2:3 chip-ID: 047f:c014 
  class-ID: 0300 
  Sound Server-1: ALSA v: k5.12.19-1-MANJARO running: yes 
  Sound Server-2: JACK v: 1.9.19 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.32 running: no 
  Device-1: Qualcomm Atheros Killer E220x Gigabit Ethernet 
  vendor: Micro-Star MSI driver: alx v: kernel port: d000 bus-ID: 03:00.0 
  chip-ID: 1969:e091 class-ID: 0200 
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: dynamic noprefixroute scope: global 
  IP v6: <filter> type: noprefixroute scope: link 
  Device-2: Intel Wireless 3160 driver: iwlwifi v: kernel port: d000 
  bus-ID: 05:00.0 chip-ID: 8086:08b3 class-ID: 0280 
  IF: wlp5s0 state: down mac: <filter> 
  WAN IP: <filter> 
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8 
  bus-ID: 1-1.3:4 chip-ID: 8087:07dc class-ID: e001 
  Report: bt-adapter ID: hci0 rfk-id: 0 state: down 
  bt-service: enabled,running rfk-block: hardware: no software: yes 
  address: <filter> 
  Message: No logical block device data found. 
  Message: No RAID data found. 
  Local Storage: total: 961.33 GiB used: 22.85 GiB (2.4%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital 
  model: WDS100T2B0A-00SM50 size: 931.51 GiB block-size: physical: 512 B 
  logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 20WD 
  scheme: GPT 
  ID-2: /dev/sdb maj-min: 8:16 type: USB vendor: SanDisk model: Cruzer Slice 
  size: 29.82 GiB block-size: physical: 512 B logical: 512 B type: N/A 
  serial: <filter> rev: 1.20 
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure? 
  Message: No optical or floppy data found. 
  ID-1: / raw-size: 931.22 GiB size: 915.53 GiB (98.32%) 
  used: 22.85 GiB (2.5%) fs: ext4 dev: /dev/sda2 maj-min: 8:2 label: N/A 
  uuid: 0eef34c8-7ed8-4eb2-bffe-5f7e04864898 
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) 
  used: 288 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1 label: NO_LABEL 
  uuid: CDDC-5789 
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
  ID-1: swap-1 type: file size: 512 MiB used: 0 KiB (0.0%) priority: -2 
  file: /swapfile 
  Message: No unmounted partitions found. 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Hub-2: 1-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0 
  speed: 480 Mb/s chip-ID: 8087:8008 class-ID: 0900 
  Device-1: 1-1.2:3 info: Logitech Cordless Mouse Receiver type: Mouse,HID 
  driver: hid-generic,usbhid interfaces: 2 rev: 2.0 speed: 1.5 Mb/s 
  power: 98mA chip-ID: 046d:c521 class-ID: 0300 
  Device-2: 1-1.3:4 info: Intel Bluetooth wireless interface type: Bluetooth 
  driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA 
  chip-ID: 8087:07dc class-ID: e001 
  Device-3: 1-1.4:5 info: Acer MSI Integrated Webcam type: Video 
  driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA 
  chip-ID: 5986:014c class-ID: 0e02 
  Hub-3: 2-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Hub-4: 2-1:2 info: Intel Integrated Rate Matching Hub ports: 8 rev: 2.0 
  speed: 480 Mb/s chip-ID: 8087:8000 class-ID: 0900 
  Hub-5: 3-0:1 info: Full speed (or root) Hub ports: 14 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Hub-6: 3-1:2 info: VIA Labs VL813 Hub ports: 4 rev: 2.1 speed: 480 Mb/s 
  chip-ID: 2109:2813 class-ID: 0900 
  Hub-7: 3-1.1:4 info: VIA Labs VL813 Hub ports: 4 rev: 2.1 speed: 480 Mb/s 
  chip-ID: 2109:2813 class-ID: 0900 
  Device-1: 3-1.1.4:6 info: SanDisk Cruzer Slice type: Mass Storage 
  driver: usb-storage interfaces: 1 rev: 2.0 speed: 480 Mb/s power: 200mA 
  chip-ID: 0781:5566 class-ID: 0806 serial: <filter> 
  Device-2: 3-1.2:5 info: Logitech Keyboard K120 type: Keyboard,HID 
  driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 1.5 Mb/s 
  power: 90mA chip-ID: 046d:c31c class-ID: 0300 
  Device-3: 3-2:3 info: Plantronics Plantronics .Audio 622 USB type: Audio,HID 
  driver: plantronics,snd-usb-audio,usbhid interfaces: 4 rev: 2.0 
  speed: 12 Mb/s power: 120mA chip-ID: 047f:c014 class-ID: 0300 
  Hub-8: 4-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.0 speed: 5 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  Hub-9: 4-1:2 info: VIA Labs VL813 Hub ports: 4 rev: 3.0 speed: 5 Gb/s 
  chip-ID: 2109:0813 class-ID: 0900 
  Hub-10: 4-1.1:3 info: VIA Labs VL813 Hub ports: 4 rev: 3.0 speed: 5 Gb/s 
  chip-ID: 2109:0813 class-ID: 0900 
  System Temperatures: cpu: 47.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 186 Uptime: 16m wakeups: 1 Init: systemd v: 248 tool: systemctl 
  Compilers: gcc: 11.1.0 Packages: pacman: 1156 lib: 326 Shell: Bash v: 5.1.8 
  running-in: konsole inxi: 3.3.06 

Kernel 5.12 is EOL so please install both 5.4 and 5.10 LTS (Long Time Support) and see which one of the two troubles you least.

Just put “Multiple systems” somewhere in there otherwise people will keep nagging for you to update it…


I have restarted the laptop… and the audio stutter issue is no longer exist… .
It will come back again some time in the future… Because it happened a few times before (but i have no time to bother it last time)…
Is there any command or something you can recommend me to try when the stutter issue reappear ? else we will never able to catch the issue…
I just purposely tried the same usb hdd that i was used to do video speed browsing… but now, it is totally fine no matter how fast i play it.

This tends to be a common trend for you in various threads across the internet. I would recommend first restarting your laptop prior to making a help thread. It will save a lot of unnecessary time and bandwidth

Yes. Please revert to this post: VLC audio Stuttering when using usb headphone but it is fine on built in speaker. KDE plasma - #2 by Fabby

Again, this happens to you A LOT. Please restart your computer more often. You will fix the overwhelming majority of your problems.


Why you think restart computer will solve this problem ? What causes that to happen ? There must be some reason why restart computer will solve the problem isn’t it ?
If i have a car that having problem on the run way, and the instruction is “to restart the car which will solve most of the problem” and am i suppose to drive on after restart ? Surely not, i will drive to car garage the first time after start (if it still drive able)…
Thing happen surely for a reason (or 2)… can’t just say restart for everything and expect thing to be fine… That’s no way to fix a problem. Expect restart and problem solved is just like universal solution to fixing tv…

Oh ya… i forgot to inform Fabby that i have all other kernel installed. But since i restarted laptop , i can’t duplicate it… there is no point of trying out other kernel.

$ pacman -Q | grep linux
linux510 5.10.53-1
linux510-headers 5.10.53-1
linux512 5.12.19-1
linux512-headers 5.12.19-1
linux54 5.4.135-1
linux54-headers 5.4.135-1

This is not a solution,but can you try another video player like SMPlayer?, try increase the speed of playing as well and see if the problem happens there.

Because that is what solved your last problem? (You forgot to restart before asking a question?)


1 Like

Ya, but usually the problem that fixed by restart always return… which mean the problem is there… just randomly appear…
It is quite impossible for me when encounter a problem : the first thing todo is restart the computer…
If i restart the computer; the problem might be gone… when it is gone, how can i ever able to troubleshoot if the problem is gone… that’s why i never want to restart computer when i faced with a trouble.
It is just sometime it dragged on for too long… i have to restart computer because i need to switch to windows os to do work… otherwise, i rather not restarting until the issue is solved.

I have never able to do real work so far with linux… lol sad… i pick up so slowly. luckily i can switch hdd between linux and win7…

Fabby, you are always seems to be a happy person. lol…

1 Like

That’s an issue, not a problem. A problem is a recurring issue.

If the solution to your issue was your own answer to restart the computer and you then accept that answer as the solution, in the end, no one is going to help you any more

So: If you have an issue:

  • restart the service / application
  • Not Solved? → Restart the computer
  • Not Solved. → Research the issue yourself.
  • Not Solved. → Post a topic here if it’s about Manjaro, post it on the VLC forum if it’s VLC, …


1 Like

If restart the computer, the issue is gone… than before 3 days it is back again… do i have to restart computer and wait for 3 days ? that will be no ending…
I always do research on google… just sometime the keyword is not right… sometime can’t figure out what word to search for… hence cant find the result…
I have spend God know how many hours on google to look thru reddit and other forums… Hence my issue never got fix… just drag on… forever.

Yes! Because it might be gone forever as well and issue was because of a cosmic ray that hit the RAX register of your I7 because of a nova 1 million years ago.



See your post here:

There is. The problem would likely be logged in your journal. The real problem is you likely have a non-replicatable issue. It’s “random” and happens every few days for no reason and a reboot seems to fix it. . . it’s nearly impossible anyone will be able to help you fix it, and it takes 30 seconds to reboot. You’re just wasting other people’s time.

If you have a car that has an intermittent problem that is nearly impossible to recreate other than randomly - and restarting it fixes it. . . More than likely what will happen is you will take the car in to be fixed. They likely won’t be able to recreate the problem, and tell you to come back when it happens again. Difference there - they don’t mind you coming back cause you’re going to drop $150 every time you show up. The owners will love you. This is Linux, we help each other for a common goal, camaraderie, building something, and the freedom that comes with it.

Every time you have a problem - MAIL me you’re computer - I’ll fix it 100%, and send it back to you for $50/hr to fix it - minimum 1 hour + shipping. I’ll help you FOREVER at that rate too.

If you can’t recreate the problem consistently, if there’s no error in terminal, no error in journal . . .

If you can say every time I do X, my audio goes out - then we can help. Otherwise - you end up what is known in the internet world as: Help Vampire | Community Management Wiki | Fandom

For instance:

If the problem is gone - you DON’T HAVE TO TROUBLESHOOT IT. That’s the beauty of it! You just saved me time, you time, @Fabby time - and time isn’t FREE.

Take note of EXACTLY what you do when it goes out. Then restart your computer - do EXACTLY the same thing again. If it happens again, restart. Do EXACTLY the same thing again - if all 3 times - you have the same problem - post it up! We can help with that.

You’re welcome to spend hours on google - just don’t as others to do it. Time is too valuable. You’ve employed probably hundreds of man hours to your system already. I know of at least two other forums where you have 100+ problem threads created. For instance - another “restart fix thread” - https://www.linuxquestions.org/questions/linux-newbie-8/restart-mouse-control-module-in-linux-4175688321/ That’s a severe problem. You’re not new to Linux either. You’re employing a LOT of people’s time to help you and then you say - you can’t be bothered to restart your computer - which fixes your problem. Or you don’t have time to look into the issue right now, but yet you’re willing to ask other people to do it. . . .

With that many problems - there’s either something VERY wrong with your hardware, you’re doing something VERY VERY wrong with your installation process, or you continue to do something that breaks your system. But with 200+ help topics, the only thing I can say 100% is the problem - the system admin (you).

1 Like