VLC all dark mode, how?

I want 100% dark mode in the app, all windows & menus. I hadit that way on my old linux, it has to be a OS.
I found pages online that says it is in setting > extra setting, but I see nothing that says settings in VLC.

Your profile page says that you are using MATE as your desktop environment. As such, you probably have to set the VLC theme from within MATE, possibly with the help of qt5ct-kde if there is no designated module in MATE for setting the theme on qt-based applications.

qt5ct-kde is in the AUR, if you don’t have it installed already. :arrow_down:

pamac build qt5ct-kde

P.S.: This is not a “non-technical question” — thread moved to #support:applications.

You do have a way of consistently posting your topics in the wrong categories, so please be a bit more mindful next time.


On my old linux drive it was 100% dark mode, I did nothing speceal. Just thought it was something simple. Also my Manjaro setting is white, that was in dark mode in mt old linux also. Is there just a easy way to get all the settings from that drive?

Like I said, your profile says that you are using MATE as your desktop environment, so look around in your System Settings (or whatever it’s called there) for how to change the theme.

If I recall correctly, then your previous installation had KDE Plasma as the desktop environment, and Plasma is qt-based while MATE is gtk-based. These two desktop environments use different configuration files, which are not compatible with one another. The qt5ct-kde utility I mentioned in my previous post is intended for setting the theme of qt-based applications (such as VLC) in a gtk-based desktop environment (such as MATE).

I use qt5ct from the community repo. You may also want kvantum for more themes.

So I can not get the settings from my old linux drive?

You may or may not be able to copy theme over but you’d still need to use qt5ct and possibly kvantum to set the theme.


When you say “old linux drive” what exactly does that mean? Was it Manjaro Mate or something else?

It was Manjaro Mate, found something online that says Navigate to the Settings option. Under the Extra Settings select the item Interface. Then in the list tap DayNight Mode. **In the popup that appears, choose the Black Theme I can not find anythibg that says night mode.

I thought it was KDE, if it was mate then copy over ~/.config/qt5ct and maybe ~/.config/vlc

Very helpful :grin:

AFAIK neither vlc nor mate have a night mode.

I don’t use Mate so I’m not going to be of much help, but maybe you just need the right theme https://www.mate-look.org/browse/