VLC 3 gives no option for GTK theme

xfce
#1

Im using XFCE.
The new VLC has no option in the preferences to choose the gtk theme.
I tried switching between phono-qt4-vlc and phono-qt5-vlc, but no change.
Maybe its a QT errorr? I also installed notepadqq and it also didnt get the gtk theme. For me it seems it is a general QT error. But its still strange that vlc doesnt give me the option in the preferences.
What do you guys think? Is there a config where i have to tell qt(apps) to use the theme of gtk?
(no clue, im desperate :stuck_out_tongue: )(but vlc works great tho)

0 Likes

#2

VLC uses Qt and thus applies a Qt theme. You can set qt5ct so that Qt applications use your GTK theme.

3 Likes

#3

Thanks for replying
I followed the instructions on that page and added these two lines and restarted the system.
export QT_QPA_PLATFORMTHEME=qt5ct
export QT_AUTO_SCREEN_SCALE_FACTOR=0
but i cant open qt5ct
Screenshot_2018-03-15_21-05-12

0 Likes

#4

Just to be sure, can you post the content of /etc/environment ?

0 Likes

#5

lol :joy: i didnt save. now /etc/enviroments is alright, now qt5ct opens but as soon as i select gtk2 the app closes/closes.


(Thanks for keeping up with me!)

1 Like

#6

Can you start qt5ct from a terminal, and paste the output when it crashes?

0 Likes

#7

litle update: i managed to select without craching->meaning i first selected ‘Standard dialogs: Gtk3’, than i could select the ‘Style: gtk2’, but when i clicked OK, it crached. now i cant open qt5ct or vlc at all.
i will post what qt5ct outputs when trying to open through the terminal:

[fean@Mobius ~]$ qt5ct
qt5ct: using qt5ct plugin

(qt5ct:1515): GLib-GObject-WARNING **: cannot register existing type 'GdkDisplayManager'

(qt5ct:1515): GLib-CRITICAL **: g_once_init_leave: assertion 'result != 0' failed

(qt5ct:1515): GLib-GObject-CRITICAL **: g_object_new_with_properties: assertion 'G_TYPE_IS_OBJECT (object_type)' failed

(qt5ct:1515): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(qt5ct:1515): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

(qt5ct:1515): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(qt5ct:1515): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

(qt5ct:1515): GLib-GObject-WARNING **: cannot register existing type 'GdkDisplay'

(qt5ct:1515): GLib-CRITICAL **: g_once_init_leave: assertion 'result != 0' failed

(qt5ct:1515): GLib-GObject-CRITICAL **: g_type_register_static: assertion 'parent_type > 0' failed

(qt5ct:1515): GLib-CRITICAL **: g_once_init_leave: assertion 'result != 0' failed

(qt5ct:1515): GLib-GObject-CRITICAL **: g_object_new_with_properties: assertion 'G_TYPE_IS_OBJECT (object_type)' failed
Segmentation fault (core dumped)
[fean@Mobius ~]$
0 Likes

#8

Let’s see. The wiki has been modified recently, and i doubt some parts of it, so i’ll try to guide you with the previous way.

First, so you know, from the wiki:

In the first tab Appearance choose Standard Dialogs: default (some people get crashes if they choose GTK3)

Second, so we’re back from how it was done before, edit /etc/environment and replace

export QT_QPA_PLATFORMTHEME=qt5ct
export QT_AUTO_SCREEN_SCALE_FACTOR=0 

with QT_QPA_PLATFORMTHEME=qt5ct , save then reboot.

Third, delete ~/.config/qt5ct/qt5ct.conf . You should be able to open qt5ct again.

2 Likes

VLC startet seit letztem Update nicht mehr
#9

Ohh man thanks, i totally forgot that it should have a config file, now that you told me the location of the config, i only changed the ‘Standard dialogs’ to gtk2, saved it, all qt apps open with no reboot needed.
issue solved.
EDIT: heres my config for those to come here in the future:

[Appearance]
color_scheme_path=/usr/share/qt5ct/colors/dusk.conf
custom_palette=false
icon_theme=Arc-Maia
standard_dialogs=gtk2
style=gtk2

[Fonts]
fixed=@Variant(\0\0\0@\0\0\0\f\0U\0\x62\0u\0n\0t\0u@(\0\0\0\0\0\0\xff\xff\xff\xff\x5\x1\0?\x10)
general=@Variant(\0\0\0@\0\0\0\f\0U\0\x62\0u\0n\0t\0u@(\0\0\0\0\0\0\xff\xff\xff\xff\x5\x1\0\x32\x10)

[Interface]
activate_item_on_single_click=1
buttonbox_layout=0
cursor_flash_time=1000
dialog_buttons_have_icons=1
double_click_interval=400
gui_effects=@Invalid()
menus_have_icons=true
stylesheets=@Invalid()
toolbutton_style=4
underline_shortcut=1
wheel_scroll_lines=3

[SettingsWindow]
geometry=@ByteArray(\x1\xd9\xd0\xcb\0\x2\0\0\0\0\x2\x9d\0\0\0\x9e\0\0\x4\xbc\0\0\x2\xd0\0\0\x2\x9f\0\0\0\xb7\0\0\x4\xba\0\0\x2\xce\0\0\0\0\0\0\0\0\x6@)
1 Like

#10

For the note, i don’t have that line in my file. So i suppose removing it is the same as having Default.

0 Likes

#11

The contents of the wiki work for me & for others too (over at Artix).

If you use the contents of the wiki & you have a problem, then post in the wiki support page (for that page), linked to at the bottom of the wiki (it is also found in the Tutorials section.

0 Likes

#12

For some reason this line was problematic. It had gtk3 instead, I changed it to gtk2 and VLC not longer breaks when I select the gtk theme.

0 Likes

#13

I have an odd issue here, when I open qt5ct, my only options for “Style” (in the Appearance Tab) options are Fusion and Windows. There’s no gtk2 option in the dropdown menu. Any idea’s.

All the best.

Update: Fixed it by installing qt5-styleplugins. Now I can see a lot more style options. And this is my 1st post here. Hello everyone.

0 Likes

closed #14

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.

0 Likes