Vivaldi fails to start

Since upgrading to Vivaldi 6.7.3329.17-1 yesterday, it does’nt start anymore, and, in Wayland, fails with :

❯ vivaldi
libva error: /usr/lib/dri/ init failed
[0427/094435.575420:ERROR:elf_dynamic_array_reader.h(64)] tag not found
[0427/094435.575673:ERROR:elf_dynamic_array_reader.h(64)] tag not found
[0427/094435.575765:ERROR:elf_dynamic_array_reader.h(64)] tag not found
[0427/094435.576728:ERROR:elf_dynamic_array_reader.h(64)] tag not found
[0427/094435.578172:ERROR:elf_dynamic_array_reader.h(64)] tag not found
[0427/094435.583825:ERROR:elf_dynamic_array_reader.h(64)] tag not found
[0427/094435.583938:ERROR:elf_dynamic_array_reader.h(64)] tag not found
[0427/094435.585403:ERROR:elf_dynamic_array_reader.h(64)] tag not found
[0427/094435.586148:ERROR:elf_dynamic_array_reader.h(64)] tag not found
[0427/094435.586273:ERROR:elf_dynamic_array_reader.h(64)] tag not found
Erreur de segmentation (core dumped)

It also fails in X11 with the same errors, except for the first one.

Similar issues appear aswell, but I did not get segmentation faults.
Instead a blank window opened
Resetting .config/vivaldi-stable.conf did not help.
Might also be updates to nvidia / mesa (dual GPU setup)

libva error: /usr/lib/dri/ init failed
[2654:2654:0427/] EGL Driver message (Critical) : eglCreateImage failed with 0x00003009
[2654:2654:0427/] Failed to create EGLImage: EGL_BAD_ALLOC
[2654:2654:0427/] Unable to initialize binding from pixmap
[2654:2654:0427/] OzoneImageBacking::ProduceSkiaGanesh failed to create GL representation
[2654:2654:0427/] SharedImageManager::ProduceSkia: Trying to produce a Skia representation from an incompatible backing: OzoneImageBacking
[2654:2654:0427/] Exiting GPU process because some drivers can't recover from errors. GPU process will restart shortly.
[2613:2652:0427/] Buffer handle is null. Not creating a mailbox from it.
[2613:2652:0427/] Creation of StagingBuffer's SharedImage failed.

Latest packages:

[2024-04-26T17:33:05+0200] [ALPM] upgraded aom (3.8.2-1 -> 3.9.0-1)
[2024-04-26T17:33:05+0200] [ALPM] upgraded ncurses (6.4_20230520-1 -> 6.4_20230520-2)
[2024-04-26T17:33:05+0200] [ALPM] upgraded libxmlb (0.3.18-1 -> 0.3.19-1)
[2024-04-26T17:33:05+0200] [ALPM] upgraded systemd-libs (255.4-2 -> 255.5-1)
[2024-04-26T17:33:07+0200] [ALPM] upgraded appstream (1.0.2-1 -> 1.0.3-1)
[2024-04-26T17:33:08+0200] [ALPM] upgraded nvidia-utils (550.76-1 -> 550.78-1)
[2024-04-26T17:33:09+0200] [ALPM] upgraded mesa (1:24.0.5-1 -> 1:24.0.6-1)
[2024-04-26T17:33:09+0200] [ALPM] upgraded systemd (255.4-2 -> 255.5-1)
[2024-04-26T17:33:10+0200] [ALPM] upgraded appstream-qt (1.0.2-1 -> 1.0.3-1)
[2024-04-26T17:33:10+0200] [ALPM] upgraded appstream-qt5 (1.0.2-1 -> 1.0.3-1)
[2024-04-26T17:33:10+0200] [ALPM] upgraded tracker3 (3.7.1-2 -> 3.7.2-1)
[2024-04-26T17:33:11+0200] [ALPM] upgraded chromium (124.0.6367.60-1 -> 124.0.6367.91-1)
[2024-04-26T17:33:12+0200] [ALPM] upgraded containerd (1.7.15-1 -> 1.7.16-1)
[2024-04-26T17:33:12+0200] [ALPM] upgraded discord (0.0.50-1 -> 0.0.51-1)
[2024-04-26T17:33:13+0200] [ALPM] upgraded docker (1:26.0.2-1 -> 1:26.1.0-1)
[2024-04-26T17:33:13+0200] [ALPM] upgraded docker-compose (2.26.1-1 -> 2.27.0-1)
[2024-04-26T17:33:13+0200] [ALPM] upgraded electron22 (22.3.27-5 -> 22.3.27-6)
[2024-04-26T17:33:13+0200] [ALPM] upgraded libavif (1.0.4-2 -> 1.0.4-3)
[2024-04-26T17:33:14+0200] [ALPM] upgraded electron27 (27.3.11-1 -> 27.3.11-2)
[2024-04-26T17:33:14+0200] [ALPM] upgraded electron28 (28.3.1-1 -> 28.3.1-2)
[2024-04-26T17:33:15+0200] [ALPM] upgraded electron29 (29.3.1-1 -> 29.3.1-2)
[2024-04-26T17:33:15+0200] [ALPM] upgraded electron30 (30.0.1-1 -> 30.0.1-2)
[2024-04-26T17:33:15+0200] [ALPM] upgraded freerdp (2:3.5.0-1 -> 2:3.5.1-1)
[2024-04-26T17:33:15+0200] [ALPM] upgraded libarchive (3.7.3-1 -> 3.7.3-3)
[2024-04-26T17:33:15+0200] [ALPM] upgraded fwupd (1.9.16-1 -> 1.9.18-2)
[2024-04-26T17:33:15+0200] [ALPM] upgraded hyprcursor (0.1.7-1 -> 0.1.8-1)
[2024-04-26T17:33:16+0200] [ALPM] upgraded imagemagick ( ->
[2024-04-26T17:33:16+0200] [ALPM] upgraded kservice5 (5.115.0-1 -> 5.115.0-2)
[2024-04-26T17:33:16+0200] [ALPM] upgraded lib32-mesa (1:24.0.5-1 -> 1:24.0.6-1)
[2024-04-26T17:33:16+0200] [ALPM] upgraded mesa-vdpau (1:24.0.5-1 -> 1:24.0.6-1)
[2024-04-26T17:33:16+0200] [ALPM] upgraded lib32-mesa-vdpau (1:24.0.5-1 -> 1:24.0.6-1)
[2024-04-26T17:33:16+0200] [ALPM] upgraded lib32-systemd (255.4-1 -> 255.5-1)
[2024-04-26T17:33:16+0200] [ALPM] upgraded libmpeg2 (0.5.1-9 -> 0.5.1-10)
[2024-04-26T17:33:16+0200] [ALPM] upgraded libupnp (1.14.18-1 -> 1.14.19-2)
[2024-04-26T17:33:16+0200] [ALPM] upgraded libwireplumber (0.5.1-2 -> 0.5.2-1)
[2024-04-26T17:33:16+0200] [ALPM] upgraded luajit (2.1.1710088188-1 -> 2.1.1713773202-1)
[2024-04-26T17:33:16+0200] [ALPM] upgraded manjaro-hello (0.7.2-1 -> 0.7.2-2)
[2024-04-26T17:33:16+0200] [ALPM] upgraded mhwd-nvidia (550.76-1 -> 550.78-1)
[2024-04-26T17:33:16+0200] [ALPM] upgraded nextcloud-client (2:3.12.3-2 -> 2:3.13.0-2)
[2024-04-26T17:33:16+0200] [ALPM] upgraded nvidia-dkms (550.76-1 -> 550.78-1)
[2024-04-26T17:33:16+0200] [ALPM] upgraded opencl-nvidia (550.76-1 -> 550.78-1)
[2024-04-26T17:33:16+0200] [ALPM] upgraded podman-compose (1.0.6-4 -> 1.1.0-1)
[2024-04-26T17:33:16+0200] [ALPM] upgraded python-inflect (7.2.0-1 -> 7.2.1-1)
[2024-04-26T17:33:16+0200] [ALPM] upgraded python-pydantic-core (1:2.18.1-1 -> 1:2.18.2-1)
[2024-04-26T17:33:16+0200] [ALPM] upgraded python-pydantic (2.7.0-1 -> 2.7.1-1)
[2024-04-26T17:33:16+0200] [ALPM] upgraded qpwgraph (0.6.3-1 -> 0.7.0-1)
[2024-04-26T17:33:16+0200] [ALPM] upgraded slirp4netns (1.2.3-1 -> 1.3.0-1)
[2024-04-26T17:33:16+0200] [ALPM] upgraded systemd-sysvcompat (255.4-2 -> 255.5-1)
[2024-04-26T17:33:17+0200] [ALPM] upgraded thunderbird (115.10.0-1 -> 115.10.1-1)
[2024-04-26T17:33:18+0200] [ALPM] upgraded vivaldi (6.6.3271.61-1 -> 6.7.3329.17-1)
[2024-04-26T17:33:18+0200] [ALPM] upgraded vivaldi-ffmpeg-codecs (122.0.6261.84-1 -> 124.0.6367.82-1)
[2024-04-26T17:33:18+0200] [ALPM] upgraded vulkan-mesa-layers (1:24.0.5-1 -> 1:24.0.6-1)
[2024-04-26T17:33:18+0200] [ALPM] upgraded waybar (0.10.0-4 -> 0.10.2-1)
[2024-04-26T17:33:19+0200] [ALPM] upgraded wine-staging (8.21-1 -> 9.7-1)
[2024-04-26T17:33:20+0200] [ALPM] upgraded wireplumber (0.5.1-2 -> 0.5.2-1)
[2024-04-26T17:33:20+0200] [ALPM] upgraded xdg-desktop-portal-gtk (1.15.1-1 -> 1.15.1-2)
[2024-04-27T06:03:36+0200] [ALPM] upgraded lib32-gnutls (3.8.4-1 -> 3.8.5-1)
[2024-04-27T06:03:36+0200] [ALPM] upgraded python-mako (1.3.2-1 -> 1.3.3-1)
[2024-04-27T06:03:36+0200] [ALPM] upgraded yq (3.4.1-1 -> 3.4.2-1)
[2024-04-27T06:08:24+0200] [ALPM] upgraded wlogout (1.2.1-1 -> 1.2.2-0)

There is no issue with Vivaldi; at least, none that I can see - the same version starts here without issue after the update. The issue will likely be specific to your own configuration, and related to the very first libva error. There are a few (somewhat dated) similar issues with libva, which might give a few clues, however:

Edit:- Renamed title to better describe OP’s observation.

Hi @tobenderZephyr and welcome to the Manjaro community.

While your input is appreciated, in future, please start (your own) new thread and detail your problem so that others can help more effectively with your specific issue; rather than attempting to hijack another poster’s thread. :eyes:

As a new user, please take some time to familiarise yourself with Forum requirements; in particular, the many ways to use the forum to your benefit. To that end, some or all these links will be invaluable:

And last, but not least, the Stable Update Announcements, which you should check frequently for important update related information. Occasionally an issue might be directly related to a particular update; it’s always best to check those announcements.

I hope this helps. Cheers.

As I said, I get the “libva” error only in Wayland, in X11 it crashes the same, without the libva error.
I incriminate Vivaldi because my Manjaro system has been running for years without any issue, and Vivaldi started failing after one upgrade that involved only Vivaldi and not the kernel or any graphics library…
Also, a bit like @tobenderZephyr stated, when I start Vivaldi using the icon/menu, I get a blank Vivalvi Window that opens and immediately closes, but when I start it from the command line, I get the errors and no window even opens.

Hello and thanks for the introduction. Sorry for the interruption - I should really have had a look at those posts beforehand, but I was guessing, this issue was similar enough.
I really do not want to de-rail this thread since I just figured, that my errors are related to this change in chromium based browsers. I’m unsure if starting vivaldi with command line parameters helps the OP, just wanted to give a hint.

Have you set the flags?
Also note that recent chromium flags had some changes.
I assume for vivaldi and others too.


The first one used to be used … the second one is new and needed.

Oh. yeah. thats whats in the link above. :person_facepalming:

1 Like

And yet, as already pointed out, Vivaldi has no issue here - I use Wayland exclusively. This strongly suggests the problem is not with Vivaldi (but perhaps something interacting with Vivaldi); something else.

In as far as I’m able to guess, the link that @tobenderZephyr has mentioned, which leads to this post is a likely candidate; which would also indicate it is not a Vivaldi issue. Vivaldi, being chromium-based, may only be exhibiting a symptom of the problem.

However, that post is from the Testing Update announcements. If you are using the Testing branch, then it becomes a possibility, however, you have not specified which branch you are using.

At least with this new information, the issue might be easier to diagnose. Unfortunately, not by me, as the errors are non-existent.


You’re already here, so there’s little sense in back-peddling now. :wink: The link you gave might well be related - in fact, it even seems likely, now that @petaramesh has added some more detail.


It harms nobody to spell things out.

Appendum:- I am error-free using Wayland and AMD graphics. Perhaps this only manifests on Nvidia (guessing). :man_shrugging:

Well, to answer your questions :

  • I’m on the stable branch
  • I don’t expect to need typing specific command-line parameters for starting my browser, everybody does it by clicking on a menu icon, and the Vivaldi desktop menu entry file doesn’t use any option.
  • The issue appearing after years of no-issue just after a Vivaldi browser update, I’m quite confident the issue is with Vivaldi.
  • Chromium still works perfectly on my system, so it does not seem like an issue that “all chromium browsers” would have.
  • It complains about the i915, so the graphics driver is obviously Intel, not NVidia or AMD.
❯ inxi -G
  Device-1: Intel Iris Plus Graphics G1 driver: i915 v: kernel
  Device-2: IMC Networks USB2.0 VGA UVC WebCam driver: uvcvideo type: USB
  Display: wayland server: v: with: Xwayland v: 23.2.6
    compositor: kwin_wayland driver: X: loaded: modesetting unloaded: fbdev
    dri: iris gpu: i915 resolution: 1600x900
  API: EGL v: 1.5 drivers: iris,swrast
    platforms: wayland,x11,surfaceless,device
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 24.0.2-manjaro1.1
    renderer: Mesa Intel UHD Graphics (ICL GT1)
  API: Vulkan v: 1.3.279 drivers: intel surfaces: xcb,xlib,wayland

Also, the linked post about libva error dates back to 2020, and I’ve been using this very machine from 2021 until april 2024 with no such error…

To what command-line parameters are you referring?

OK. Let me extrapolate. I (and others) am using the same Vivaldi browser; the same version; and just had the same update - yet, I (and others) are not experiencing the same issue. Good so far?

This indicates that it is not a problem with Vivaldi, but a condition specific to your machine (and likely a few others) that is triggered by something interacting with Vivaldi. If the problem was specifically with Vivaldi, I would have it too; unless it was something present on your machine that is missing from mine (thus my pondering interest in graphics). That also might indicate the ‘something else’ as the culprit.

Incidentally, both Chromium and Microsoft Edge (the only Chromium-based browsers I have apart from Vivaldi) also work without issue.

The links were found quickly, and may have served as an indicator to the problem, regardless of their age. As stated:

The link that @tobenderZephyr gave, nonetheless describes an issue similar to what you experience (as you volunteered after seeing the information):

I don’t know what more to add, that might allow you to follow the logic.
All I can do is to wish you luck.


Certain configurations may be necessary given certain system parameters.

Even if you ‘refuse’ to “need typing specific command-line parameters for starting your browser”, you may have things you need to put in place, or maybe as a troubleshooting step you could ascertain your current options or try new ones.

For example … as mentioned … wayland.

And look - you are using wayland.

Example of other chromium based browser … in this one brave;

Or here on the forums, as was already linked above;

Since you are on wayland you probably should set the wayland flags.
Or the other way around and force it to run on X11 using … the X11 flags.
Both can be set in the GUI and/or permanently.
But its still important.

That’s because Chromium 124 is not in the stable branch. :wink:

But vivaldi

Is based on Chromium 124

@petaramesh so your assumptions were incorrect and what we said does apply to your vivaldi.

Please review the advice about ozone.

Yes, I’m aware there are both Brave and Vivaldi updates in the stable branch based on Chromium 124. :wink:

He specifically wondered why chromium was working but the others weren’t.

Im telling OP here who refuses to acknowledge the software changes to vivaldi
“because chromium works”

Yes … so I spelled it out.
(not for you. le sigh)

Alright. Hmmm… it seems I may be tired and missing things after long day. If so, apologies.

Me thinks it’s time for dinner & binge watching Sci-Fi things.

1 Like

I think we can strategically blame the missing Retort Plugin for our lack of extra context clues.
( and levity :small_airplane: )

Well, I said I had the issue in Wayland and I also said I also had the issue in X11.

As a side note, I don’t recall having had such unpleasant and harsh interaction on the Manjaro forums before today, and it started with answer #3.
That comes as a surprise to me.

People replying to other people they don’t know, from their heights, as if the others were complete morons, I’m not sure this fits with the forum guidelines.

Guys I’ve been an IT professional for more than 40 years and a Linux professional since 1996.

So uh …
did you use --ozone-platform=wayland yet ?

1 Like

Hi petaramesh,
Since this thread was the first time ever posting here; I just want to hint into using the flags, perhaps you have set vivaldi with vivaldi://flags before to use wayland and you did not do that for chromium for whatever reason.
After launching vivaldi with the flag posted multiple times before, It started working for me again, and I was able to undo the vivaldi://flag setting. It might just be, that this option persisted the update to your browser and prevents you now from launching it without specific command line overrides.

Thanks @tobenderZephyr

I was unable to test the theory as my Vivaldi (v6.7.3329.17-1, on Wayland) simply does not exhibit any issue remotely similar to what was described.

It’s great to know that these flags mentioned (multiple times) do indeed solve the issue for you. Now, if the OP might also resolve to follow your lead, we might be able to mark this thread as solved.

To that end, and for convenience, here are the related links that support the conclusion:

I’ll overlook the attempt, even though it was clearly aimed at me - I could easily be harsh, if it’s needed, but I’d prefer to simply help wherever possible, as I (and others) have been, despite your resistance.

If you’re happy to use the progressively proposed (and now, it seems confirmed) solution; and it solves your issue; may I suggest marking the post from @tobenderZephyr as the solution. It was he that kindly linked to the information in the first place (not bad, for a new member).