VisualBoyAdvance-M no longer opening roms after last stable update

Hello! I did my system update today and now my VBA is refusing to open any roms I have instead now just choosing to crash whenever I try. I have tried both GBA and GBC roms and neither work.

I know that the package was updated because of wxgtk2 being removed, but I don’t believe I had that package installed previously as I did not have to delete it to do the full update so I am at a loss as to why the emulator has stopped working.

Any insight would be very appreciated!

1 Like

If you recall - custom packages are unsupported - your only chance is that someone uses the same package - and that someone has been able to work around the issue.

You will likely need to rebuild the custom package and if that doesn’t help you should address the maintainer of the AUR build script. As a last resort you should address the developer.

If you are using Timeshift - you could roll your system back to a state where it works.

Thank you for the reply. However, vbam-wx is not an AUR package, it’s from the official repository.

Ah - I missed that in the heap of vba packages in AUR.

That package comes from packager

It has recently been rebuilt so - it is on its way to stable branch.

1 Like

Yeah that’s on me for not not realizing there were a bunch of AUR packages and not being specific, sorry about that. Learned a lesson for asking for help in the future if ever needed!

Thanks for the insight that the update is on it’s way!

After the July 18th stable update I noticed an issue with the VisualBoyAdvance-M package and posted a topic about it in the support channel. I was told that it had been rebuilt and would be pushed out soon.

After the update today, the problem is still present. Is there an ETA on when the package will be rolled out?

vbam-sdl / vbam-wx 2.1.4.r453.65b5affe-3 (wxWidgets 3.2 rebuild) has been available in the Manjaro stable branch since the 2022-07-18 update. That is the latest version available.

Well after seeing that the package had already been uploaded I did some digging and found a bandaid solution to the issue.

Going into Options > Video > Configure and changing the output module from “OpenGL” to “Simple” fixed the issue and allows ROMs to be opened.

I’m not sure what the issue is exactly, as other OpenGL games run without an issue but the problem has technically been solved for now.

Visualboy is also failing to open games for me.

Following your advice to set OpenGL to Simple fixed the problem.