Visible screen flickering

I installed KDE stable on my laptop, and the screen seems to flicker. I tried to take a video clip to show the problem, but it turned out to be quite hard to capture the flickering, so I have to rely on words. The flickering is better described as backlight pulsing at high frequency, and is different from graphic glitches or screen tearing. It is not very visible if I look at the screen directly, but rather visible and distracting using peripheral vision. Using free or non-free graphics drivers does not seem to matter - the flickering persists. I’m not sure if this is related to drivers or backlight pwm control. Please give me some suggestions on how to track down the problem.

Edit:
I’m experiencing two kinds of flickering. A high frequency flicker as mentioned above (which seems to only appear on the desktop), and a slow flicker - backlight changes slightly every second or so (which is visible in many apps).

My hardware:

$ inxi -Fxzc0
System:    Host: yichi-pc Kernel: 4.19.13-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 Desktop: KDE Plasma 5.14.4 
           Distro: Manjaro Linux 
Machine:   Type: Laptop System: Hewlett-Packard product: HP OMEN Pro 15 Notebook v: Type1ProductConfigId serial: <filter> 
           Mobo: Hewlett-Packard model: 8104 v: 02.38 serial: <filter> UEFI: Insyde v: F.46 date: 11/12/2018 
Battery:   ID-1: BAT0 charge: 21.9 Wh condition: 60.4/60.4 Wh (100%) model: 13142 RR04058 status: Discharging 
CPU:       Topology: Quad Core model: Intel Core i7-4720HQ bits: 64 type: MT MCP arch: Haswell rev: 3 L2 cache: 6144 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 41523 
           Speed: 998 MHz min/max: 800/2600 MHz Core speeds (MHz): 1: 998 2: 999 3: 998 4: 1002 5: 998 6: 998 7: 998 8: 1000 
Graphics:  Device-1: Intel 4th Gen Core Processor Integrated Graphics vendor: Hewlett-Packard driver: i915 v: kernel 
           bus ID: 00:02.0 
           Device-2: NVIDIA GK107GLM [Quadro K1100M] driver: N/A bus ID: 01:00.0 
           Display: x11 server: X.Org 1.20.3 driver: intel resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel Haswell Mobile v: 4.5 Mesa 18.3.1 direct render: Yes 
Audio:     Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio vendor: Hewlett-Packard driver: snd_hda_intel 
           v: kernel bus ID: 00:03.0 
           Device-2: Intel 8 Series/C220 Series High Definition Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel 
           bus ID: 00:1b.0 
           Sound Server: ALSA v: k4.19.13-1-MANJARO 
Network:   Device-1: Intel Wireless 7260 driver: iwlwifi v: kernel port: 4040 bus ID: 09:00.0 
           IF: wlo1 state: up mac: <filter> 
Drives:    Local Storage: total: 476.94 GiB used: 11.32 GiB (2.4%) 
           ID-1: /dev/sda vendor: Samsung model: MZHPU512HCGL-000H1 size: 476.94 GiB 
Partition: ID-1: / size: 452.11 GiB used: 11.32 GiB (2.5%) fs: ext4 dev: /dev/sda1 
           ID-2: swap-1 size: 16.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda2 
Sensors:   System Temperatures: cpu: 31.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 216 Uptime: 7m Memory: 15.59 GiB used: 1.31 GiB (8.4%) Init: systemd Compilers: gcc: 8.2.1 Shell: bash 
           v: 4.4.23 inxi: 3.0.28 

The laptop seems to have some sensor which measures the ambient lighting and sets the screen brightness accordingly:

As it is common for Windows 8.1, it is possible to adjust the brightness in 10 steps. Instead of the manual control, you can also let the light sensor do the job, which works well.

Source: https://www.notebookcheck.net/HP-Omen-Pro-15-Workstation-Review.146160.0.html#toc-display

So you might want to disable it (https://askubuntu.com/questions/776454/how-do-i-disable-automatic-brightness-in-ubuntu-gnome-16-04-15-10) to get rid of the low frequency screen flickering.

I did some digging on the Internet and found little info on auto brightness adjustment for KDE, which led me to believe it is not implemented (not out-of-the-box, at least). There’s no option in “Power Management” settings that suggests brightness is adjusted automatically. I also checked the laptop with a flashlight, and the brightness did not change in response to the light. I think it is likely the flickering is not related to the auto brightness adjustment you mentioned.

Maybe it is possible to disable the sensor in the BIOS settings?

I don’t see one. The thing is, the brightness doesn’t seem to change when ambient light changes as I checked with the flashlight. I doubt the sensor is being used and the low frequency flickering has anything to do with the sensor.

It might just not work properly thus not reacting to the flashlight accordingly. :slight_smile:

I don’t use KDE unfortunately, so I’m of not of big help here…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by