Virtualize manjaro-arm on manjaro-x86_64

Hi folks, currently running Manjaro on x86_64 machine. Would like to test Manjaro version for Raspberry Pi 4, but currently don’t have it. Is possible to virtualize it using software like qemu, Oracle Virtualbox, virt-manager, etc.?

@Strit @spikerguy As this was not posted in the #arm category, maybe you missed this?

(I have no clue as I only know about x-compilation)

:sob:

Yes it is possible using qemu but won’t be a pleasant experience.

I don’t need it to be pleasant, just need basic testing. How do you recommend to do it?

Thank you @spikerguy

@Tribble Spikerguy just told you how to fish and is not fishing for you:

https://wiki.qemu.org/Documentation/Platforms/ARM

:man_shrugging:

1 Like

QEMU only supports officially the Raspberry Pi 2 at this moment.

It’s the only option as far as I know.

But then again, I don’t virtualize as I have the hardware.

1 Like

@Strit do you know if the Pi 2 and the Pi 4 can run the same manjaro/AUR packages? Or binaries have to be compiled different and are not binary-compatible?

If it runs aarch64 packages then it should be able to, yes.

Your original question has been answered here:

Therefore, I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

:innocent:
P.S. In the future, please don’t forget to come back to your question after your issue has been solved and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
Solution
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

Finally could get the Raspberry Pi 3 emulated on x86_64 Manjaro, thanks to this video:

Emulating ARM64 Raspberry Pi Image using QEMU

Couldn’t get XFCE4 to work, so it’s shell only.

Tutorial for raspbian with CPU arm1176 and graphical interface:

Raspberry Pi on QEMU

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.