VirtualBox VM not starting after system upgrade (kernel related?)

Hi All, I just reinstalled Manjaro as I had some twitchyness after playing with Kernel versions. All seems to be resolved now except I cannot start my VirtualBox VMs anymore. I have a Windows 10 and Mint 20 VMs and neither will load anymore. Windows 10 gives this error:

Failed to start the virtual machine Trade.

Failed to load R0 module /usr/lib/virtualbox/ExtensionPacks/Oracle_VM_VirtualBox_Extension_Pack/linux.amd64/VBoxEhciR0.r0: SUP_IOCTL_LDR_OPEN failed (VERR_INVALID_PARAMETER).

Failed to load ring-0 module 'VBoxEhciR0.r0' for device 'usb-xhci' (VERR_INVALID_PARAMETER).

Result Code: NS_ERROR_FAILURE (0x80004005)
Component: ConsoleWrap
Interface: IConsole {872da645-4a9b-1727-bee2-5585105b9eed}

I have a script that installs VirtualBox (among other things) for me, it reads thusly:

pamac install virtualbox $(pacman -Qsq "^linux" | grep "^linux[0-9]*[-rt]*$" | awk '{print $1"-virtualbox-host-modules"}' ORS=' ')
sudo vboxreload
pamac build virtualbox-ext-oracle
sudo gpasswd -a $USER vboxusers
echo
echo "Don't forget this: http://download.virtualbox.org/virtualbox/" && echo
sleep 3

My System:
OS: Manjaro 20.1 Mikah
Kernel: x86_64 Linux 5.7.17-2-MANJARO
Shell: bash 5.0.18
DE: KDE 5.73.0 / Plasma 5.19.4
VirtualBox Graphical User Interface Version 6.1.12 r139181

Everything is basically standard, I completed the install less than an hour ago. If this is more of a VirtualBox thing let me know and I will post over there instead and get rid of this thread.

Thanks in advance.

Lately there has been something off with VirtualBox and the extension pack.

A workaround is to uninstall the extension package

sudo pacman -R virtualbox-ext-oracle

Next edit your virtual machine settings USB tab and set USB to 1.1.

1 Like

Thanks, this was exactly the solution.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.