Virtualbox Small Screen

kde

#1

So I got Manjaro installed (yay!) in VirtualBox last night (Mojave is host OS on late 2015 iMac). Everything within the VirtualBox instance seems to work just fine, however, the window only takes up about 1/20th of my screen, and I can’t make it any larger (full-screen mode changes nothing and seamless mode is greyed out in the VirtualBox menus).

Per this post (Manjaro as guest in VirtualBox small screen size) I installed virtualbox-guest-utils using pacman.

pacman -Qs virtualbox-guest-utils now returns:

local/vituralbox-guest-utils 6.0.0-1
    VirtualBox Guest userspace utilities

I restarted the system. No change. Do I have to go into settings somewhere to use the package that I installed? Is there something else I need to install/do?

if it helps, kernel: 4.19.13-1-MANJARO

thanks.


#2

:thinking: what edition on Manjaro? is it i3 or openbox by any chance ?


#3

it’s Manjaro KDE. put it in the tag but forgot it in the actual post, sorry bout that.


#4

no problem, i had this issue with manjaro installed on hardware. a reboot fixed it for me.
you might wanna tweak some setting on your VM


#5

Under display, I’ve changed the scale factor to 300% and that did make the window larger, but the resolution was atrocious. When I started the virtual machine and went into the Manjaro settings display menu, it won’t let me change the default (800X600). It will usually let me click something else but then in gets very laggy and reverts back to 800x600 and nothing ever changes.


#6

well then, this goes beyond my knowledge, we need a VirtualBox expert in this thread NOW
:face_with_head_bandage:


#7

You missed to install the linux4XX-virtualbox-guest-modules for the running kernel inside your guest install, where XX is the kernel you are using from the 4 “series” …

That will not help. Set Auto-resize Guest Display - that will help to keep the proper resolution for the given window size, and when you change it, it refreshes automatically.


#8

Thanks. When I run:

pacman -Qs virtualbox-guest-modules

I get:

local/linux419-virtualbox-guest-modules 6.0.0-2 (linux419-extramodules)
    Guest kernel modules for VirtualBox

I’m guessing that means that package came pre-installed on the system and it doesn’t need to be redownloaded. Am I correct there?

Where should I go next?

Edit: forgot to mention that Auto-resize guest display is checked and greyed out (and always has been).


#9

That means is ok from the guest part, but … since you mentioned

Probably a host issue ? Mojave lowered the graphic performances on some Macs, so maybe … Have you tried a different distro/OS install and see if the issue is similar?


#10

I will try another distro and report back.


#11

Did an install of Kali Linux, Seamless Mode is no longer greyed out, and I am able to put the VM in full screen (the resolution is good too). I’m guessing that means its not a hardware problem?


#12

Correct … All my speculations are invalid so far.
The only thing worth to try is to step by step make another VM for Arch_x64, with all the correct settings and install Manjaro again. :slight_smile:


#13

OP sounds like the “tiny windows” problem: [VirtualBox] [fix available] tiny windows with i3 - second thread

However, it only occured on i3… so your issue must be a little different.

What I think it could be: wrong graphics adapter.
VBox 6 introduced two new graphics adapters besides the old one, you might want to experiment with a different one.
The VMWare adapter (VMSVGA) should work with Manjaro guests, as well as the legacy VBoxVGA.


#14

I have tried the various graphics adapters. Does not solve the problem. I also checked out the “tiny windows” problem you linked, and it seems like the solution was a patch specific to i3. I’m assuming that means I shouldn’t download the patch while I’m using KDE?


#15

But maybe the host has the problem, since VB worked fine in Debian…

@the1 try to get some error message to pinpoint the issue source.
Run system settings from terminal and go to monitors to change resolution. Apply and look in the terminal for errors.

systemsettings5

Are there any higher resolutions available in the Monitors settings, or just 800x600?

Note: It really looks like a video driver issue, which is only VB type drivers…


#16

I don’t think the patch will help, it only adds i3wm to the list of supported WMs, solving that “tiny windows” problem.

When you use the VMware adapter, can you change display resolution inside the guest in KDE settings (like it was a real computer)? I mean not touching the VBox menus, just inside the guest.


#17

I had the same issue under Manjaro Budgie, could never get any of the guest utilities to work correctly. If you pull down the menu in Virtualbox and install guest utilities, it always resulted in errors trying to add them. I always thought they are included in the kernel, and I did install my correct virtualbox kernel modul in pacman, but still got errors adding guest utilities. I think it is a Manjaro/distro issue. Something is not configured correctly.

Edit to add; never had a problem under Debian.


#18

So, why i never encounter this problem on my installs? Manjaro host and different OS’s and linux distros guests.


#19
/** X11: Known Window Manager types. */
enum X11WMType
{
    X11WMType_Unknown,
    X11WMType_Compiz,
    X11WMType_GNOMEShell,
    X11WMType_KWin,
    X11WMType_Metacity,
    X11WMType_Mutter,
    X11WMType_Xfwm4,
};

I had a small window with a Manjaro KDE guest too, but using VMSVGA or VBoxVGA adapter and setting resolution in the guest solved the problem.


#20

So I’ve made a second VB instance of Manjaro KDE. After the initial set-up I ran sudo pacman -Syu virtualbox-guest-utils and chose option (6) linux419-virtualbox-guest-modules which corresponds with my kernel version. the terminal then says:

looking for conflicting packages...
Packages (2) linux419-virtualbox-guest-modules-6.0.0-2
             virtualbox-guest-utils-6.0.0-1

and asks if I would like to proceed with installation (I declined). Could that conflict be the source of the issue? What happens if I proceed with the install? How would I go about resolving that conflict?

Are there any higher resolutions available in the Monitors settings, or just 800x600?

in first VB of Manjaro KDE, yes, there were higher resolutions available. The system seemed to freeze when I clicked one however, nothing changed, and I always had to power the VB down after a few minutes of it still being frozen.