VirtualBox not working after update

edit: a reboot fixed it…

Hi there,

This is the error I get (I can’t add any links to this post for some reason)

I checked for the error 1912 and read that I needed to add the proper kernel modules, as the error message says.

~ $ uname -a
Linux XPS15 5.4.62-1-MANJARO #1 SMP PREEMPT Thu Sep 3 14:38:22 UTC 2020 x86_64 GNU/Linux

So I will need modules for linux54, correct?

~ $ sudo pacman -S linux54-virtualbox-host-modules

What do I need to do next? In this old post I read that I should " load vboxdrv with modprobe vboxdrv and then run your virtual machine", is that correct?
When I try this I get an error but maybe I am doing it wrong…

~ $ modprobe vboxdrv
modprobe: FATAL: Module vboxdrv not found in directory /lib/modules/5.4.62-1-MANJARO

Can someone point me into the right direction?

edit: why does the new forum not allow external links or media in a post?


Your kernel version is out-of-date, the current 5.4 kernel is 5.4.105 (you have 5.4.62), that could be the issue because VB is working fine for me (using it currently to run Win 10 for work).

Be sure to have package DKMS installed. DKMS (dynamic Kernel Module system) will rebuild all kernel modules when a kernel is updated. You will need the kernel headers installed as well. After installing DKMS, reboot, then reinstall all packages for VirtualBox.

This is embarrassing but rebooting fixed it…

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.