VirtualBox not launching

Oracle VB was working until Nov 2021 in Xfce. I have not used VB again until I tried yesterday. It would not launch.

I update Manjaro regularly before launching the program. The current updated kernel version is 4.19.252-3.

I wonder if this is the reason VB has stopped working? This version I think is not supported now.

And why this old kernel when I do an update now?


that number does not look like a kernel version - more like the version of the virtualbox modules
not sure - did not investigate

perhaps consciously, intentionally, install a more recent kernel
and make sure to also install the virtualbox kernel modules for that kernel version

Kernels will get updated within a particular version
but never will they be replaced by more recent ones
without your interaction

We’re going to need more details than that.

Please see [HowTo] Make support easier

4.19 is an LTS (Long Term Support) kernel and you have the latest version available from the Manjaro stable branch.

Have you tried any other kernels like 5.4, 5.10, 5.15 or 5.18?

No, it didn’t. I’ve decrypted it for you and edited the post. :wink:

Thanks for advice.

By ‘not launching’ I mean that when I try to open the application from the menu, nothing happens, nothing at all. It is as though the application was not there.

Thanks for your help. But I am running into lots of other problems.

The Manjaro Settings Manager does not open. When I try to open it from the menu, nothing happens. It is as though the menu entry is not there. So, I cannot find a source for newer kernels.

Same applies to Qt5 settings - nothing happens which I try to open it. The same may apply to other applications. I did not check them all.

On the VB, I took a screenshot of the entry in the file manager but I cannot find a way of posting it here.

Sorry, if I missed something obvious.

please give us a little mor basic infos to understand. snippets of information doesn’t play well. the minimum basic should be the output of the glorious inxi command described below.
:+1: Welcome to Manjaro! :+1:

  1. Please read this:
    [HowTo] Provide System Information
    and press the three dots below your post and press the :pencil2: to give us more information so we can see what’s really going on.
    Now we know the symptom of the disease, but we need some more probing to know where the origin lies… :grin:
  2. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information for us to be able to help you. (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
    Also, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text.



[howard@Lyra ~]$ inxi --admin --verbosity=7 --filter --width
  Kernel: 4.19.252-3-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-4.19-x86_64
    root=UUID=bb8bf78e-d283-448b-b815-c7f00a4edbef rw acpi_osi=Linux
    acpi_backlight=vendor quiet
  Desktop: Xfce v: 4.16.0 tk: Gtk v: 3.24.29 info: xfce4-panel wm: xfwm
    v: 4.16.1 vt: 7 dm: LightDM v: 1.30.0 Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Apple product: MacBookPro6,2 v: 1.0
    serial: <superuser required> Chassis: type: 10 v: Mac-F22586C8
    serial: <superuser required>
  Mobo: Apple model: Mac-F22586C8 v: MacBookPro6,2
    serial: <superuser required> UEFI: Apple v: MBP61.88Z.0057.B17.1702241225
    date: 02/24/17
  ID-1: BAT0 charge: 56.0 Wh (96.6%) condition: 58.0/69.0 Wh (84.1%)
    volts: 12.4 min: 10.9 model: SMPNz451 bq20z451 type: Unknown serial: N/A
    status: N/A
  Device-1: hid-00:1f:20:e1:a9:cb-battery model: Bluetooth Mouse M557
    serial: N/A charge: N/A status: discharging
  RAM: total: 7.72 GiB used: 1.32 GiB (17.1%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges
  Info: model: Intel Core i7 M 620 bits: 64 type: MT MCP arch: Westmere
    gen: core 1 built: 2010-11 process: Intel 32nm family: 6 model-id: 0x25 (37)
    stepping: 5 microcode: 0x7
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 4 MiB desc: 1x4 MiB
  Speed (MHz): avg: 1437 high: 1463 min/max: 1197/2661 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1463 2: 1423
    3: 1437 4: 1428 bogomips: 21278
  Flags: acpi aes aperfmperf apic arat arch_perfmon bts clflush cmov
    constant_tsc cpuid cx16 cx8 de ds_cpl dtes64 dtherm dts ept est
    flexpriority flush_l1d fpu fxsr ht ibpb ibrs ida lahf_lm lm mca mce mmx
    monitor msr mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm pebs
    pge pni popcnt pse pse36 pti rdtscp sep smx ss ssbd sse sse2 sse4_1 sse4_2
    ssse3 stibp syscall tm tm2 tpr_shadow tsc vme vmx vnmi vpid xtopology xtpr
  Type: itlb_multihit status: KVM: Split huge pages
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds status: Vulnerable: Clear CPU buffers attempted, no microcode;
    SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Core Processor Integrated Graphics driver: i915 v: kernel
    arch: Gen-5.75 process: Intel 45nm built: 2010 ports: active: none
    off: LVDS-1 empty: DP-1,HDMI-A-1,VGA-1 bus-ID: 00:02.0 chip-ID: 8086:0046
    class-ID: 0300
  Device-2: NVIDIA GT216M [GeForce GT 330M] vendor: Apple driver: nouveau
    v: kernel non-free: series: 340.xx status: legacy (EOL) last:
    release: 340.108 kernel: 5.4 xorg: 1.20 arch: Tesla process: 40-80nm
    built: 2006-13 pcie: gen: 1 speed: 2.5 GT/s lanes: 16 ports:
    active: LVDS-2 empty: DP-2 bus-ID: 01:00.0 chip-ID: 10de:0a29
    class-ID: 0300
  Device-3: Apple Built-in iSight type: USB driver: uvcvideo bus-ID: 2-1.1:3
    chip-ID: 05ac:8507 class-ID: 0e02 serial: <filter>
  Display: x11 server: v: compositor: xfwm v: 4.16.1 driver:
    X: loaded: modesetting alternate: fbdev,vesa gpu: i915,nouveau
    display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1680x1050 s-size: <missing: xdpyinfo>
  Monitor-1: LVDS-1 mapped: LVDS-1-1 note: disabled model: Apple Color LCD
    built: 2009 res: N/A dpi: 129 gamma: 1.2 size: 331x207mm (13.03x8.15")
    diag: 390mm (15.4") ratio: 16:10 modes: 1680x1050
  Monitor-2: LVDS-2 pos: primary model: Apple Color LCD built: 2009
    res: 1680x1050 hz: 60 dpi: 129 gamma: 1.2 size: 331x207mm (13.03x8.15")
    diag: 390mm (15.4") ratio: 16:10 modes: max: 1680x1050 min: 640x350
  Message: Unable to show GL data. Required tool glxinfo missing.
  Device-1: Intel 5 Series/3400 Series High Definition Audio
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:3b56
    class-ID: 0403
  Device-2: NVIDIA GT216 HDMI Audio driver: snd_hda_intel v: kernel pcie:
    gen: 1 speed: 2.5 GT/s lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:0be2
    class-ID: 0403
  Sound Server-1: ALSA v: k4.19.252-3-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.1 running: yes
  Device-1: Broadcom NetXtreme BCM5764M Gigabit Ethernet PCIe driver: tg3
    v: 3.137 pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: N/A bus-ID: 02:00.0
    chip-ID: 14e4:1684 class-ID: 0200
  IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  Device-2: Broadcom BCM43224 802.11a/b/g/n vendor: Apple AirPort Extreme
    driver: wl v: kernel modules: bcma pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    bus-ID: 03:00.0 chip-ID: 14e4:4353 class-ID: 0280
  IF: wlp3s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Device-1: Apple Bluetooth Host Controller type: USB driver: btusb v: 0.8
    bus-ID: 1-1.1.3:9 chip-ID: 05ac:8218 class-ID: fe01
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 988.84 GiB used: 372.29 GiB (37.6%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Crucial model: CT1000MX500SSD1
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 3.0 Gb/s
    type: SSD serial: <filter> rev: 020 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 type: USB vendor: SanDisk model: Cruzer Blade
    size: 57.33 GiB block-size: physical: 512 B logical: 512 B type: N/A
    serial: <filter> rev: 1.00 scheme: MBR
  Optical-1: /dev/sr0 vendor: ■■■■■■■■ model: DVD-R UJ-898 rev: HC10
    dev-links: cdrom
  Features: speed: 24 multisession: yes audio: yes dvd: yes
    rw: cd-r,cd-rw,dvd-r state: running
  ID-1: / raw-size: 922.42 GiB size: 906.86 GiB (98.31%) used: 115.87 GiB
    (12.8%) fs: ext4 dev: /dev/sda2 maj-min: 8:2 label: N/A
    uuid: bb8bf78e-d283-448b-b815-c7f00a4edbef
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 264 KiB
    (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1 label: N/A uuid: E733-32D6
  ID-3: /home/<filter>/TresoritDrive raw-size: N/A size: 3.91 TiB used: 256.43
    GiB (6.4%) fs: fuse.tresoritfs source: ERR-102
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/sda3 maj-min: 8:3 label: N/A
    uuid: dac08ddf-cc6d-4827-a355-6d1a84d429ca
  ID-1: /dev/sdb1 maj-min: 8:17 size: 2 GiB fs: iso9660
  ID-2: /dev/sdb2 maj-min: 8:18 size: 3.9 MiB fs: vfat label: N/A
    uuid: C26E-047E
  ID-3: /dev/sdb3 maj-min: 8:19 size: 55.33 GiB fs: ext4 label: writable
    uuid: 825d3ca3-48d4-4199-8741-6d39bf95e321
  Hub-1: 1-0:1 info: Full speed or root hub ports: 6 rev: 2.0 speed: 480 Mb/s
    chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 1-1:2 info: Microchip (formerly SMSC) USB 2.0 Hub ports: 4 rev: 2.0
    speed: 480 Mb/s power: 2mA chip-ID: 0424:2514 class-ID: 0900
  Hub-3: 1-1.1:3 info: Broadcom BCM2046B1 USB 2.0 Hub (part of BCM2046
    Bluetooth) ports: 3 rev: 2.0 speed: 12 Mb/s power: 94mA chip-ID: 0a5c:4500
    class-ID: 0900
  Device-1: 1-1.1.3:9 info: Apple Bluetooth Host Controller type: Bluetooth
    driver: btusb interfaces: 4 rev: 2.0 speed: 12 Mb/s chip-ID: 05ac:8218
    class-ID: fe01
  Device-2: 1-1.2:4 info: Apple Internal Keyboard/Trackpad (ISO)
    type: Keyboard,HID,Mouse driver: apple,bcm5974,usbhid interfaces: 3 rev: 2.0
    speed: 12 Mb/s power: 40mA chip-ID: 05ac:0237 class-ID: 0301
  Device-3: 1-1.3:6 info: Apple Internal Memory Card Reader
    type: Mass Storage driver: usb-storage interfaces: 1 rev: 2.0
    speed: 480 Mb/s power: 500mA chip-ID: 05ac:8403 class-ID: 0806
    serial: <filter>
  Device-4: 1-1.4:8 info: Logitech Unifying Receiver
    type: Keyboard,Mouse,HID driver: logitech-djreceiver,usbhid interfaces: 3
    rev: 2.0 speed: 12 Mb/s power: 98mA chip-ID: 046d:c52b class-ID: 0300
  Hub-4: 2-0:1 info: Full speed or root hub ports: 8 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-5: 2-1:2 info: Microchip (formerly SMSC) USB 2.0 Hub ports: 3 rev: 2.0
    speed: 480 Mb/s power: 2mA chip-ID: 0424:2514 class-ID: 0900
  Device-1: 2-1.1:3 info: Apple Built-in iSight type: Video driver: uvcvideo
    interfaces: 3 rev: 2.0 speed: 480 Mb/s power: 500mA chip-ID: 05ac:8507
    class-ID: 0e02 serial: <filter>
  Device-2: 2-1.2:4 info: Apple Built-in IR Receiver type: HID
    driver: appleir,usbhid interfaces: 1 rev: 2.0 speed: 1.5 Mb/s power: 100mA
    chip-ID: 05ac:8242 class-ID: 0300
  Device-3: 2-1.3:5 info: SanDisk Cruzer Blade type: Mass Storage
    driver: usb-storage interfaces: 1 rev: 2.0 speed: 480 Mb/s power: 200mA
    chip-ID: 0781:5567 class-ID: 0806 serial: <filter>
  System Temperatures: cpu: 65.0 C mobo: N/A gpu: nouveau temp: 61.0 C
  Fan Speeds (RPM): N/A
  Processes: 185 Uptime: 4h 33m wakeups: 2 Init: systemd v: 251
  default: graphical tool: systemctl Compilers: gcc: 12.1.0 clang: 14.0.6
  Packages: pacman: 1374 lib: 454 Shell: Bash v: 5.1.16
  running-in: xfce4-terminal inxi: 3.3.20
[howard@Lyra ~]$ 

Looks like I’m on my own on this one! Thanks anyway.