VirtualBox Manjaro GNOME apparently freezed after installation


  1. Install either full or minimal (not LTS) GNOME versions of Manjaro (official download page as of date 05/08/2021).

  2. Power off the virtual machine and remove the *.iso from the storage.

  3. Start the virtual machine.

  4. Do either one of these:

a) Start the Manjaro Hello setup, when trying to apply the Dash to Panel, entire panel gets screwed up, an error can be seen on the Manjaro Hello extensions windows, searchController is undefined.

b) Update all packages installed, restart is required, do it.

  1. Grey screen, freezed (can be seen since the clock is not moving).

Note: If I resize the window the screen gets updated, but still looks like freezed, no keyboard input, no mouse input, nothing works.


  • Windows 11 21H2 SO 22000.100
  • VirtualBox 6.1.26

Any solutions? Didn’t seem to find any on the forums doing a quick search. Thanks in advance.

By default in Manjaro Gnome we have enabled Dash to Dock and is not playing nice together with Dash to Panel - well known upstream issue. Use either one or the other.

Change in the VBox settings for your guest Manjaro system to use VMSVGA Graphics Controller.

You could then switch to unstable branch for Manjaro, or to testing, and then you will be able to use the VBoxSVGA controller again, where there are fixes for that rendering issue, once you update the system and reboot.

1 Like

Hello, thanks for the reply.

Having them both at the same time was not the problem. I always deactivate Dash to Dock then activate Dash to Panel.

This did indeed help with the rendering / freeze issue.

I tried unstable and testing branches, following Switching Branches from the official wiki. Rebooted the system closing the VM and opening it back, but neither or these branches helped me as soon as I changed to either VBoxSVGA or VBoxVGA. They both get freezed.

If you did that correctly and didn’t help, i don’t know what else to suggest than maybe use the review release:

I’ve been running the Manjaro dev version of Gnome for awhile in vbox and in Gnome boxes.I haven’t had any issues with boxes but in vbox if i log in with gnome on xorg I have no mouse or keyboard and lately the screen is black.If i disable 3D acceleration then it works.I can log in with Wayland and everythings ok.You might try disabling acceleration and see if that helps or see if you can log in using Wayland.

I’ll give it a try again when I’m back home. Thanks.

I’ll try this too.

So the funny thing about all this is that I’ve an old Manjaro VBox machine running for about 2-4 months now, I can still use that one 0 problems, it’s up to date and it’s using stable branch and latest VBox version.
The issue only happens on fresh installs.

I’ve tried all 3 graphic controllers with and without acceleration (if supported), it only seems to work with VMSVGA with and without it.