VirtualBox Guest Mouse issue

Hello all,
I need help with the following problem. I have VirtualBox installed on my Manjaro host system. As soon as I start a VM, after a certain time the mouse support breaks and only the keyboard is recognized. Only after shutting down the VM and closing VirtualBox, followed by a restart, the mouse is recognized again in the VM.

I have already tried to change the pointing device to PS/2 mouse, which also brought no improvement.

The problem occurs with both Windows and Linux guest systems (with installed guest extensions).
VirtualBox is installed in the latest version including extension pack.
As kernel module I have installed the 515.

Hope some one could help me.

You can try enabling 3D Acceleration in Settings > Display and restart the virtual machine.

I tried with 3D Acceleration, with VBoxSVGA and VMSVGA, but no difference.

Does this happen in full screen mode or also in window mode?
Have you checked VM logs and did you make sure you did completely shutdown the VM instead of “save machine state” ?
I assume you are running on X11 and not Wayland, since it’s not working in Windows either?

I have been struggling with this problem for a long time and have not yet found a satisfactory solution.
I found a relevant discussion on the Virtualbox forum
but the above solution does not work for me.

Sorry for the delay.
It happens in full and scaled mode.
I am always shutting down the VMs with the keyboard if the mouse got stucked.
Its standard manjaro gnome minimal installation, how can i check if im running x11 or wayland. How do you conclude that it is x11?

@ivoshm thanks for the tip, but it did not work for me either

If you haven’t changed your host system you will be on X11 and that should not cause problems with Virtualbox. See here how to check: [HowTo] Check a user session type (Wayland / X11) you are using on Gnome, KDE
Hard to find the issue with this, we probably can’t help much, could be Hardware, Virtualbox, everything. It sounds more like a slight program freeze of Virtualbox.
When running the VM, at the lower right corner there is an icon for mouse integration. With right click you can activate or deactivate it on the fly. Try that and see if it comes back. The host OS still has the mouse functioning.
Give enough hardware power to the VM, maybe reinstall Guest Additions and also check VM logs.

It seems that at least a partial workaround has been found (at least for me) - if the “Automatic keyboard capture” option is turned off beforehand, the problem with the mouse buttons no longer occurs.

You can find this option in File/Preferences/Input and then uncheck the above setting. Keyboard capture can also be turned on or off also by pressing the RightCtrl key, but unfortunately this does not solve the mouse problem that has already occurred.