Virtualbox getting NS_ERROR_FAILURE (0x80004005)


#1

I noticed that every boot, I also get the notification “VBoxClient: the VirtualBox kernel service is not running…”

Then when I start any machine on virtual box, I get these messages:

Failed to open a session for the virtual machine Whonix-Gateway-XFCE.

The VM session was closed before any attempt to power it on.

Result Code: NS_ERROR_FAILURE (0x80004005)
Component: SessionMachine
Interface: ISession {c0447716-ff5a-4795-b57a-ecd5fffa18a4}

I have already tried updating the kernel with sudo pacman -S linux419 -virtualbox-host-modules. And still no luck. Just to add, I also never used save states.

All of these just started happening out of nowhere.


#2
pacman -Qs virtualbox

#3
local/linux-rt-lts-manjaro-virtualbox-host-modules 4.14-1 (linux-rt-lts-manjaro-extramodules)
    Host kernel modules for VirtualBox
local/linux-rt-manjaro-virtualbox-host-modules 4.18-1 (linux-rt-manjaro-extramodules)
    Host kernel modules for VirtualBox
local/linux316-virtualbox-host-modules 6.0.4-1 (linux316-extramodules)
    Host kernel modules for VirtualBox
local/linux414-rt-virtualbox-guest-modules 6.0.4-1 (linux414-rt-extramodules)
    Guest kernel modules for VirtualBox
local/linux414-rt-virtualbox-host-modules 6.0.4-1 (linux414-rt-extramodules)
    Host kernel modules for VirtualBox
local/linux418-rt-virtualbox-host-modules 6.0.2-1 (linux418-rt-extramodules)
    Host kernel modules for VirtualBox
local/linux419-virtualbox-host-modules 6.0.4-5 (linux419-extramodules)
    Host kernel modules for VirtualBox
local/virtualbox 6.0.4-1
    Powerful x86 virtualization for enterprise as well as home use
local/virtualbox-ext-vnc 6.0.4-1
    VirtualBox VNC extension pack
local/virtualbox-guest-dkms 6.0.4-1
    VirtualBox Guest kernel modules sources
local/virtualbox-guest-iso 6.0.4-1
    The official VirtualBox Guest Additions ISO image
local/virtualbox-guest-utils 6.0.4-1
    VirtualBox Guest userspace utilities
local/virtualbox-host-dkms 6.0.4-1
    VirtualBox Host kernel modules sources
local/virtualbox-sdk 6.0.4-1
    VirtualBox Software Developer Kit (SDK)


#4

Did you spam install every virtualbox package you could find?

You don’t need the following packages

local/virtualbox-guest-dkms 6.0.4-1
local/virtualbox-guest-utils 6.0.4-1
local/virtualbox-host-dkms 6.0.4-1
local/virtualbox-ext-vnc 6.0.4-1
local/virtualbox-sdk 6.0.4-1

Guest packages belong in guest OS not host.


#5

Haha, yes. It’s because I was trying to improve Virtualbox’s performance.


#6

Just removed them and it still didn’t work.


#7

Never mix host and guest virtualbox packages.

On the host all you need is virtualbox and the kernel host module packages.

On a Manjaro guest all you need is the kernel guest module packages and virtualbox-guest-utils package.

On the host you can also install the virtualbox-guest-iso package if you have VM systems that require it. Note that Manjaro guests do not, other distros and other OSes (ie Windoze) will / might though.

On the host you should also install virtualbox-ext-oracle from AUR (Oracle VirtualBox Extension Pack), which provides better device integration like USB ports.


#8

Reboot.


#9

The “VBoxClient: the VirtualBox kernel service is not running…” I get on boot is finally gone but the problem still persists.


#10

Turns out that this caused by memory leaking from the theme I am using which is Air. At this time of this post, this theme has memory leaking. So just try switching your theme to breeze or any stable theme.

credits to: @sueridgepipe


#11

All the virtualbox packages you installed played a bigger part though

Virtualbox won’t run properly when both host and guest kernel module packages are installed.