Virtualbox funktioniert nicht


#1

Wenn ich eine Virtualbox Maschine starte, funktioniert es nicht.


#2

Dein Link zum Screenshot funktioniert auch nicht :wink:


#3

Habe den Screenshot neu hochgeladen


#4

Wenn man den angzeigten Fehlercode NS_ERROR_FAILURE… bei Tante G oder DuckDuck eingibt, bekommt man die Lösung:

This usually means that you are not a member of the vboxusers group or you do not have write permissions to the .virtualbox folder.

Dies bedeutet in der Regel, dass Sie nicht Mitglied der vboxusers-Gruppe sind oder keine Schreibrechte für den Ordner .virtualbox haben.

https://forums.virtualbox.org/viewtopic.php?t=24331

sudo gpasswd -a username vboxusers

username durch deinen Benutzernamen ersetzen.
https://wiki.manjaro.org/index.php?title=VirtualBox#Adding_Your_Account_to_the_vbox_User_Group
Nach einem Reboot sollte dann die VBox funktionieren


#5

Funktioniert immer noch nicht


#6

Hallo neumaif02,
dann probiere mal das hier

viele Grüße gosia


#7

Das schaffe ich nicht einmal auszuführen :joy:


#8

Der Befehl groups zeigt dir, in welchen Gruppen der aktuelle Benutzer Mitglied ist.
Dort muss vboxusers drin stehen.


#9

Hast du alle benötigten Pakete installiert?

Neben dem Paket virtualbox solltest du die Pakete virtualbox-host-dkms und linuxXXX-virtualbox-host-modules sowie linuxXXX-headers installiert haben. XXX durch die Versionsnummer deines Kernels ersetzen, z.B. linux419-virtualbox-host-modules. Es schadet auch nicht wenn du zusätzlich das Paket dkms installierst

Dann sollte es nach einem Reboot funktionieren.


#10

Du brauchs kein virtualbox-host-dkms und keine Headers wenn du die vorkompilierten Module zum passenden Manjaro Kernel benutzt, d.h. linux419-virtualbox-host-modules ist ausreichend für linux419.


#11

Im Grunde hast du recht. Wenn du aber einen neuen Kernel installierst, musst du das Host-Modul passend zum Kernel manuell installieren, virtualbox-host-dkms übernimmt dieses und du brauchst dich nicht weiter darum zu kümmern.

Die Installation der Headers hat mir vor langem jemand im Zusammenhang mit Virtualbox empfohlen und wenn sie nicht benötigt werden, so schaden sie auch nicht. Ich habe sie jedenfalls auf meinen Geräten installiert.


#12

Das stimmt nur bedingt. Wenn du einen neuen Kernel von Hand installierst ist das korrekt. Allerdings ist das in Manjaro nicht die empfohlene Methode einen neuen Kernel zu installieren.

Verwende besser den Manjaro Settings Manager. Damit werden alle extra Modules installiert, die auch schon für alle alten Kernel installiert waren. Dazu gehört auch das für den Kernel passende Headers Paket.

Wenn du keine GUI Tools magst kannst du auch sehr einfach mit

sudo mhwd-kernel -i  linuxXX

einen neun Kernel installieren. Das XX muss natürlich durch die Kernel Version ersetzt werden.

mhwd-kernel -l 

Zeigt alle verfügbaren Kernels an.


#13

Nun, ich plädiere seit langem dafür die Headers auf die ISOs drauf zu tun, auch wenn sie nicht strikt notwendig sind, aber das wird wohl so schnell nicht passieren.

Wie Xabbu schon geschrieben hat, wenn man den Kernel mit den Manjaro-Tools aktualisiert, brauch man sich um dkms etc. keine Gedanken zu machen.


#14

Das ist mir bekannt, ich arbeite mit Manjaro schon einige Jahre, damals war die ISO noch auf 0.8 und da wurde mir dieser Rat gegeben. Kann sein, dass sich hier in der Zwischenzeit einiges geändert hat, Ich mache es noch immer so, wie es mir damals ans Herz gelegt wurde


#15

Nun, man kann ja lange und ergebnislos über die Notwendigkeit von virtualbox-host-dkms streiten. Aber wenn man es installiert automatisiert es den Vorgang und erleichtert damit die ganze Choose doch sehr, auch und gerade für Anfänger :wink:

“It is also necessary to install the appropriate headers package(s) for your installed kernel(s): linux-headers or linux-lts-headers. When either VirtualBox or the kernel is updated, the kernel modules will be automatically recompiled thanks to the DKMS Pacman hook.”
https://wiki.archlinux.org/index.php/VirtualBox#Install_the_core_packages

viele Grüße gosia

PS. war eigentlich als Antwort für @xabbu gedacht, aber Josef ist ja auch irgendwie da beteiligt :wink:
Und wie immer bei Linux: viele Wege führen nach Rom…