VirtualBox error in the last update

Yes it is.
Have been running Win11 in VBox for half an hour – nice and smooth.

Maybe not; I’ve had some unexpected restarts that I don’t think were Windows’ fault.
Looks like we have to wait for vbox 6.1.35; it’s in testing, and some fedora users report that it works, in this forum.

Still no joy for me with these versions.

I still get these various errors with manjaro guest, so going back to kernel 5.4:

On manjaro upgrade:

  • openssl_read error ssl3_get_record:decryption failed or bad record mac

  • error: failed to decompress: /usr/lib32/ (Zstd decompression failed: Restored data doesn’t match checksum)

random segfaults with calamres during install

fsck.ext4: error whil eloadning shared libraries: cannot open shared object file: No such fil eor directory
ERROR: Bailing out. Run ´fsck /dev/sda1´ manually

sh: can’t access tty: job control turned off

Same here

1 Like

Some contributions:

  1. The VM files don´t get corrupted by anyway (even though running it through those mentioned kernels in those mentioned VirtualBox’s version become VERY unstable regarding memory issues);

  2. Downgrading to virtualBox 6.1.32 or even 6.1.30 didn’t make it for me;

  3. Upgrading my kernel to the 5.15 LTS didn´t make it for me (I was originally on 5.10 LTS);

  4. Upgrading my kernel to the non-LTS 5.18 brought everything back to normal (so far).


I confirm linux 518 works.

1 Like

Also noticed the issue on a haswell laptop (i7-4750HQ). Virtualbox crashes windows guests, unless kernel 5.18.5 is used.

This seems weird. Problems are generally expected with recent kernels. Conversely in this case VirtualBox seems to have problems with the least recent kernels where patches were backported via the kernel stable branches. These are never expected to cause regressions of this sort.

Sometimes newer kernel fix stuff first and only then fixes are backported to other kernels.

was this fixed with the latest update?
I’m on Kernel 5.15.
want to know before i bother making a VM.

1 Like

No, will be fixed with VirtualBox 6.1.36. In Manjaro the version is 6.1.34 at the moment.


Thank you.

First I tried upgrading to linux518 and even to linux519, but none of these helped. Then I decided to go downgrading. I downgraded 4 packages from cache like this:
# pacman -U file:///linux517-5.17.9-1-x86_64.pkg.tar.zst file:///linux517-headers-5.17.9-1-x86_64.pkg.tar.zst file:///linux517-virtualbox-host-modules-6.1.34-9-x86_64.pkg.tar.zst file:///virtualbox-6.1.34-2-x86_64.pkg.tar.zst
And it worked. My Windows 10 came back to life!
I’ll stick to this workaround until the official fix released.

I swear I’ll keep using kernel 5.4 and won’t upgrade anymore in the coming 10 years!

You’re right. Unfortunately.

I tried every 5.x kernel and still Virtualbox is not installlable.

I regret updating Manjaro and trying to fix Virtualbox by reinstalling it again. Since I can’t install VirtualBox anymore at all.

Heads up: 6.1.36 is out a few hours ago.

I didn’t test it yet, because it’s not in the AUR left alone in the (Manjaro) repos.

Edit: for some reason Discourse does not make links with this editor. So:

1 Like

It is available on Arch Community since today: Arch Linux - virtualbox 6.1.36-1 (x86_64)

and on Manjaro Unstable Packages | manjaro

In the changes a.o “Linux Host and Guest drivers: Introduced initial support for kernels 5.18, 5.19 and RHEL 9.1 (bugs [#20914], [#20941])”

Had the same issue, using a similar machine on 5.15
The issue was fixed after I upgraded virtualbox package manually to 6.1.36-1

1 Like

Virtualbox 6.1.36-1 is now available in manjaro repo. It is working fine for me with kernel 5.15.

1 Like

Kernel 5.18.14-1. Updated virtualbox to 6.1.36-1 and all its dependencies, but my windows 10 virtual machine still doesn’t start. I keep seeing this screen. Any ideas, guys?

Maybe the solution in my thread about 5.18 will be helpful: Linux 5.18 virtualization issues - #3 by Zesko

I also went back from 5.18 to 5.15 (LTS), because virtualbox 6.1.36-1 works on both

linux518-virtualbox-host-modules [Installed] 6.1.36-3 extra
linux515-virtualbox-host-modules [Installed] 6.1.36-4 extra
virtualbox-guest-utils [Installed] 6.1.36-1 community
virtualbox-guest-iso [Installed] 6.1.36-1 community
virtualbox [Installed] 6.1.36-1 community

windows 10 (guest) is starting flawless