VirtualBox error in the last update

I am using linux515 5.15.32-1 and linux515-virtualbox-host-modules 6.1.32-20. My versions may be a little older than yours because I fell a bit behind on upgrades and those are the versions that were available in /var/cache/pacman/pkg/ :).

@vtriolet when I try to downgrade to linux515 5.15.32-1 everything seems to go fine. Then I reboot,and I get:

[FAILED] Failed to start Load Kernel Modules

Then I have to boot from my USB key and do a Pacman -Syyu

I’m certainly not an expert at all. I just want to get my VirtualBox working again and this is a nightmare. If you have specific instructions on how you successfully downgraded, I would super appreciate it. =)

I had similar issues with the latest update. LTS Kernels 5.15 and 5.12 lead to completly unusable VBox guests, with Kernel 5.18.3-1 everything seems to be fine again.

1 Like

If you choose to downgrade a Kernel, make sure to downgrade all pre-build Kernel modules you have installed. If you use for example Nvidia, downgrade the Nvidia modules too or if you need specific wifi modules, you have to downgrade them also. If with the last update the Nivida drive receiveed an update you will need to downgrade the complete Nvidia stack with all necessary libraries. This is usually not that easy and will often fail.
To start look in /etc/modules-load.d and check the contend of the files. They list all modules that get loaded.

@xabbu thank you and what you describe is just WAY to much to deal with tbh. I WANT all of my modules to be the latest (stable) versions. I don’t want to start messing with everything because I feel like I’m just going to break more things, or create a completely unstable system.

That’s why this is such a nightmare.

Anyway, I just loaded the linux54 kernel and rebooted into it. SO FAR (crosses toes) VirtualBox has not crashed yet and its been 10 minutes with 3 Chrome tabs open. (it usually crashes in less than a minute).

@TheInvisible maybe I should load 5.18 and try it too? How much better is it than 5.4 ??

Thanks again everyone for the feedback. I’ll post more as I do more tests.

@85083d95abcf08651fb6 did any of this help you?

1 Like

Difficult to say - I use virtualbox everyday - maintaining a backend developed for .net framework on IIS - I can tell - in my environment virtualbox is solid as rock.

 pacman-mirrors -G

$ inxi -S
  Host: tiger Kernel: 5.18.3-1-MANJARO arch: x86_64 bits: 64
    Desktop: KDE Plasma v: 5.24.5 Distro: Manjaro Linux

$ vboxmanage --version

Just a thought - do you all have the extension pack installed - from AUR?

Not having the correct version - may cause unexpected issues.

Another thought

I don’t use the Manjaro precompiled host module (linuxXYY-virtualbox-host-modules) but instead I use the virtualbox-host-dkms and the headers for my kernel(s)

I upgraded the kernel to 5.18.3-1 per @TheInvisible and VirtualBox 6.1.34 is back to stable. Running for 1 hour now with no issues. Many thanks to @TheInvisible

Thank you very much everyone for commenting and providing solutions.

@rob215x Yes, I think it would be best to switch to kernel 5.18.

If I want to upload the kernel, do I have to make any other changes (not to mention changing the headers)?

No - that shouldn’t be necesarry - that is - unless you are using nvidia - then you should take care.

You can check your installed kernels

mhwd-kernel -li

If you want to use the 5.18 kernel and virtualbox-host-dkms - this will do it

sudo pacman -Syu linux518 linux518-headers virtualbox-host-dkms

Or the better safe than sorry

sudo pacman -Syu linux515 linux515-headers virtualbox-host-dkms

Thanks for the reply, I have tried with kernel 5.15, linux515-headers and virtualbox-host-dkms, and It does not work, I get the same error, I think it will be best to risk uploading the kernel 5.18.

Thank you.

Did you remove the linuxXYY-virtualbox-host-modules before you installed virtualbox-host-dkms.

I am having the same issue.I rolled back both the kernel and Virtualbox version and still had the issue. went from 5.15.46-1 → 5.10121-1 → 5.18 and VB to to 6.1.32 it was better but still having some issues with stability in my main work win10 VM. Fixed by using timeshift to go to a pre update state.

I don’t use it very often but thought I’d give it a try as several are having issues.I’m running unstable branch and have the latest 5.18.3-1 kernel and virtualbox is 6.1.34 r150636.I can’t find any issues as I started Win10 and ran all the updates which were a lot restarted and didn’t see any issues.Maybe I got lucky or I had a different update but can’t find any issue.

Yes, eliminated both Virtualbox and Linux515-Virtualbox-Host-Modules and installed Virtualbox (Official Manjaro Repo) + Virtualbox-Host-DKMS, and then I restarted the PC, unfortunately it did not work.

With the 5.18 kernel I have had no problems, so far.

Thanks for all.

One thing that may or may not be part of the issue but my system having the issue is using the nvidia driver. I don’t have a system available to test/confirm that it is the nvidia driver.

Well, my story isn’t quite over…

Today I updated the 4 machines affected by the issue. (2) Dell desktops, (1) ASUS desktop, (1) Lenovo desktop. The Lenovo and the ASUS have aftermarket graphics cards but nothing spectacular, just enough for dual monitors.

TEST 1: Kernel 5.18.3

  • VirtualBox Windows 7 Guests seem to run fine at first (they did not crash in the first minute or less, like previously).
  • Windows 7 Guest on the Lenovo crashed after about 30 minutes.
  • Windows 7 Guest on the ASUS seemed a bit sluggish compared to before this mess. One piece of software wouldn’t run. Chrome seemed to run fine but I kept seeing the “busy” icon appear next to my mouse.
  • I didn’t see an issue on the Dell machines but I didn’t play with them for more than 20 minutes.

TEST 2: Kernel 5.4 (yes all the way back to 5.4 because 5.10 didn’t work either)

  • I decided to go back to 5.4 because I tried it with one of the machines on Monday and left it running overnight. This morning it was still running fine with dozens of tabs open in both Chrome and Firefox, plus a couple of other programs running.
  • As of 8pm, all 4 computers are running fine with 5.4, none are sluggish, and none have crashed after several hours of testing.

I see Kernel 5.4 is LTS so guess its fine for now. Maybe its the lack of sleep over the past 48 hours, but I just find this whole thing super frustrating.

1 Like

Well, I guess you know it, but it is worth mentioning that there are pretty good alternatives to virtualbox.

  1. gnome-boxes
  2. virt-manager

I myself love the simple and easy to use interface of Gnome Boxes. Some features are missing, but it works faster and rock stable for me. I guess you just need to convert the VDI-Image to qcow2 and then create a virtual machine with it. All you need is this setup for Windows:

1 Like

"sudo pacman -S linux-headers " all you need

You are correct - but converting a 128G vdi is not a simple process and virt-manager can be quite intimidating in setting up a VM - it has a steeper learning curve than VirtualBox.

Gnome Boxes is virt-manager without the intimidating stuff - you still need to convert the VDI

That is partly correct - you still need to know your kernel as a selection will be presented and the default is not always the right one.

1 Like