VirtualBox doesn't see USB devices


It’s been 2 days that I’m on the virtualization of Windows with VirtualBox and I break my nose on USB devices.
They are not recognized in USB tab.

I’m on VirtualBox 6.1.30 and I managed (not without pain) to install the extension package for that version (from AUR - with the official package I am asked for a password that I do not know).
I also installed the VirtualBox-Guest-ISO and VirtualBox-Guest-Utilities packages, I added myself in the VBoxusers group and restarted the machine.

The USB 2.0 and USB 3.0 options finally appeared but no device appears. I also tried to connect only once the VM launched but nothing is detected.

What did I forget?

1 Like

I read that link and paid attention to the shared folder section as mentioned but my problem is to use USB devices, i don’t wanna share folders.

You should have paid attention to section 5. Advanced Guest Configuration


Attach a device

Access the DevicesUSB menu in VirtualBox Machine Window or USB menu item in the status bar. Select the USB device to mount in the virtual machine.
:warning: USB devices

I’m not sure to be understood, that’s the issue i’m posting for: there’s no devices in that tab.

but you can select an empty filter
which matches every device
or, the second option, a filter for a specific device

So I just add empty filters and restart the VM?

… not filters (plural) - a filter
then apply and you should be good to boot the VM
or take the second option and select your host USB bus
or plug in your device - it will then appear in the filter list and you can add that one specifically …

If i plug a device it doesn’t appear.
I tried to put a filter, no luck.

I can’t do it either: “No device available” is greyed when i click on the second option.

you are member of the vboxusers group?
modules are loaded?

Settings → USB tab
enable the checkbox “Enable USB Controller”
select either USB 2.0 or USB 3.0
then you should be able to add a filter from the row of little icons below and right of that

If that does not work
you need to re-check your whole installation procedure, retrace your steps
virtual box and the host modules corresponding to the kernel version you are running on
then the extension pack - without it you’ll only have USB 1.1

the version of this one is critical - it should match the virtualbox version
This can be a problem in Manjaro, where the virtualbox may be a lower version than the host modules available from the AUR!

The VM inside virtualbox does actually work?



As stated earlier the options are available since i installed the pack (same version than Virtualbox). It even appears in the Extension Tab with the right version number in Settings.

Is there anything command that would allow me to troubleshoot this? I already gave all the details in the OP and it really doesn’t work like that. Hence my post.

I was just making sure - sorry for the noise!

Nothing I know of.
The only thing that I could find quickly was the recommendation to boot the windows machine and let it sit a while to autodetect the virtualized USB ports and install drivers for it.

But that doesn’t seem to be the problem, rather the host USB is not picked up by virtualbox for some reason.
I would like to, but I really don’t … know.

Thanks for your help, i’ll wait if someone comes around here with an idea. I was sweating a bit to install the VM and now i bump into this without any idea what to do… frustrating.

You might need to wait until the update gets to your branch (6.1.32 is currently in unstable). Seems to be a known issue.

Do you mean i should wait that 6.1.32 arrives in Stable or can i try to install it now?

EDIT: i upgraded to 6.1.32 but not all packages have a 6.1.32 version yet.

linux515-rt-virtualbox-host-modules 6.1.30-3
linux515-virtualbox-host-modules 6.1.30-12
virtualbox-bin 6.1.32-1
virtualbox-bin-guest-iso 6.1.32-1
virtualbox-ext-oracle 6.1.32-1
virtualbox-ext-vnc 6.1.30-3
virtualbox-guest-utils 6.1.30-3

What a mess to just use USB devices…

You don’t need theses


Try upgrading the linux515-virtualbox-host-modules to the latest version in unstable so you don’t have to wait,here is one on the repo

Install it,also add yourself to the vboxusers group

sudo gpasswd -a $USER vboxusers

reboot and check if your usb devices are recoginzed,

1 Like

Thanks for your help.
I did install [linux515-virtualbox-host-modules-6.1.32-1 and checked again i was in the the group.
After a reboot i have a message that says " failed to load kernel modules".
When i check i have this return:

systemd-modules-load.service - Load Kernel Modules
     Loaded: loaded (/usr/lib/systemd/system/>
     Active: failed (Result: exit-code) since Thu 2022-01-20 06:45:3>
       Docs: man:systemd-modules-load.service(8)
    Process: 244 ExecStart=/usr/lib/systemd/systemd-modules-load (co>
   Main PID: 244 (code=exited, status=1/FAILURE)
        CPU: 238ms

jan 20 06:45:31 matmat systemd-modules-load[244]: Failed to insert m>
jan 20 06:45:31 matmat systemd-modules-load[244]: Failed to insert m>
jan 20 06:45:31 matmat systemd-modules-load[244]: Failed to find mod>
jan 20 06:45:31 matmat systemd-modules-load[244]: Failed to find mod>
jan 20 06:45:31 matmat systemd-modules-load[244]: Failed to insert m>
jan 20 06:45:31 matmat systemd-modules-load[244]: Failed to insert m>
jan 20 06:45:31 matmat systemd-modules-load[244]: Failed to insert m>
jan 20 06:45:31 matmat systemd[1]: systemd-modules-load.service: Mai>
jan 20 06:45:31 matmat systemd[1]: systemd-modules-load.service: Fai>
jan 20 06:45:31 matmat systemd[1]: Failed to start Load Kernel Modules>

Impossible to load the modules with a sudo modprobe vboxdrv.

The good point is that i can now see the USB devices in the tab within Virtualbox … but i cannot launch it anymore.

I think you need all the others linux515 packages to get the modules working,for example if you run this it will output all the linux515 packages thats need upgraded (compare it with Branch Compare)

pacman -Q | grep linux515

If you want,you can switch to unstable branch,update the system so you can get all the updated packages at once and then return to stable branch so you don’t have to deal with upgrading single packages and be in a partial-upgrade system.

You can switch to unstable with

sudo pacman-mirrors --api --set-branch unstable

Then do a upgrade

sudo pacman-mirrors --fasttrack 5 && sudo pacman -Syyu

You can also do a backup with Timeshift in case something happens you can rollback to the stable branch you were before.

After update,reboot and now with the upgraded linux515 packages,the kernel modules should be loaded fine,meaning virtualbox should run now,you can switch to stable branch if you want.

1 Like

I don’t understand why i should upgrade all the system when switching to unstable.
Can’t I just switch to unstable and upgrade only the linux515 packages?
I don’t have enough disk space to use Time Shift at the moment.