Virtualbox cannot load but can recognise USB

gnome
virtualbox

#1

I use Manjaro Gnome with the latest update. I installed Windows 7 Starter Edition (32bit) as my VM.

I installed the Extension Pack from AUR repositories and add the user-name to the vbox user group, then rebooted, as shown in this Wiki: https://wiki.manjaro.org/index.php?title=VirtualBox.

However, Virtualbox cannot load but can recognise my USB devices. In the Virtualbox USB setting I couldn’t select which USB type to use as they were grey out. The USB driver installation on my VM also failed.


I tried several USB devices and they all have this problem. The same problem also happened several days ago when I ran a Windows 10 VM. So I think it’s not the problem with USB or Windows editions.

Here is my system output if it’s needed:

System:
  Host: js_f Kernel: 4.19.6-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 
  Desktop: Gnome 3.30.2 wm: gnome-shell dm: GDM 3.30.2 Distro: Manjaro Linux 
Machine:
  Type: Laptop System: Dell product: Latitude 5250 v: N/A serial: <filter> 
  Chassis: type: 9 serial: <filter> 
  Mobo: Dell model: 0HMFMD v: A00 serial: <filter> UEFI: Dell v: A14 
  date: 12/26/2016 
Battery:
  ID-1: BAT0 charge: 23.4 Wh condition: 26.2/38.8 Wh (68%) volts: 12.0/11.4 
  model: Samsung SDI DELL R5MD0D9 type: Li-poly serial: <filter> 
  status: Discharging 
CPU:
  Topology: Dual Core model: Intel Core i3-5010U bits: 64 type: MT MCP 
  arch: Broadwell rev: 4 L2 cache: 3072 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 16766 
  Speed: 798 MHz min/max: 500/2000 MHz Core speeds (MHz): 1: 798 2: 798 
  3: 798 4: 798 
Graphics:
  Device-1: Intel HD Graphics 5500 vendor: Dell driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:1616 
  Display: x11 server: X.org 1.20.3 driver: i915 compositor: gnome-shell 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 5500 (Broadwell GT2) 
  v: 4.5 Mesa 18.2.6 compat-v: 3.0 direct render: Yes 
Audio:
  Device-1: Intel Broadwell-U Audio vendor: Dell driver: snd_hda_intel 
  v: kernel bus ID: 00:03.0 chip ID: 8086:160c 
  Device-2: Intel Wildcat Point-LP High Definition Audio vendor: Dell 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:9ca0 
  Sound Server: ALSA v: k4.19.6-1-MANJARO 
Network:
  Device-1: Intel Ethernet I218-LM vendor: Dell driver: e1000e v: 3.2.6-k 
  port: f080 bus ID: 00:19.0 chip ID: 8086:15a2 
  IF: eno1 state: down mac: <filter> 
  Device-2: Intel Wireless 7265 driver: iwlwifi v: kernel port: f040 
  bus ID: 02:00.0 chip ID: 8086:095a 
  IF: wlp2s0 state: up mac: <filter> 
Drives:
  Local Storage: total: 119.24 GiB used: 29.78 GiB (25.0%) 
  ID-1: /dev/sda vendor: Samsung model: SSD PM851 2.5 7mm 128GB 
  size: 119.24 GiB speed: 6.0 Gb/s serial: <filter> rev: 8D0Q scheme: GPT 
RAID:
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci 
  v: 3.0 port: f060 bus ID: 00:1f.2 chip ID: 8086.282a rev: 03 
Partition:
  ID-1: / size: 108.46 GiB used: 28.43 GiB (26.2%) fs: ext4 dev: /dev/sda2 
  ID-2: swap-1 size: 8.25 GiB used: 1.34 GiB (16.3%) fs: swap dev: /dev/sda3 
Sensors:
  System Temperatures: cpu: 45.0 C mobo: 37.0 C sodimm: 34.0 C 
  Fan Speeds (RPM): cpu: 0 
Info:
  Processes: 270 Uptime: 15h 46m Memory: 3.75 GiB used: 2.61 GiB (69.6%) 
  Init: systemd v: 239 Compilers: gcc: 8.2.1 Shell: bash v: 4.4.23 
  running in: gnome-terminal inxi: 3.0.27 

#4

That’s a common problem with Virtualbox - all explained in the Arch wiki on the subject - just search for “USB” here:
https://wiki.archlinux.org/index.php/VirtualBox#Accessing_host_USB_devices_in_guest


#5

Because your virtual machine was running … Stop the VM and then make the changes. Usually USB2 is the best choice :wink:


#6

Thanks! The solution is actually much easier than I expected.